Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

PDF won't open

  • 11 trả lời
  • 70 gặp vấn đề này
  • 13932 lượt xem
  • Trả lời mới nhất được viết bởi Trinbagonian

more options

This just started a few months ago. I cannot open a PDF from a search engine with FF (version 22). I click on a link (PDF) and FF opens a blank tab. I have searched Options-Applications-Search for PDF, and nothing comes up. However, in the applications tab, I can see Adobe Reader (default). PDF opens just fine with IE 10 and Google Chrome. I have read through all of the other posts regarding this issue, and I have tried the advice there to no avail. Can someone please help me? Thank you!

Tất cả các câu trả lời (11)

more options

Hello,

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps:

  1. Go to Tools > Options (or Firefox > Options).
  2. In the Options window, select the Applications tab.
  3. In the Search field, type PDF. You should find Portable Document Format (PDF).
  4. On the right handside you should find an Action column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose Preview in Firefox.

Did this fix your problems? Please report back to us!

Thank you.

more options

When I type in PDF, nothing shows up.

more options

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

more options

Cor-el,

I tried all of those, and still nothing. Any other advice?

Thank you!

more options

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

These steps didn't really work for me. I don't understand why Firefox used to just open PDFs. Chrome, IE and Safari just open without the need to configure a PDF add-on, or make some special steps. Firefox should just work by default.

more options

I am using FF 23.0.1 & have set all the pdf options to the external AcroRd (V 11.0.3.37) - it STILL doesn't work. A good workaround - paste the URL into Chrome ;-] That works perfectly!

more options

Amitshare and Cor-el: None of your solutions work. I am having the same problem as the other users (using Firefox 23.0.1) A couple of months ago I would put the address of the PDF in the address window, click go to in Firefox and the PDF would always come up and display. It no longer does this. Something has changed in the current version of the application which now prevents this. There does not appear to be a work around. (And even if there is a workaround it makes Firefox useless. If one wants another party to view one's PDF in Firefox one would have to inform that party and all others to implement that workaround!!)

more options

This discussion continued here: PDF addresses not longer load and display PDF in Firefox and solutions suggest to other users with problem DON'T WORK (work fine in Chrome and Safari). => One of the problems was the PDF Download extension was preventing any access to PDFs. After disabling that, the next problem was that the built-in PDF Viewer doesn't handle some of the content correctly.

more options

Change the default reader to adobe(in firefox) rather than preview in firefox

more options

Hi! I've only just registered although I've used FF for YEARS! The problem of a "blank" page coming up in FF (26?) but NOT in IE was driving me batty for months. I tried some of the (least!) technical previous solutions but without success - I'm afraid I get a bit lost if it gets beyond "go to page ... and check box ..." - yep, SHAME ON ME! Anyway, YOU'VE JUST SOLVED MY PROBLEM - THANKS EVER SO MUCH!!