Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

I can no longer get "save link as" to work, how do I fix this?

  • 6 trả lời
  • 4 gặp vấn đề này
  • 3583 lượt xem
  • Trả lời mới nhất được viết bởi MintShard

more options

With Firefox 16 (and all previous versions) if I were to right click a direct file link, such as a dropbox mp3, and select "save link as" it would save the mp3 to my computer. Now, however, in Firefox 17 all it does is save the link itself as a several kilobyte html file called "redirect". Other than basic updates of Firefox and all presently installed add-ons, nothing has been changed between when it last worked and now.

Giải pháp được chọn

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (6)

more options

Giải pháp được chọn

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

more options

Thank you for the quick reply, unfortunately things have gotten very confusing. I did what you said and went into safe-mode and it worked, links were no longer saved as html's. Then I started re-enabling things, started with the theme, then download statusbar, then the WOT extension, then downloadhelper, and that's when it started doing the html thing again. One would assume this meant downloadhelper was to blame, but when I disabled it again, html didn't go away. In fact, now it does it in safe mode as well. I'm very confused...

Edit: After restarting my computer safe mode worked to fix it again. I re-enabled everything except for downloadhelper and it worked! So currently there is a compatibility issue with downloadhelper 4.9.12 in firefox 17.0 that causes "save link as" to not work properly.

Được chỉnh sửa bởi MintShard vào

more options

Do (or did) you have automatic conversion enabled in the DownloadHelper extension?

You can also try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

more options

No I did not have automatic conversion enabled.

What would deleting the mimeTypes.rdf do? Will it affect any of my other settings or extensions?

Được chỉnh sửa bởi MintShard vào

more options

Deleting mimeTypes.rdf will remove all download file actions as seen in Tools > Options > Applications

You can rename the file (e.g. mimeTypes.rdf.sav), then you can undo this if it didn't help.

more options

Ok, I tried deleting the mimeTypes.rdf file but I still encountered the same problem when downloadhelper is enabled.