Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

google toolbar does not work with firefox 5.0. why not!

  • 56 trả lời
  • 3835 gặp vấn đề này
  • 1775 lượt xem
  • Trả lời mới nhất được viết bởi DaaBoss

more options

google toolbar does not work and will not download to firefox 5.0.

Moderator edit - 07-23-2011
The Google Toolbar "will not be supported on Firefox 5 and future versions."
http://googletoolbarhelp.blogspot.com/2011/07/update-on-google-toolbar-for-firefox.html

http://www.google.com/support/toolbar/bin/answer.py?answer=1342452&topic=15356%29

Được chỉnh sửa bởi the-edmeister vào

Giải pháp được chọn

The GTB 7.1.20110512W version works in Firefox 5.0 by using the Compatibility Reporter extension, I tried it myself due to the large number of postings about the GTB this morning.
https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

Đọc câu trả lời này trong ngữ cảnh 👍 98

Tất cả các câu trả lời (20)

more options

Thats because the old installed version of googletoolbar has a file named install.rdf that declares the max supported version of firefox to be 4.0.

To fix this ,just open the install.rdf file with notepad and change maxVersion from 4.0.* to 6.* (see the image i've also uploaded)


Now, in order to find the correct install.rdf file do the following:

Go to folder : C:\Users\[your user name here]\AppData\Roaming\Mozilla\Firefox\Profiles\[sometext].default and search for the install.rdf file (im using windows 7)

Windows search will find many install.rdf files (one for each addon you have installed on firefox) so make sure that you find the install.rdf that has the line

Google Toolbar for Firefox

in it. For this install.rdf file just rename the max version as stated above , restart firefox..and vualla! Google toolbar is back!

Được chỉnh sửa bởi Alexandros T. vào

more options

OK clever

but for everyone else - it needs to happen without messing about. Think about it.

And for info, in French it is

"et voila !" or, "and there it is"

Ok? Smart arse?

more options

You should be talking to Google.

more options

Thanks for the spelling correction francis.

Its not a clever solution, its a technical solution that is meant to be quick and dirty. If you desperately need the toolbar apply the fix, else its a matter of time until google team uploads an update that will support firefox 5.

Cheers

more options

Giải pháp được chọn

The GTB 7.1.20110512W version works in Firefox 5.0 by using the Compatibility Reporter extension, I tried it myself due to the large number of postings about the GTB this morning.
https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

more options

Dear A. Joom: Thanx for the excellent quick fix. :-)

more options

Thanks A.Joom! Worked geat for me. I had to do a bit of searching for the correct file since I have XP. For anyone with XP, best is to do a right click on C:\Documents and Settings\[your user name here]\Application Data\Mozilla folder and click on Search... and write install.rdf in the top search window and click on Search. Some install.rdf files will show up in folders easily identifiable to various software or apps, some not. You have to open (with notepad) each install.rdf file not easily identifiable to a particular app and find the one that has the Google Toolbar for Firefox line. Once you've got the correct install.rdf file, change, like A.Joom says, the maxVersion from 4.0.* to 6.* and close it and save it and restart Firefox. Actually, I did a reboot of my computer and now my GTB is showing up ok, but a simple restart of Firefox might have worked also, I guess. The few bugs that might show up with the GTB restored this way should be resolved with the installation of the next versions of the GTB. Hopefully.....

and ps: btw, francis_lucey, if you want to be pointy, your "voila" requires a grave accent on the a like so: "voilà".

Được chỉnh sửa bởi aildoux vào

more options

Works perfect. Thanks

more options

Woo Hoo

more options

Very good technical and quick work around!

more options

Thanks, it's WORK!!

more options

Hello! I am following the procedure, i manage to see all the install.rdf but cannot find the one that has the line Google Toolbar for Firefox in it. !

help please!

more options

Great article!!! it's good work for me, thank you so much.

more options

@a.joom or anyone who can help me.

Hi - Im using Windows 7 and when I follow the path, it is not the same. I get C:\users\ and then I only have 2 choices: family laptop or Public. I opened both of these looking for "AppData" but neither have it. Where should I go from here? Is there a different path I should take for Windows 7? Help.

Thanks so much!

more options

I notice that the compatibility address you've posted is for en_us - which I assume means english language, USA? I live in the UK. Do I alter it to read en_uk? and will it work?

more options

Running win 7 64 and do not have the file install.rdf in the specified directory. Any suggestions?

more options

I did this:

"You have to open (with notepad) each install.rdf file not easily identifiable to a particular app and find the one that has the Google Toolbar for Firefox line. Once you've got the correct install.rdf file, change, like A.Joom says, the maxVersion from 4.0.* to 6.* and close it and save it and restart Firefox. "


However, I dont know how to get all the install.rdf files back to "Open with unknown application" as they all were before.

more options

Do NOT mess with the .rdf files, that's hacking, just install the compatibility reporter mentioned above and restart Firefox twice.

more options

Is there any solution for mac OS?

more options

a.joom's hint worked for me on XP with the following modification: On XP, install.rdf was found in C:\Documents and Settings\All Users\Application Data\Google\Toolbar for Firefox\{3112ca9c-de6d-4884-a869-9855de68056c}. Note *All Users*. I then used Notepad to open install.rdf, changed 4.* to 6.* (5.* would probably work too!), saved it, then quit Firefox and restarted, and the Google toolbar displayed just fine.

Thanks. a.joom!

  1. 1
  2. 2
  3. 3