Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox browser force search

more options

I created a few virtual hosts and sites on my local machine and this is working perfectly.

Problem is with Firefox, when I enter non-existant url in address bar, Firefox force me to search and don't let me to open the url, but I need to go to this url for testing, developing, etc...

Any solution?

I created a few virtual hosts and sites on my local machine and this is working perfectly. Problem is with Firefox, when I enter non-existant url in address bar, Firefox force me to search and don't let me to open the url, but I need to go to this url for testing, developing, etc... Any solution?

Giải pháp được chọn

jscher2000 - Support Volunteer said

You say non-existent -- from Firefox's perspective -- but they do exist as local DNS entries on your system? And I assume not in a hosts file? By default, Firefox prefers DNS over HTTPS, but can fall back to a local lookup. If your DNS service is dishonest about not having the address, it may divert you to a "search" page of paid links. As a starting point, you could disable DNS over HTTPS and see whether that makes any difference in Firefox's ability to resolve your local addresses: Firefox DNS-over-HTTPS.

Thanks for the reply.

Actually, domain I am using exist in hosts file. Domain is working and some pages are working, but there is a few links that I just can't open. I type on purpose wrong page at domain, firefox force me to search, and don't open the link as expected.

Thanks for the link https://support.mozilla.org/en-US/kb/firefox-dns-over-https

Firefox DNS-over-HTTPS is not what I used, but I used "Excluding specific domains" part and excluded domain I am using localy, now everything is working and I can finally use Firefox to continue working on my app.

Thank you a lot!

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

See if this help as they talk about incorrect url configuration.

https://support.mozilla.org/en-US/questions/1176578

Hữu ích?

more options

You say non-existent -- from Firefox's perspective -- but they do exist as local DNS entries on your system? And I assume not in a hosts file?

By default, Firefox prefers DNS over HTTPS, but can fall back to a local lookup. If your DNS service is dishonest about not having the address, it may divert you to a "search" page of paid links.

As a starting point, you could disable DNS over HTTPS and see whether that makes any difference in Firefox's ability to resolve your local addresses: Firefox DNS-over-HTTPS.

Hữu ích?

more options

Giải pháp được chọn

jscher2000 - Support Volunteer said

You say non-existent -- from Firefox's perspective -- but they do exist as local DNS entries on your system? And I assume not in a hosts file? By default, Firefox prefers DNS over HTTPS, but can fall back to a local lookup. If your DNS service is dishonest about not having the address, it may divert you to a "search" page of paid links. As a starting point, you could disable DNS over HTTPS and see whether that makes any difference in Firefox's ability to resolve your local addresses: Firefox DNS-over-HTTPS.

Thanks for the reply.

Actually, domain I am using exist in hosts file. Domain is working and some pages are working, but there is a few links that I just can't open. I type on purpose wrong page at domain, firefox force me to search, and don't open the link as expected.

Thanks for the link https://support.mozilla.org/en-US/kb/firefox-dns-over-https

Firefox DNS-over-HTTPS is not what I used, but I used "Excluding specific domains" part and excluded domain I am using localy, now everything is working and I can finally use Firefox to continue working on my app.

Thank you a lot!

Hữu ích?

more options

Thank you for reporting back.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.