Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Bookmark folders don't always open on mouseover

  • 6 trả lời
  • 0 gặp vấn đề này
  • 26 lượt xem
  • Trả lời mới nhất được viết bởi willjoe24421

more options

Hi there,

I've got plenty of bookmarks organized in folders and sub-folders (never could wrap my head around using tags). Normally, hovering on top of a folder or sub-folder just opens it. However for some unknown reason, some folders just don't open on hovering. By contrast, opening the "Manage bookmarks" pane shows all bookmarks are there and functional. The issue only appears in the menus, and I'm not sure when it appeared exactly.

Already tried: Renaming faulty folders: no effect Moving bookmarks into a newly created folder: no effect Moving faulty folders into an already-working folder: works, except if the folder is the one containing the root menu.

Screenshots: A working sub-menu: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-24-be01e3.png

Two different, non-opening submenus: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-43-4a4bb1.png https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-50-615eee.png

How to solve this strange issue?

Hi there, I've got plenty of bookmarks organized in folders and sub-folders (never could wrap my head around using tags). Normally, hovering on top of a folder or sub-folder just opens it. However for some unknown reason, some folders just don't open on hovering. By contrast, opening the "Manage bookmarks" pane shows all bookmarks are there and functional. The issue only appears in the menus, and I'm not sure when it appeared exactly. '''Already tried: ''' Renaming faulty folders: no effect Moving bookmarks into a newly created folder: no effect Moving faulty folders into an already-working folder: works, except if the folder is the one containing the root menu. Screenshots: A working sub-menu: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-24-be01e3.png Two different, non-opening submenus: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-43-4a4bb1.png https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-01-10-56-50-615eee.png How to solve this strange issue?
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (6)

more options

Interestingly enough, the problem is still present on another Mac OS X computer running the same version of Firefox, but doesn't appear on Windows.

more options

An update: I set up a completely clean profile, synced to the previous one, and the bug reappeared!

more options

Still unsolved…

more options

You can possibly use the sidebar (Command+B) in case there is a problem with folders not opening on hover if you want to create a new bookmark.


This could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

more options

The Sidebar command does display the sub-folders without problems. And I just checked the database integrity; it's reported as sane.

Yet some shortcut folders still don't open on mouseover :(

more options

Click View in the Firefox menu bar at the top of the screen. Go down to the Toolbars menu and select Bookmarks Toolbar. Choose one of these settings: Always Show will show the Bookmarks toolbar on all pages. Never Show will hide it on all pages.

Regards, Will