Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

firefox wrongly flags video as geoblocked

  • 7 trả lời
  • 1 gặp vấn đề này
  • 16 lượt xem
  • Trả lời mới nhất được viết bởi Fraidy

more options

Hello Mozilla support

I wanted to view the video at this site -

https://www.daserste.de/information/reportage-dokumentation/dokus/videos/die-recyclingluege-video-102.html

(The site is German public TV)

Firefox (my default browser) says the video is geoblocked outside Germany, and my DNS proxy will not unblock it.

I tried again with Chrome browser, no problem, the video is not blocked, didn't need the DNS proxy.

Could this be a firefox problem? It seems bizarre - a small proportion of videos from the site are in fact geoblocked, most are available internationally. And always previously, whenever I encountered a blocked video, my DNS proxy would unblock it. But not for this video.

Any ideas as to what's going on?

Thanks, Fraidy . (Firefox 101.0.1 64 bit Windows 7)

Hello Mozilla support I wanted to view the video at this site - https://www.daserste.de/information/reportage-dokumentation/dokus/videos/die-recyclingluege-video-102.html (The site is German public TV) Firefox (my default browser) says the video is geoblocked outside Germany, and my DNS proxy will not unblock it. I tried again with Chrome browser, no problem, the video is not blocked, didn't need the DNS proxy. Could this be a firefox problem? It seems bizarre - a small proportion of videos from the site are in fact geoblocked, most are available internationally. And always previously, whenever I encountered a blocked video, my DNS proxy would unblock it. But not for this video. Any ideas as to what's going on? Thanks, Fraidy . (Firefox 101.0.1 64 bit Windows 7)

Tất cả các câu trả lời (7)

more options

Sounds like addon blocker is the issue. Did you try private mode window to see what happens.

Hữu ích?

more options

It plays for me here in the US. see screenshot Can you post a screenshot of what you are seeing? What are your proxy setting? Where are you?

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

Hello Dropa and jonzn4SUSE, thanks for replies. Dropa, I disabled my Adbock Plus, and set private window browsing, didn't work, the video is still blocked even with my proxy DNS. What do you get when you try and access the site - in Firefox? In Chrome?

jonzn4SUSE, that screenshot of yours is exactly what I'm getting, it is the standard blocking notification for this site. Translated, it reads " For legal reasons this video is not available in your country..."

(I'm in New Zealand)

The actual video is 75 Min long.

Can you unblock it with a proxy DNS?  What about with Chrome? For me, with Chrome it's not blocked at all.

I've emailed the site administrator to ask if that video is in fact officially blocked - haven't had a reply yet. I can't understand why Firefox and Chrome behave differently, the technology is all a bit beyond me... So, the problem is not solved yet, but thank again for replies.

Fraidy

Hữu ích?

more options

How is it a browser issue when all other browser show the same thing?

Hữu ích?

more options

Hello jonzn4SUSE, when you say "all other browser show the same thing?", do you mean you get the same result using Firefox and Chrome? ie. that same blocked notification screen that you posted?

The proxy DNS service is a paid service provided by Smart DNS Proxy (https://www.smartdnsproxy.com)

They can't help me with this problem - their support service is not great.

I'm still waiting to hear back from the site administrator, whether the video really is geoblocked. (My Firefox says yes, my Chrome says no )

Fraidy

Hữu ích?

more options

You can use websites like these to see how your location is reported via a reverse DNS look up of your IP:

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Hữu ích?

more options

Hello cor-el, thanks for your reply. I played around with some of that info you posted for me, but honestly, it's all a bit over my head. Every time I have to grapple with internet technology, I am reminded how little I actually know about it.

But - the problem has solved itself in rather an odd way. My ISP also provides my phone service, up to now an analogue phone. Now my ISP says I have to change to VoiP, which my old router doesn't support, so they've provided me with a new router. I set it up yesterday, and now everything works properly, including the way Firefox accesses that geoblocked video.

I have two internet connections, one uses the DNS provided by my ISP. If I use that connection, the video is geoblocked.

My other connection is set up to use the proxy DNS provided by "Smart DNX proxy". That connection successfully unblocks the video. Which is how things always used to be.

So the problem is fixed, I haven't the faintest idea how or why, but I don't really care , as long as everything stays working...

Thanks again for your reply - Fraidy

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.