Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox (win 7) Takes 15 Seconds To Load

  • 9 trả lời
  • 1 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi EddieC43

more options

I've been through the usual listed issues, refresh, disable add ons (only one), disabled AV, clear all history, passwords, etc. Checked that the latest update is installed. Have done malware and virus scans with no ill reports. This can't be normal. What else can I try to resolve it b efore moving on?

I've been through the usual listed issues, refresh, disable add ons (only one), disabled AV, clear all history, passwords, etc. Checked that the latest update is installed. Have done malware and virus scans with no ill reports. This can't be normal. What else can I try to resolve it b efore moving on?

Tất cả các câu trả lời (9)

more options

What version of Firefox? Have you tried Windows in Safe Mode? Turn on the computer and immediately begin pressing the F8 key repeatedly. From the Windows Advanced Options Menu, use the arrow keys to select Safe Mode, and press ENTER. The computer will automatically exit Safe Mode when it is shut down.

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

more options

FredMcD,

Starting in Troubleshoot mode cures it but how do I find the issue? I only have one add on which is AdBlock Plus.


Jonzn,

Also starting Windows in Safe Mode cured the lag, but again here, how do I find the issue?

more options

Firefox is 99.0.1

more options

What security software are you running? Disable it and see if it makes a difference.

more options

Running Avast AV only. Turned it off and there is no difference. I also tried Firefox in Troubleshoot safe mode that started immediately. I turned off the Ad Blocker and retried FF in normal starting mode and the startup lag persisted.

I saw the written suggestion to change the background theme to default but I never changed it from the original install and none of the backgrounds were called default. It is running "System Theme - Auto".

I have used Firefox for a long time over Chrome, but now it's gotten to be not worth the trouble because Chrome works without a hitch and this seems to be a dead end.

Được chỉnh sửa bởi EddieC43 vào

more options

EddieC43 said

Running Avast AV only. Turned it off and there is no difference. I also tried Firefox in Troubleshoot safe mode that started immediately. I turned off the Ad Blocker and retried FF in normal starting mode and the startup lag persisted. I saw the written suggestion to change the background theme to default but I never changed it from the original install and none of the backgrounds were called default. It is running "System Theme - Auto". I also did a fresh install prior to posting to the forum and that did not solve it. I might guess that this happened after the last update but I am not quite sure about the timing. I have used Firefox for a long time over Chrome, but now it's gotten to be not worth the trouble because Chrome works without a hitch and this seems to be a dead end.
more options

Uninstall Avast and test. I'm in Win7 and running ABP(see screenshot) with no Firefox start up issues. You already demonstrated by running Firefox and Windows in Safe Mode that the browser starts normally.

Được chỉnh sửa bởi jonzn4SUSE vào

more options

johzn, As I previously noted, turning off AV did not make a difference.

I had Avast and Firefox on for a long time and they worked fine together. Something happened recently that affected Firefox and all I and all I recall is Firefox update, but who knows.

It's just odd that starting in Troubleshoot start mode fixes it and turning off the one add on shown does not fix the issue. Something is not being reported in the Troubleshoot start mode that is apparently causing the problem when not using Troubleshoot mode.