Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Help to Permanently Disable Full-Screen Mode... Forever

  • 7 trả lời
  • 1 gặp vấn đề này
  • 26 lượt xem
  • Trả lời mới nhất được viết bởi Unwilling Passenger

more options

I am NOT a fan of this relatively new Full-screen mode at all unless I initiate it when watching a movie or in very few other instances. I don't like any device second-guessing or anticipating what I need to do and when or if it needs to do this for me. It has caused me more problems than it has helped, and injected some frustrating delays getting what I want done due to the added need and interruption of being paused to constantly press F11 again and again. It's not second nature and at this point, I don't think it will be. I don't need or want this feature and I don't understand this new world where features have to be nailed down and locked now with the "like it or lump it" mentality without option to remove or disabled this? (Sorry, I don't like MS Edge either, and not only for this reason!) I would be happy to go back to a previous version of Firefox that is without this feature, if this is the only answer. I'm hoping it is not?

There was a previous very brief post on here that directed users to go to about:config and set full-screen-api.enabled to false in order to disable this feature, but no one positively confirmed that it worked and the thread was closed. This doesn't appear to be working for me with the most current version of Firefox.

Is there someone who can help give me peace in my life again by showing me how to disable this permanently and forever? I know about F11 and don't ever want to have to press it again! I would appreciate any help, and you might even make my Christmas list if it works?

Thanks!

I am NOT a fan of this relatively new Full-screen mode at all unless I initiate it when watching a movie or in very few other instances. I don't like any device second-guessing or anticipating what I need to do and when or if it needs to do this for me. It has caused me more problems than it has helped, and injected some frustrating delays getting what I want done due to the added need and interruption of being paused to constantly press F11 again and again. It's not second nature and at this point, I don't think it will be. I don't need or want this feature and I don't understand this new world where features have to be nailed down and locked now with the "like it or lump it" mentality without option to remove or disabled this? (Sorry, I don't like MS Edge either, and not only for this reason!) I would be happy to go back to a previous version of Firefox that is without this feature, if this is the only answer. I'm hoping it is not? There was a previous very brief post on here that directed users to go to about:config and set '''full-screen-api.enabled''' to '''false''' in order to disable this feature, but no one positively confirmed that it worked and the thread was closed. This doesn't appear to be working for me with the most current version of Firefox. Is there someone who can help give me peace in my life again by showing me how to disable this permanently and forever? I know about F11 and don't ever want to have to press it again! I would appreciate any help, and you might even make my Christmas list if it works? Thanks!

Tất cả các câu trả lời (7)

more options

Hello! When you set full-screen-api.enabled to false, did you try clicking Clear startup cache..., in the about:support? See if it'll work.

If websites automatically enter full-screen mode on it's own, try: Go to about:config>> Search permissions.fullscreen.allowed>> If it says true, set it to false

Did it help?

more options

Thanks for the reply! But, it's already set to False and clearing cache did not help.

Được chỉnh sửa bởi Unwilling Passenger vào

more options

That's a very good idea! But, I am not allowed to attach or post pictures here. Uploading images never finishes uploading.

The 3 different modes that I see are described below, all from the Google.com homepage.

1. "full screen" mode hides the entire top part of the page, the navigation and header. At the google.com page, all I see is a gear icon in the top right corner.

2. If you move the cursor to the top of the display when "full screen" mode is engaged, it unhides part of the header information, including the hamburger and the same gear icon just below this in the browsing area. But not any bookmark or other information to display. It gives basic header info.

3. After pressing F11 to disengage full screen and go back to regular mode, this shows the full display again and is where I would like it to stay all the time.

Most of my troubleshooting was on Firefox 98. I'm running Firefox 99 (64-bit) now and also used the about:support option recommended above to reset data again, and nothing changed. The Firefox version shows Up-to-date.

My machine was purchased last November from Dell website, XPS-8940 Desktop, 32GB RAM, 1TB SSD, NVidia 1660 SUPER graphics, 34" curved Dell Display. I removed Windows 11 and am running a clean install of Windows 10.

more options

Hiding the Navigation Toolbar and Tab bar is quite normal when you are in "3-bar" Firefox menu button. If you hover the mouse to the top of the screen then Firefox should show the toolbars automatically. Once you have the toolbars visible then you can right-click free space or the "3-bar" Firefox menu button and disable the auto-hide feature (remove the checkmark).

When you are in Full Screen Mode, hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. You can use one of these to leave Full Screen Mode:

  • press the F11 key
  • click the Maximize button at the right end of the Tab bar
  • click the Full Screen button in the "3-bar" Firefox menu button drop-down list
  • right-click empty space on a toolbar and click "Exit Full Screen Mode"
more options

Thanks, but as mentioned in my original post, I don't want to ever press F11 and I want Firefox not to hide anything and to leave my display alone! I want to remove this feature so F11 does nothing to the browser unless I map it to do something.

Được chỉnh sửa bởi Unwilling Passenger vào

more options

Firefox wouldn't automatically enter full screen mode. You would have to press the F11 key or click a toolbar button or Full Screen in a menu drop-down list. Some webpages also have a button to switch to Full Screen Mode by using the Full Screen API. To prevent that you can disable this API via the about:config page (full-screen-api.enabled = false), but then you won't be able to view videos in full screen mode.

Được chỉnh sửa bởi cor-el vào

more options

It could quite well be me, but I've seen others complaining about movie websites and other places where it pops into this mode. This is the type of behavior I'm seeing. It's also a problem on some websites that also use F11 for gaming. But, the bottomline is, I don't like it and don't see why anyone would force the feature globally and not have a way to disable it so that key presses don't re-enable it? It's maddening!

Also, as you can see, I started this thread because I have the about:config setting as you have stated it would need to be in order to disable this feature, but it is not disabling this feature permanently. F11 still enables it.

Is there another way you know of to disable this feature permanently?

Được chỉnh sửa bởi Unwilling Passenger vào