Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox does not connect to "google.de" or "amazon.de" do to "HTTP Strict Transport Security (HSTS)"

  • 6 trả lời
  • 1 gặp vấn đề này
  • 17 lượt xem
  • Trả lời mới nhất được viết bởi gimmeshelter

more options

Firefox does not connect to "google.de" or "amazon.de" do to "HTTP Strict Transport Security (HSTS)". First I cleaned the "Firefox" (about:config). Then I deinstalled and reinstalled it. No change in behavior. I started with an empty "SiteSecurityServiceState.txt" Anyway still no connection possible to "google.de" or "amazon.de". I would be glad if anyone could help me.

BS is WIN10 Version 20H2 (Version 21H1 could not be loaded yet --> mistake while installing. I am still waiting for a solution to this problem via MS)

Sorry for my humble English.

Giải pháp được chọn

Hi Jscher, that did it. You were perfectly right. "No proxy", and the connection works again. Thanks a lot!!!

gimmeshelter

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

It looks like your security software has replaced a certificate for these websites to spy on your secure browsing.

Hữu ích?

more options

Using "Chrome" or "Edge" doesn't show this behavior. Amazon and Google are reachable under these browsers, guarded by the same security software. I use Symantecs "SEP" by the way.

Hữu ích?

more options

Hi gimmeshelter, on the error page saying that Firefox did not connect, could you click the "Advanced" button. That section has at least two useful bits of information:

(1) Error code

Many of these are covered in the following article: How to troubleshoot security error codes on secure websites

(2) "View Certificate" link

This opens a page with details on the certificate that Firefox cannot verify as valid. Typically the best clues are in the Issuer/Issued by section where you may spot a link to particular software.

For https://www.google.de/ I have "Common Name: GTS CA 1O1"

For https://www.amazon.de/ I have "Common Name: DigiCert Global CA G2"

Hữu ích?

more options

Hi jscher, Fehlercode: SEC_ERROR_UNKNOWN_ISSUER The error code is: https://www.google.de/

Der Zertifikat-Aussteller der Gegenstelle wurde nicht erkannt. (The certificate issuer of the remote terminal was not recognized.)

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Zertifikatskette:

-----BEGIN CERTIFICATE-----
MIIDbjCCAlagAwIBAgIQZycJoHnYb5pDb44p32knnjANBgkqhkiG9w0BAQsFADAj
MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMjAwNjA3MjA1
NTA5WhcNMzEwNjA3MjI1NTA5WjAYMRYwFAYDVQQDDA13d3cuZ29vZ2xlLmRlMIIB
IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEApeHMT4wTZLgtWZQk+0v7xsUL
X0XuamFFLOxnBIFYfxdgpCSPyGlR0Oxgdp/DjLAH5lXycdQLiBTkmNs7qvE1vNAY
H2ANQ7jVG/kU5clmprYViCsW89+XgMF6hqeNdLd8P4GTXDvuNeqnexiOgnDb2VjL
VQlbp1OrYCZ6QBw4MQmMvlfqsOTYsPNwqW46Q/bxqFjCDShtWi1v5kwHX1H6Zgey
aPrHFng3VteG5T0af1B3Hy2P0HcaENNqWSY+QPqGm+3mXAhg++PL18LW3JP7uYGJ
dOXdUKVoSoZ7WuPgkU4Jb7YabWj+Crsu54LiS3yg8rwyu5XeWJntyQ+h5IjATQID
AQABo4GoMIGlMBMGA1UdJQQMMAoGCCsGAQUFBwMBMAwGA1UdEwEB/wQCMAAwDgYD
VR0PAQH/BAQDAgWgMDAGA1UdEQQpMCeCDXd3dy5nb29nbGUuZGWCCyouZ29vZ2xl
LmRlgglnb29nbGUuZGUwHwYDVR0jBBgwFoAUxjiFh2+c/iG8Tb9j96NvvxskI4sw
HQYDVR0OBBYEFPjYohphhHyuWkpE/+feTekF5csvMA0GCSqGSIb3DQEBCwUAA4IB
AQB6y95dkB51dNS0g/7sAG1N2slVJshZSUtc5o3aZXJyRhI0mADdVx6HeV7dinTj
9SmYiI4HVYEuDXrdw1XNKUQhlh1B6itWXel8A3zIPIf4q8YMMB6aqBx9qnvL0xs2
f1Y+Jc+2YuKmaYhiorV/rvKvpQ1+g/KVmzvyQAkDOTfXb9lSOAhhxdWDwg9B7uQO
Au3qTQ3nI8IReMwASb/98bnOA4HrS09vxGMakUa0u24QR9YEjxJEannmZUMzRRrN
MaopEhqE2bdqpV8+iqtY54PIGba3p0C7JMMUw8cGn4udUXswCGcyPVwhabGLzoYL
Ck3vwHNhjB1yxoY3qrPXlInF
-----END CERTIFICATE-----

What can I do? Is there a way to import the google and amazon certificate?

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Thank you for the certificate, it shows:

Issuer Name = DigiCert Global Root G1A

This seems to be associated with a proxy, but in all the threads where I've seen it, no one has identified who that is. Either way, the usual workaround is:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Change to "No proxy"

Any difference?

Hữu ích?

more options

Giải pháp được chọn

Hi Jscher, that did it. You were perfectly right. "No proxy", and the connection works again. Thanks a lot!!!

gimmeshelter

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.