On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

FF89 (Proton UI) - Web Search on New Tab Only Runs From Address Bar

  • 2 trả lời
  • 1 gặp vấn đề này
  • 36 lượt xem
  • Trả lời mới nhất được viết bởi lmacri

more options

Since upgrading to FF89 (the new Proton UI) I've noticed a change in behavior when I try to perform a web search from a New Tab. When I try to type a search string in the Google search bar on a New Tab, any character I type immediately appears in the address bar (see attached image) and search suggestions are shown in a drop down under the address bar.

With FF88 (the old Photon UI) I could type my entire search string into the Google search bar and then hit "Enter" to start the search.

Is this a bug in the way that searches are performed from a New Tab in the Proton UI or a deliberate design change? Is there some setting I can change to stop the Proton UI from running my searches from the address bar when I search from a New Tab?

An image of my New Windows and Tabs settings is also attached, and my default search engine at Settings | Search | Search | Default Search Engine is set to Google. Note that I live in Canada and the custom URL for my Home Page is set to Google Canada (https://www.google.ca/), but any searches that runs from the address bar defaults to Google.com (e.g., https://www.google.com/search?client=firefox-b-d&q=<search string>).


Dell Inspiron 15 5584 * 64-bit Win 10 Pro v20H2 build 19042.985 * Firefox v89.0.0 * MS Edge v91.0.864.37 * Microsoft Defender v4.18.2104.14 * Malwarebytes Premium v4.4.0.117-1.0.1308

Since upgrading to FF89 (the new Proton UI) I've noticed a change in behavior when I try to perform a web search from a New Tab. '''When I try to type a search string in the Google search bar on a New Tab, any character I type immediately appears in the address bar''' (see attached image) and search suggestions are shown in a drop down under the address bar. With FF88 (the old Photon UI) I could type my entire search string into the Google search bar and then hit "Enter" to start the search. Is this a bug in the way that searches are performed from a New Tab in the Proton UI or a deliberate design change? Is there some setting I can change to stop the Proton UI from running my searches from the address bar when I search from a New Tab? An image of my New Windows and Tabs settings is also attached, and my default search engine at Settings | Search | Search | '''Default Search Engine''' is set to '''Google'''. Note that I live in Canada and the custom URL for my Home Page is set to Google Canada (https://www.google.ca/), but any searches that runs from the address bar defaults to Google.com (e.g., https://www.google.com/search?client=firefox-b-d&q=<''search string''>). -------- Dell Inspiron 15 5584 * 64-bit Win 10 Pro v20H2 build 19042.985 * Firefox v89.0.0 * MS Edge v91.0.864.37 * Microsoft Defender v4.18.2104.14 * Malwarebytes Premium v4.4.0.117-1.0.1308
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can turn it off by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

You can turn it off by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

more options

TyDraniu said

You can turn it off by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

Hi TyDraniu:

Thanks, that solved the problem.

Do you know if this advanced setting now has a default value of True in the new FF89 Proton UI, and is this a "regular" setting that can be changed from the Firefox interface (e.g., from Settings | Search) without going into about:config?


Dell Inspiron 15 5584 * 64-bit Win 10 Pro v20H2 build 19042.985 * Firefox v89.0.0 * MS Edge v91.0.864.37 * Microsoft Defender v4.18.2104.14 * Malwarebytes Premium v4.4.0.117-1.0.1308