Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox runs my GPU to overheat, even at idle? Why is it doing this?

  • 14 trả lời
  • 1 gặp vấn đề này
  • 15 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

I left my FF browser open by accident when I went to bed, no other applications were open. This morning I realized my GPU was sitting at 55c when I looked at the thermistor sensor in the hardware monitor report in precision X1.

As soon as i closed FF the temps went back to 25c in less than 1 minute.

So what is FF doing that consumes so much GPU even when idle?

I had a 2080TI GPU go bad two months ago after sitting idle overnight - now I know why - it was firefox using my GPU and overheating my system (even while not "appearently" doing anything).

I used to be a FF fan, but not anymore after losing a $1200 GPU due to the horrible programming that basically is making FF become a huge contributor to my electricity bill wearing out my hardware.

as of 2021 I am abandoning FF due to concerns of further damaging my PC.

Tất cả các câu trả lời (14)

more options

Also I should mention that I have "Use hardware acceleration when available" checkbox disabled. Because I use my GPUs for work and gaming and don't like other applications touching them or running background processes that consume GPU resources.

FF ignores this option?? Even with that checkbox off i see FF is grabbing the GPU and doing some processing with it, when I start firefox the GPU shows 0%, after I browse google for a minute of two then the GPU utilization kicks in, and then sometimes the GPU utilization just stays constant at some value until FF is closed (like last night) resulting in huge energy consumption and overheating GPU.

I also beta test FF nightly (without any addons) and this would happen there too! Even with hardware acceleration switched off! I think it's just badly written software or Mozilla is using my PC for other purposes ¯\_(ツ)_/¯

Được chỉnh sửa bởi tamed.phoenix vào

more options

Not saying I will ever come back to FF even if you fix, but here's a thought:

My PC was warm this morning, like a hundred extra watts warm. and ~250 million users use FF daily. So due to the careless programming techniques employed by mozilla and the way FF was written then possibly millions of other PCs are having their GPUs over utilized (during idle) resulting in hundreds of megawatt hours of wasted energy each day, Congratulations Mozilla, shows how much you care .

Wondering where all that energy goes?

Được chỉnh sửa bởi tamed.phoenix vào

more options

tamed.phoenix said

I left my FF browser open by accident when I went to bed, no other applications were open. This morning I realized my GPU was sitting at 55c when I looked at the thermistor sensor in the hardware monitor report in precision X1. As soon as i closed FF the temps went back to 25c in less than 1 minute. So what is FF doing that consumes so much GPU even when idle?

That's a good question. I can't recall seeing any other reports of this, so it is very curious, especially considering:

tamed.phoenix said

Also I should mention that I have "Use hardware acceleration when available" checkbox disabled.

If you test with Nightly again, do you notice any difference after toggling this setting (you might need to restart before it takes effect):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.webrender.force-disabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

more options
(2) In the search box in the page, type or paste gfx.webrender.force-disabled and pause while the list is filtered

Thanks for replying! I was not aware of the force disable parameter. I have configured it as you suggest. Hoping now my GPU will be safe from damage now!!

I feel bad for any other users who are having their GPUs wrecked.

Firefox Version: 70.0 (64 bit) PC specs: https://pcpartpicker.com/list/qqyFnH Nvidia Driver: Studio Driver v 461.72 2x GeForce RTX 2080 TI (not overclocked)

Được chỉnh sửa bởi tamed.phoenix vào

more options
(2) In the search box in the page, type or paste gfx.webrender.force-disabled and pause while the list is filtered

Thanks for replying! I was not aware of the force disable parameter. I have configured it as you suggest. Hoping now my GPU will be safe from damage now!!

I still feel bad for any other users who are having their GPUs overworked.

Here are my system specs: Firefox Version: 70.0 (64 bit) PC specs: https://pcpartpicker.com/list/qqyFnH Nvidia Driver: Studio Driver v 461.72 2x GeForce RTX 2080 TI (not overclocked)

Được chỉnh sửa bởi tamed.phoenix vào

more options
(2) In the search box in the page, type or paste gfx.webrender.force-disabled and pause while the list is filtered

Thanks for replying! I was not aware of the force disable parameter. I have configured it as you suggest. Hoping now my GPU will be safe from being damage again. It was not fun losing one of my GPU due to this!!

I still feel bad for any other users who are having their GPUs overworked.

Here are my system specs: Firefox Version: 70.0 (64 bit) PC specs: https://pcpartpicker.com/list/qqyFnH Nvidia Driver: Studio Driver v 461.72 2x GeForce RTX 2080 TI (not overclocked)

Được chỉnh sửa bởi tamed.phoenix vào

more options
(2) In the search box in the page, type or paste gfx.webrender.force-disabled and pause while the list is filtered

Thanks for replying! I was not aware of the force disable parameter. I have configured it as you suggest. Hoping now my GPU will be safe from being damage again. It was not fun losing one of my GPU due to this!!

I still feel bad for any other users who are having their GPUs overworked.

Here are my system specs: Firefox Version: 70.0 (64 bit) PC specs: https://pcpartpicker.com/list/qqyFnH Nvidia Driver: Studio Driver v 461.72 2x GeForce RTX 2080 TI (not overclocked)

more options

Oh, Firefox 70? WebRender was not enabled by default in release versions before Firefox 88 78. However, I think it has been enabled by default in Nightly for a long time. Hard to keep track.

I am suspicious that the activity could be a coin miner or other malware process attempting to conceal itself by running with Firefox. However, there are other tools to root out such things.

Được chỉnh sửa bởi jscher2000 vào

more options

After toggling this option: gfx.webrender.force-disabled there is still a noticable ramping of the GPU overnight only when using firefox.

This morning I saw again my GPU total power was sitting some constant value. As soon as I close firefox the GPU power goes to zero.

So firefox is still trying to destroy my GPU even though I am using your suggestions to completely disable the GPU.

if firefox is highjacked by miner trojan then how do I eliminate that? Why only firefox would be affected?

I kind of have feeling it's badly written software, because the constant power consumption levels are different each time, and only ~25% total GPU power usage. If it were infected firefox then wouldn't they use 100% of GPU??

How do I check if firefox is infected ?

more options

I notice if I visit https://forum.unity.com/ then GPU power ramps up to ~25% and just stays there. But if I visit https://stackoverflow.com/ then the GPU stays at zero.

If I close the tab for forum.unity.com then the gpu power goes back to zero.

If I visit forum.unity.com then visit stackoverflow.com the GPU power stays at 25%

^Something in firefox is getting stuck and is trying to heat up my GPUs.

I really don't wish to blacklist firefox but it is looking like this browser is just not very safe.

Được chỉnh sửa bởi tamed.phoenix vào

more options

I notice if I visit https://forum.unity.com/ then GPU power ramps up to ~25% and just stays there. But if I visit https://stackoverflow.com/ then the GPU stays at zero.

If I close the tab for forum.unity.com then the gpu power goes back to zero.

If I visit forum.unity.com then visit stackoverflow.com the GPU power stays at 25%

^Something in firefox is getting stuck and is trying to heat up my GPUs.

I really don't wish to blacklist firefox but it is looking like this browser is just not very safe.

more options

Just installed Firefox 88, still ramps my GPU to 25% and holds it there until I close the tab. This is ridiculous to think a web browser needs so much GPU even at idle.

I am blacklisting this program once and for all.

Được chỉnh sửa bởi tamed.phoenix vào

more options

You can check the Firefox Task Manager (about:performance) and about:memory pages.

Some menus have been rearranged in Firefox 87 and "Task Manager" has been moved to the Help menu.

more options

tamed.phoenix said

I notice if I visit https://forum.unity.com/ then GPU power ramps up to ~25% and just stays there. But if I visit https://stackoverflow.com/ then the GPU stays at zero. If I close the tab for forum.unity.com then the gpu power goes back to zero. If I visit forum.unity.com then visit stackoverflow.com the GPU power stays at 25%

So if you visit Unity in a tab, and you keep using that tab to visit other pges, GPU power stays high, but when you close the tab, it returns to normal. Hmm, Firefox has a feature called the "fast back-forward" cache that allows pages to be rendered more quickly if you use the Back and Forward buttons in a tab. Actually, I think all browsers have this, but their implementations probably are different. I wonder whether a page in the Fast BF cache, or some asset used by that page, could still be "running"? That would be strange, but at least it's a theory.

I wonder what is going on with that Unity forum page? It makes my laptop fan spin up, but there's no obvious explanation (no huge background videos playing, etc.).