Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Always allow... check box not respected for external links

  • 3 trả lời
  • 1 gặp vấn đề này
  • 3 lượt xem
  • Trả lời mới nhất được viết bởi jcrow

more options

Hi all,

We have an internal web application that uses an external application on our pc's to handle certain links.

After updating Firefox to version 8X it now continually asks to open these links. The Always allow... checkbox is not respected. Once checking the box it lasts for the period you have the browser open but as soon as you close Firefox and open again it will again prompt.

I tried renaming my handlers.json file and letting it be rebuilt to no avail.

Anyone know what he issue might be?

thanks

Giải pháp được chọn

Firefox 84 added a site-level perrmission to protocol links launching external applications. If Firefox loses your site approvals at shutdown, it could be due to:

  • using automatic private browsing ("Never remember history")
  • using "Clear history when Firefox closes" with "Site Preferences" ticked in the Settings dialog

I think other users have mentioned that this is the key setting to disable the new behavior:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste protocol and pause while the list is filtered

Scroll to the end of the list...

(3) Double-click the security.external_protocol_requires_permission preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (3)

more options

So is this broken in Firefox now?

Hữu ích?

more options

Giải pháp được chọn

Firefox 84 added a site-level perrmission to protocol links launching external applications. If Firefox loses your site approvals at shutdown, it could be due to:

  • using automatic private browsing ("Never remember history")
  • using "Clear history when Firefox closes" with "Site Preferences" ticked in the Settings dialog

I think other users have mentioned that this is the key setting to disable the new behavior:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste protocol and pause while the list is filtered

Scroll to the end of the list...

(3) Double-click the security.external_protocol_requires_permission preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hữu ích?

more options

Thanks for the reply jscher2000. Simply unchecking Data/Site Preferences in the Clear History options solved the problem!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.