Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox doesn’t change back to light mode after dark mode

  • 9 trả lời
  • 2 gặp vấn đề này
  • 103 lượt xem
  • Trả lời mới nhất được viết bởi Tu Ngo

more options

Has anyone experienced this issue?

I have set Firefox for macOS to use the default theme in which uses the system colours.

The system goes into dark mode without issue in Firefox, however, Firefox fails to go back to light mode when the system goes back. Currently it is the only application that I have this trouble with and I can not workout what the issue is.

Tried reinstalling Firefox.

I haven't heard anyone else having this issue so now wondering if there is something uniquely wrong with my system or set-up?

I would be grateful for any ideas

All Replies (9)

more options

acOS 10.15.4 + Firefox 75 and Firefox 77 At night there was the dark theme and Firefox was dark. Every morning when I turn on the mac, the system automatically has the light theme. I open Firefox (both, stable and nightly): it still has the dark theme. To change it I have to go to the system settings,

click on light theme (now Firefox "understands" to change to the light theme) and then
click again on automatic theme. However, it changes by itself to the dark theme......

It’s not just a problem with Firefox, other applications also have the same identical problem in switching from dark theme to light theme automatically. I think the reason is that when I change to the dark theme, Firefox is open, it assists live to the theme change

Helpful?

more options

Steps to reproduce:

  1. Update Mac OS to 10.15 (Catalina)
  2. Install Firefox Nightly and keep default theme
  3. Select "Automatic" theme in system preferences
  4. Firefox does not update itself to match the system theme

A good example is to switch from Dark theme to Automatic theme during the day (automatic will select the Light theme). Firefox won't update according to the system theme.

Actual results:

Firefox keep using the colour depending on the theme used before choosing the automatic mode.

Expected results:

Firefox should match the system theme when using automatic mode, the same way it does when switch between Light and Dark theme in system preferences.

Thank you!

Helpful?

more options

If I use a third party tool to control macOS darkmode such as NightOwl. Firefox’s default theme switches between light and dark modes automatically. This is what was confusing me. I am sure there is a bug somewhere.

The default theme does state that it uses the system theme colours.

Được chỉnh sửa bởi apc vào

Helpful?

more options

Nightowl App does not seem a viable alternative. You may think on NightOwl app to thange theme mode manually, but it changes it from always light to always dark, completely bypassing automatic setting, because it was designed to work in Mojave, not in Catalina, and Mojave does not have that automation. Also, there is a Bug under discussion for the same issue with themes, that you may want to check. Reference Link: https://bugzilla.mozilla.org/show_bug.cgi?id=1558086

Helpful?

more options

Yes sorry I meant that it manually changes it but NightOwl’s functionality can be automated Itself via time and geolocation data. I agree it’s not an alternative. Thank you for the issue link.

Helpful?

more options

Hi ARMAN KHAN

Thanks for the nice set of steps to reproduce (STR) and the other info. Please file a bug at bugzilla.mozilla.org with the STR and the other info.

Cheers!

...Roland

Helpful?

more options

The bug has already been raised and currently open at

Bug 1558086 10.15 Theme does not adapt to automatic dark mode on MacOS Catalina

Awaiting fix to retest

Được chỉnh sửa bởi apc vào

Helpful?

more options

Automatically match system theme When you switch your device to light or dark theme, Firefox will match your system theme by default. To change this:

1.Tap the menu button at the bottom of the screen (the menu will be at the top right if you're using an iPad): menu button ios 10

2.Tap Settings in the menu panel.

3.Tap Theme.

4.Tap the Use System Light/Dark Mode toggle (blue means it’s on).

Manually or automatically set themes You have the ability to manually or automatically set themes.

Tap the menu button at the bottom of the screen (the menu will be at the top right if you're using an iPad): menu button ios 10

Tap Settings in the menu panel. Tap Theme. Tap the Use System Light/Dark Mode toggle to turn it off (gray means it’s off). Tap an option from the Switch Mode menu: Manually: all theme changes will occur manually. Automatically: theme will match your screen brightness. Tap a theme from the Theme Picker menu: Light Dark Customize your theme’s brightness using the Threshold slider.

Helpful?

more options

I'm experiencing this issue with Firefox and Viber too, other apps mostly change automatically. To be detailed, my experience is as follow: - Set my Mac's theme to Auto, if I don't shut down my Mac, on the next day the apps' theme changes automatically. However, if I shut down my Mac at night, and turn it on next morning, Firefox's theme is still dark. It won't change until I change my Mac theme to Manual and switch back to Auto.

Được chỉnh sửa bởi Tu Ngo vào

Helpful?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.