Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How to stop URL bar from enlarging on click firefox 77

  • 7 trả lời
  • 5 gặp vấn đề này
  • 326 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

Hello I would like how to disable bar from enlarging .I see this do not works in firefox 77.After I update to 77 the Enlatging bar back.


   browser.urlbar.openViewOnFocus
   browser.urlbar.update1

Giải pháp được chọn

iikolor said

Yes this works but I see some problem with bar .I use 2 bars but one is a little low .
#urlbar[breakout],
#urlbar[breakout][breakout-extend] {
  --urlbar-height: 28px !important;
  --urlbar-toolbar-height: 30px !important;

  width: 100% !important;
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
}

Hi, I think you need to adjust the value for top: to something higher. Since you use the "normal" density layout, I think, you could try:

top: 5px !important;

and see whether that works for you.

I also have a rules file here if you want to compare: https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Đọc câu trả lời này trong ngữ cảnh 👍 2

All Replies (7)

more options

The original solution was for Firefox 75. Due to changes in Firefox 77, the original solution is obsolete and there are new options.

Firefox supports an optional style sheet file named userChrome.css that we can use to modify the toolbar area, including taming the expanding address bar. Setting up your first userChrome.css file is about a 10 minute project, so when you have time to dive in, here are some threads to check out:

  [[Type in the address bar about:config and press Enter. (ignore the warning)  Type in the search bar and look for the preference :  browser.urlbar.openViewOnFocus  and set its value to false  Do the same with these preferences :  browser.urlbar.update1 (already mentioned by jscher2000)  browser.urlbar.update1.interventions  browser.urlbar.update1.searchTips  Then close and restart Firefox.]] 
   https://support.mozilla.org/en-US/questions/1283911#answer-1303777
   https://support.mozilla.org/en-US/questions/1284030#answer-1304125
   https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler 

More background on userChrome.css files: https://www.userchrome.org/

Helpful?

more options

In Nightly, there is a specific preference for this in about:config called browser.urlbar.update1 (previously known as browser.urlbar.megabar).

Setting that to false will revert the bar to its more typical behavior in new windows (the windows that are already open seem to keep the megabar behavior until the next session).

For anyone unfamiliar:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.


3rd solution:-

The original solution was for Firefox 75. Due to changes in Firefox 77, the original solution is obsolete and there are new options.

Firefox supports an optional style sheet file named userChrome.css that we can use to modify the toolbar area, including taming the expanding address bar. Setting up your first userChrome.css file is about a 10 minute project, so when you have time to dive in, here are some threads to check out:

 [[Type in the address bar about:config and press Enter. (ignore the warning)  Type in the search bar and look for the preference :  browser.urlbar.openViewOnFocus  and set its value to false  Do the same with these preferences :  browser.urlbar.update1 (already mentioned by jscher2000)  browser.urlbar.update1.interventions  browser.urlbar.update1.searchTips  Then close and restart Firefox.]] 
  https://support.mozilla.org/en-US/questions/1283911#answer-1303777
  https://support.mozilla.org/en-US/questions/1284030#answer-1304125
  https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler 

More background on userChrome.css files: https://www.userchrome.org/


(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.update1 preference to switch the value from true to false

Note: This preference does not exist in Firefox 71-72.


Note(1):- In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. Note: This preference does not exist in Firefox 71-72. This preference to turn off the "Megabar" works in Firefox 75 and probably will work in Firefox 76.

Helpful?

more options

Yes this works but I see some problem with bar .I use 2 bars but one is a little low .Which parameter is responsible for put it up.Small bar windows is 1milimiter too low.The should be on the same line .---------------- .Screenshot show problem red arrow.

  1. urlbar[breakout],
  2. urlbar[breakout][breakout-extend] {
 --urlbar-height: 28px !important;
 --urlbar-toolbar-height: 30px !important;
 width: 100% !important;
 top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
 left: 0 !important;

}

  1. urlbar[breakout][breakout-extend] > #urlbar-input-container,
  2. urlbar-input-container {
 height: var(--urlbar-height) !important;
 width: 100% !important;
 padding-block: unset !important;
 padding-inline: unset !important;
 transition: none !important;

}

  1. urlbar[breakout][breakout-extend] > #urlbar-background {
 box-shadow: 0 1px 4px rgba(0,0,0,.05) !important;
 animation: none !important;

}

Helpful?

more options

Giải pháp được chọn

iikolor said

Yes this works but I see some problem with bar .I use 2 bars but one is a little low .
#urlbar[breakout],
#urlbar[breakout][breakout-extend] {
  --urlbar-height: 28px !important;
  --urlbar-toolbar-height: 30px !important;

  width: 100% !important;
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
}

Hi, I think you need to adjust the value for top: to something higher. Since you use the "normal" density layout, I think, you could try:

top: 5px !important;

and see whether that works for you.

I also have a rules file here if you want to compare: https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Helpful?

more options

Yes your file works for me .Thanks you .I do not understand why Team Firefox make our live that difficult.I see how a lot of people in Poland will be like change this for old behavior . Thanks your brother both .

This movie show my me mistake with create userChrome.My mistake was because file has to be in folder """chrome""" then Firefox see this file .

https://vimeo.com/241645477

Helpful?

more options

I'm on FF 77.0.1 and none of the above works for me.

Helpful?

more options

Hi joe80, let's continue with your new question here: https://support.mozilla.org/questions/1290682

Helpful?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.