Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can I remove the "Fill login" context menu entry?

  • 11 trả lời
  • 3 gặp vấn đề này
  • 112 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Firefox offers the option to "Fill login" through the context menu (see attached image) when ever in a login or password field. However I am using Bitwarden instead of the Firefox password manager and disabled saving passwords in Firefox. Is there a way to remove this "Fill login" action as it always just shows that no logins are saved?

Thanks, Mattias

Firefox offers the option to "Fill login" through the context menu (see attached image) when ever in a login or password field. However I am using Bitwarden instead of the Firefox password manager and disabled saving passwords in Firefox. Is there a way to remove this "Fill login" action as it always just shows that no logins are saved? Thanks, Mattias
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

OK, I've found an inconvenient solution using userChrome.css. Follow this guide to set it up and then put this content inside it. (Make sure you enable the legacy stylesheet loading.)

#fill-login {
   display: none !important;

}

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (11)

more options

I'm also in a similar situation! I've been searching and disabled anything to do with "autofill" or "password" in the about:config options and yet it still won't go away.

more options

Hello Mattias and mattmcoomber,

To disable this feature that came with the update to Firefox version 67.0 :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

signon.showAutoCompleteFooter

And set its value to false

Then close and restart Firefox.

That should do the trick .....

more options

Giải pháp được chọn

OK, I've found an inconvenient solution using userChrome.css. Follow this guide to set it up and then put this content inside it. (Make sure you enable the legacy stylesheet loading.)

#fill-login {
   display: none !important;

}

more options

McCoy said

Hello Mattias and mattmcoomber, To disable this feature that came with the update to Firefox version 67.0 : Type in the address bar about:config and press Enter (ignore the warning) Type in the search bar and look for the preference : signon.showAutoCompleteFooter And set its value to false Then close and restart Firefox. That should do the trick .....

This still isn't disabling the context menu option for me - looks like the userChrome option is still better!

more options

Hi,

thanks for the replies. The showAutoCompleteFooter sadly doesnt work for me either, but the userChrome solution does. Only tiny problem with that is that it leaves a redundant separator in the menu :p

Được chỉnh sửa bởi Mattias vào

more options

@ matmcoomber :

You're not talking about this feature (?) :

https://matthew.noorenberghe.com/blog/2019/05/password-manager-improvements-firefox-67

more options

Well, it looks like toggling the value of that preference doesn't work for either of you - apparantly I misconstrued your question(s).

Sorry ..... :(

more options

Mattias said

Hi, thanks for the replies. The showAutoCompleteFooter sadly doesnt work for me either, but the userChrome solution does. Only tiny problem with that is that it leaves a redundant separator in the menu :p

If you change it to

#fill-login-separator, #fill-login {
  display: none !important;

} it removes the separator too!

more options

mattmcoomber said

Mattias said
Hi, thanks for the replies. The showAutoCompleteFooter sadly doesnt work for me either, but the userChrome solution does. Only tiny problem with that is that it leaves a redundant separator in the menu :p

If you change it to

#fill-login-separator, #fill-login {
  display: none !important;

} it removes the separator too!

Awesome! Now the menu is nice and clean. Thanks! I wish this would be done by default when disabling the builtin password manager.

more options
In Firefox 76.0.1 this userChrome solution doesn't work.

Mattias said

mattmcoomber said
Mattias said
Hi, thanks for the replies. The showAutoCompleteFooter sadly doesnt work for me either, but the userChrome solution does. Only tiny problem with that is that it leaves a redundant separator in the menu :p

If you change it to

#fill-login-separator, #fill-login {
  display: none !important;

} it removes the separator too!

Awesome! Now the menu is nice and clean. Thanks! I wish this would be done by default when disabling the builtin password manager.

In Firefox 76.0.1 this userChrome solution doesn't work. Was the selector renamed?

more options

I think that this is code for the current Firefox releases.

#fill-login,
#fill-login-generated-password,
#fill-login-and-generated-password-separator {
 display:none !important;
}