X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why I can not save changes in about:config page?

DSD
Được đăng

Like in the description I can not save the changes I made in the about:config page no matter what I do, I already do an re installation also use the refresh button and delete the preferences file and still the issue remains.

Like in the description I can not save the changes I made in the about:config page no matter what I do, I already do an re installation also use the refresh button and delete the preferences file and still the issue remains.

Giải pháp được chọn

Maybe:

/* Blank "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: none !important;
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}

Or if you want to see something there to know that the tab is at least trying to load:

/* Static globe for "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: url("chrome://mozapps/skin/places/defaultFavicon.svg") !important;
  opacity: 0.5 !important; /* Lighten to gray */
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}
Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

IDM, Adblock Plus, flagfox, Roboform

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8703 giải pháp 71122 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi dsd7, does the change work while Firefox is still running and then revert at the next startup? Or is the change never effective?

What is the status of the preference you are trying to change in about:config? For example:

  • default - you should be able to change it
  • modified - you or some other software has changed it already, but you should be able to change it again
  • locked - a policy or settings file is preventing edits
  • something else?

It sounds as though you already know about the following article, but just in case: How to fix preferences that won't save.

Hi dsd7, does the change work while Firefox is still running and then revert at the next startup? Or is the change never effective? What is the status of the preference you are trying to change in about:config? For example: * default - you should be able to change it * modified - you or some other software has changed it already, but you should be able to change it again * locked - a policy or settings file is preventing edits * something else? It sounds as though you already know about the following article, but just in case: [[How to fix preferences that won't save]].
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

Hi,

The change is never effective and the status is default, and yes I already read and do what that article describes.

Hi, The change is never effective and the status is default, and yes I already read and do what that article describes.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17483 giải pháp 157999 câu trả lời
Được đăng

What changes is this about?

Does Firefox write a new prefs.js file when you close Firefox? Do you possibly have numbered prefs-##.js files?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

What changes is this about? Does Firefox write a new prefs.js file when you close Firefox? Do you possibly have numbered prefs-##.js files? You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

No it does not write another one and even not do I have other numbered of that file. Also I am not using that software. The change is the one about disabling animations.

No it does not write another one and even not do I have other numbered of that file. Also I am not using that software. The change is the one about disabling animations.
Bài viết này có hữu ích với bạn không?
Trích dẫn
WestEnd
  • Top 25 Contributor
60 giải pháp 5379 câu trả lời
Được đăng

dsd7 said

The change is the one about disabling animations.

This is from my reading is the confusing part what and or where are you referring to what site or domain?

''dsd7 [[#answer-1228784|said]]'' <blockquote> The change is the one about disabling animations. </blockquote> This is from my reading is the confusing part what and or where are you referring to what site or domain?

Được chỉnh sửa bởi WestEnd vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

WestEnd said

dsd7 said
The change is the one about disabling animations.

This is from my reading is the confusing part what and or where are you referring to what site or domain?

What changes is this about?

The change is the one about disabling animations.

I was speaking about my question: Why I can not save changes in about:config page?

''WestEnd [[#answer-1228786|said]]'' <blockquote> ''dsd7 [[#answer-1228784|said]]'' <blockquote> The change is the one about disabling animations. </blockquote> This is from my reading is the confusing part what and or where are you referring to what site or domain? </blockquote> What changes is this about? The change is the one about disabling animations. I was speaking about my question: Why I can not save changes in about:config page?
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5036 câu trả lời
Được đăng

Hello dsd7,

Apologies if this is a rethorical question, but after you changed the value, did you then close and restart Firefox in order for the change to take effect ?

Hello dsd7, Apologies if this is a rethorical question, but after you changed the value, did you then close and restart Firefox in order for the change to take effect ?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

Hello McCoy,

Yes I was doing that even restarting the device without any result, the change keep staying in default.

Hello McCoy, Yes I was doing that even restarting the device without any result, the change keep staying in default.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5036 câu trả lời
Được đăng

Stab in the dark, but what if you just changed the value of this preference :

toolkit.cosmeticAnimations.enabled (set it to false)

Does that work  ?

(the prefs you tried to toggle, may be obsolete)

(edit : typo ... )

Stab in the dark, but what if you just changed the value of this preference : '''toolkit.cosmeticAnimations.enabled''' (set it to '''false''') Does that work ? (the prefs you tried to toggle, may be obsolete) (edit : typo ... )

Được chỉnh sửa bởi McCoy vào

Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17483 giải pháp 157999 câu trả lời
Được đăng

What prefs did you try to change?

What prefs did you try to change?

Được chỉnh sửa bởi cor-el vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

McCoy said

Stab in the dark, but what if you just changed the value of this preference : toolkit.cosmeticAnimations.enabled (set it to false) Does that work  ? (the prefs you tried to toggle, may be obsolete) (edit : typo ... )

No matter how I do it keep reverting back to true.

''McCoy [[#answer-1228810|said]]'' <blockquote> Stab in the dark, but what if you just changed the value of this preference : '''toolkit.cosmeticAnimations.enabled''' (set it to '''false''') Does that work ? (the prefs you tried to toggle, may be obsolete) (edit : typo ... ) </blockquote> No matter how I do it keep reverting back to true.
Bài viết này có hữu ích với bạn không?
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

cor-el said

What prefs did you try top change?

This one: toolkit.cosmeticAnimations.enabled

''cor-el [[#answer-1228876|said]]'' <blockquote> What prefs did you try top change? </blockquote> This one: toolkit.cosmeticAnimations.enabled
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5036 câu trả lời
Được đăng

dsd7 said

This one: toolkit.cosmeticAnimations.enabled

'Had no idea that this particular pref was the only one you tried to toggle .....

I suggested this, because developers decided to only use this pref to disable animations, instead of many prefs, but now it looks like they're not so sure anymore - this bug report may explain why changing the value doesn't work anymore (just a guess) :

https://bugzilla.mozilla.org/show_bug.cgi?id=1478597

Does changing the values of the other animation related preferences work  ?

''dsd7 [[#answer-1228919|said]]'' <blockquote> This one: toolkit.cosmeticAnimations.enabled </blockquote> 'Had no idea that this particular pref was the only one you tried to toggle ..... I suggested this, because developers decided to only use this pref to disable animations, instead of many prefs, but now it looks like they're not so sure anymore - this bug report may explain why changing the value doesn't work anymore (just a guess) : https://bugzilla.mozilla.org/show_bug.cgi?id=1478597 Does changing the values of the other animation related preferences work ?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

McCoy said

dsd7 said
This one: toolkit.cosmeticAnimations.enabled

'Had no idea that this particular pref was the only one you tried to toggle .....

I suggested this, because developers decided to only use this pref to disable animations, instead of many prefs, but now it looks like they're not so sure anymore - this bug report may explain why changing the value doesn't work anymore (just a guess) :

https://bugzilla.mozilla.org/show_bug.cgi?id=1478597

Does changing the values of the other animation related preferences work  ?

Now that you say it and after I look again things are different, the value keep the change after the restart but with no effect, so I look at it and is in false but I still see the animations.

''McCoy [[#answer-1228923|said]]'' <blockquote> ''dsd7 [[#answer-1228919|said]]'' <blockquote> This one: toolkit.cosmeticAnimations.enabled </blockquote> 'Had no idea that this particular pref was the only one you tried to toggle ..... I suggested this, because developers decided to only use this pref to disable animations, instead of many prefs, but now it looks like they're not so sure anymore - this bug report may explain why changing the value doesn't work anymore (just a guess) : https://bugzilla.mozilla.org/show_bug.cgi?id=1478597 Does changing the values of the other animation related preferences work ? </blockquote> Now that you say it and after I look again things are different, the value keep the change after the restart but with no effect, so I look at it and is in false but I still see the animations.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5036 câu trả lời
Được đăng

Animations never bothered me all that much, but just now I set the value of that preference ("toolkit.cosmeticAnimations.enabled ") to "false" - and : didn't stop the animations .....

What you could try :

On the "about:config" page type animat in the search bar and see what prerefences you would like to toggle.

But : write down the name of the preference(s) you have toggled before closing Firefox, in case you want to change the value(s) back later.

Animations never bothered me all that much, but just now I set the value of that preference ("toolkit.cosmeticAnimations.enabled ") to "false" - and : didn't stop the animations ..... What you could try : On the "about:config" page type '''animat''' in the search bar and see what prerefences you would like to toggle. But : write down the name of the preference(s) you have toggled before closing Firefox, in case you want to change the value(s) back later.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

Disabled all the preferences after writing animat also animations without help.

Disabled all the preferences after writing '''animat''' also animations without help.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5036 câu trả lời
Được đăng

dsd7 said

Disabled all the preferences after writing animat also animations without help.

I was afraid of that - the changes you made did save though (?)

So far I found three bug reports on the subject, but no solution :

https://bugzilla.mozilla.org/show_bug.cgi?id=1352069

https://bugzilla.mozilla.org/show_bug.cgi?id=1478597

https://bugzilla.mozilla.org/show_bug.cgi?id=1520641

If you want to, you could vote to show your interest for a bug report :

https://bugzilla.mozilla.org/page.cgi?id=voting.html

You can post a comment, but only if you have additional (useful) information - keep it to the point and concise.

See Bugzilla Etiquette and Guidelines, the section  :
Commenting, especially #4

''dsd7 [[#answer-1228931|said]]'' <blockquote> Disabled all the preferences after writing '''animat''' also animations without help. </blockquote> I was afraid of that - the changes you made ''did'' save though (?) So far I found three bug reports on the subject, but no solution : https://bugzilla.mozilla.org/show_bug.cgi?id=1352069 https://bugzilla.mozilla.org/show_bug.cgi?id=1478597 https://bugzilla.mozilla.org/show_bug.cgi?id=1520641 If you want to, you could vote to show your interest for a bug report : https://bugzilla.mozilla.org/page.cgi?id=voting.html You can post a comment, but only if you have additional (useful) information - keep it to the point and concise. See Bugzilla Etiquette and Guidelines, the section : <BR>[https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Commenting, especially #4]
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

the changes you made did save though (?)

till now I can't see any changed behavior.

I will read all that reports and vote like you indicate.

Thank you!

'''the changes you made did save though (?)''' till now I can't see any changed behavior. I will read all that reports and vote like you indicate. Thank you!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17483 giải pháp 157999 câu trả lời
Được đăng

Does resetting toolkit.cosmeticAnimations.enabled only happen after a restart?

You didn't post your troubleshooting information.

You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Does resetting toolkit.cosmeticAnimations.enabled only happen after a restart? You didn't post your troubleshooting information. You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. *http://kb.mozillazine.org/preferences_not_saved You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
DSD
Được đăng

Người tạo câu hỏi

cor-el said

Does resetting toolkit.cosmeticAnimations.enabled only happen after a restart? You didn't post your troubleshooting information. You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Resetting is permanent, the value stay in false but the animations still present. I do not have user.js file and was never created, now my question is if I need to do that?

''cor-el [[#answer-1229028|said]]'' <blockquote> Does resetting toolkit.cosmeticAnimations.enabled only happen after a restart? You didn't post your troubleshooting information. You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. *http://kb.mozillazine.org/preferences_not_saved You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Resetting is permanent, the value stay in false but the animations still present. I do not have user.js file and was never created, now my question is if I need to do that?
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.