X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Disable video preview/preroll on websites

Được đăng

I have recently noticed that various websites (Washingon Post etc.) have an auto-roll preview of video articles, which I find annoying. The videos themselves don't autoplay, just the preview. Is there a way to disable this? (I'm running FF 63.0.1on Mac but also have it installed on a Windows machine.

The attached image is from the WaPo today (Nov.8). Thre are two previews for this article, about 5 secs. each.

I have recently noticed that various websites (Washingon Post etc.) have an auto-roll preview of video articles, which I find annoying. The videos themselves don't autoplay, just the preview. Is there a way to disable this? (I'm running FF 63.0.1on Mac but also have it installed on a Windows machine. The attached image is from the WaPo today (Nov.8). Thre are two previews for this article, about 5 secs. each.
Đính kèm ảnh chụp màn hình

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:63.0) Gecko/20100101 Firefox/63.0

Thông tin chi tiết

user1929 72 giải pháp 290 câu trả lời
Được đăng

Hi,

There's a hidden setting that you can use to disable autoplay:

1. Type "about:config" in the address bar. 2. Click the "I accept the risk" button. 3. Type "media.autoplay.default" in the search box. 4. Double-click on the item that appears, and enter "1" in the dialog box. 5. Reload the Washington Post page.

This will disable autoplay on every website, not just the Washington Post, but there are plans to add a setting to disable autoplay on just a specific website in the future.

Hope that helps!

Hi, There's a hidden setting that you can use to disable autoplay: 1. Type "about:config" in the address bar. 2. Click the "I accept the risk" button. 3. Type "media.autoplay.default" in the search box. 4. Double-click on the item that appears, and enter "1" in the dialog box. 5. Reload the Washington Post page. This will disable autoplay on every website, not just the Washington Post, but there are plans to add a setting to disable autoplay on just a specific website in the future. Hope that helps!

Người tạo câu hỏi

Nope, didn't help. I know about that media autoplay setting, although I was surprised that I had it set to "0". Changing it to "1" made no difference, though.

There are a bunch of media autoplay settings. Here's what I have:

Nope, didn't help. I know about that media autoplay setting, although I was surprised that I had it set to "0". Changing it to "1" made no difference, though. There are a bunch of media autoplay settings. Here's what I have:
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

I only needed to set (3) but some users also need to set (4):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.default preference and edit 0 to 1 and then click OK

(4) Double-click the media.autoplay.allow-muted preference to switch the value from true to false

(Note: I reloaded bypassing the cache between tests using Ctrl+Shift+r -- some ads and tracking features may have been blocked.)

I only needed to set (3) but some users also need to set (4): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered (3) Double-click the '''media.autoplay.default''' preference and edit '''0''' to '''1''' and then click OK (4) Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false (Note: I reloaded bypassing the cache between tests using Ctrl+Shift+r -- some ads and tracking features may have been blocked.)

Người tạo câu hỏi

In the image I posted, media.autoplay.default WAS set to 1. I changed media.autoplay.allow-muted to "false", but that didn't help either. Doesn't this just mute the audio? I dont get any audio with the previews anyway.

If you gp to the WaPo site (https://www.washingtonpost.com) and are not getting any of these preview/prerolls with the settings you suggest, but I am, something is very strange indeed! (Currently, there is a preview of "Fleeing the flames" in the second column.)

In the image I posted, '''media.autoplay.default''' WAS set to 1. I changed '''media.autoplay.allow-muted''' to "false", but that didn't help either. Doesn't this just mute the audio? I dont get any audio with the previews anyway. If you gp to the WaPo site (https://www.washingtonpost.com) and are not getting any of these preview/prerolls with the settings you suggest, but I am, something is very strange indeed! (Currently, there is a preview of "Fleeing the flames" in the second column.)
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

I got the one in your screenshot when I tested, but changing the preference froze it for me.

Do you use any add-ons related to videos that might somehow change how they load?

I got the one in your screenshot when I tested, but changing the preference froze it for me. Do you use any add-ons related to videos that might somehow change how they load?