Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox's message whenever enter fullscreen in YouTube videos plus slow exit fullscreen animation

  • 4 trả lời
  • 1 gặp vấn đề này
  • 143 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

So I just return to Firefox after a long time. There are things to catch up. When I enter fullscreen for YouTube videos (not the website fullscreen, F11), there is slide down message about YouTube is now in fullscreen and a button to exit fullscreen right away. How to not continue receiving such message? Also, when I exit fullscreen, YouTube re-scale and the animation is quite slow, you can feel the video frame is exiting full-screen and downsizing to smaller frame. Is there an option for me make it enter/exit fullscreen w/o such notice message or animation?

So I just return to Firefox after a long time. There are things to catch up. When I enter fullscreen for YouTube videos (not the website fullscreen, F11), there is slide down message about YouTube is now in fullscreen and a button to exit fullscreen right away. How to not continue receiving such message? Also, when I exit fullscreen, YouTube re-scale and the animation is quite slow, you can feel the video frame is exiting full-screen and downsizing to smaller frame. Is there an option for me make it enter/exit fullscreen w/o such notice message or animation?

Được chỉnh sửa bởi BnL_Nexus vào

Giải pháp được chọn

To avoid confusion, that would be these two prefs:

  • full-screen-api.transition-duration.enter: "0 0"
  • full-screen-api.transition-duration.leave: "0 0"
Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (4)

more options

You can modify some settings to shorten the notification or hide it completely. But I'm not sure that will help with the issue of exiting fullscreen. You can look at settings in that same area to see whether any of them help.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste FULL-S and pause while the list is filtered

(3) Double-click the full-screen-api.warning.delay preference and edit the value to 0 (that's a zero)

(4) Double-click the full-screen-api.warning.timeout preference and edit the value to 200 (that's 2 tenths of a second, just a very brief blip)

(5) There are three preferences starting with full-screen-api.transition. that could affect the other issue, but I've never experimented with them myself.

If you change them in a way that is worse, you can right-click > Reset to restore their default values.

Let us know what you come up with.

more options

the Full-scree-api.transition-enter and -leave should be set to 0 0 (2 zeros) and that pretty much almost remove the animation. Thank you for your help with the fullscreen message :D

more options

Please Mark the Solution that Solved your issue so others can find it. Thanks

more options

Giải pháp được chọn

To avoid confusion, that would be these two prefs:

  • full-screen-api.transition-duration.enter: "0 0"
  • full-screen-api.transition-duration.leave: "0 0"