Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I set the default font size to a lower value?

  • 38 பதிலளிப்புகள்
  • 116 இந்த பிரச்னைகள் உள்ளது
  • 19261 views
  • Last reply by Cutterschoice

I recently got the Firefox 22.0 build 20130514181517 update (at the same time as a Windows 7 update, I might add) and since then the default font sizes on all websites have been enlarged. I have a 17" monitor, but due to the grossly overscaled fonts it seems more like an old 14", and it's quite irritating. To view the websites in approximately the old way they used to look, I have to zoom out twice, but it also means I have to do it on all sites. I also have the habit of accidentally zooming in or out while using my laptop's touchpad, so whenever I ctrl-0 to reset the font, it goes back to the large font, and I need to rezoom it again.

I am primarily trying to figure out if there is a way to reset the font size without using any add-ons.

Thanks

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Read this answer in context 👍 10

All Replies (18)

To dianam59:

I sympathize - I am also old, but moderately computer literate. I was entering my distillation of the procedure when I saw John99's comment, which explains it all rather better than I could. My only addition is that apparently the problem has arisen because Mozilla have been modifying Firefox to work well on new high resolution displays, and this has side effects for the rest of us.

To Waka_Flocka_Flame and ilikefree:

Thanks for the suggestions. As i posted above, i have now fixed it after editing about:config as described above by John99.

To dianam59:

I sympathize - I am also old, but moderately computer literate. I was entering my distillation of the procedure when I saw John99's comment, which explains it all rather better than I could. My only addition is that apparently the problem has arisen because Mozilla have been modifying Firefox to work well on new high resolution displays, and this has side effects for the rest of us.

To Waka_Flocka_Flame and ilikefree:

Thanks for the suggestions. As i posted above, i have now fixed it after editing about:config as described above by John99.

Firefox needs to fix this problem quickly or it will lose a long time user!!!!! I have tried the solution above and it does not fix the problem on my monitor. Please go back to the way it was. It worked fine. I am tired of hitting control- on every page I go to.

If you wish to have your comment noted please use

(Last I heard analysis of comments suggested this was not a major concern of users so I guess not many people have been commenting)

It is pointless in complaining in this forum. All we do here is try have other users who try to help users with problems. We do not discuss development issues or decisions.

You will not get developer attention by posting here.

As I understand it the change was intentional and is unlikely to be reversed, although with enough complains consideration may be given to improving the situation.

Once you have zoomed a site to a suitable value Firefox should remember that and on the next visit that site should look ok.

When the most recent update to 22.0 happened, the web page fonts were too large, Pressing CTRL and "-" worked for me to make the web page, font and all, smaller. CTRL and "+" makes things larger.

Same here. Every single time I hit "enter" my font size increases to huge sizes. I'm sick of it. I have to re-size my font every time I move to a another site. How can something so ridiculously simple be a constant, pain-in-the-a-- problem. I was told that downloading the newest version (I have 22) would be the answer to ALL OF THIS. Yeah, right. I'm ready to bale. NO ONE needs to deal with this every time they sign on.

You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 (current default value is -1.0) to restore the behavior of previous Firefox versions and make icons on the toolbars appear right.

Use this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing the layout.css.devPixelsPerPx pref.


In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords and other persistent web page settings.

John99 said: "Once you have zoomed a site to a suitable value Firefox should remember that and on the next visit that site should look ok"

If that's true, I would only need NoSquint to set global zoom - not domain-specific zoom. Right?

Possibly you do only need to set NoSquint globally,

Or you may wish to take advantage of per domain settings, just as you may not wish to set each site as the same zoom level in Firefox.

As cor-el points out above some users may also be disabling Firefox remembering settings.

The title of this post is misleading. This isn't about font size, it's about the entire web page and UI of FF being rendered too large and blury. It does not look good on HD displays (I'm using a 15" 1080p monitor). If this behavior is not going to be reverted, and if there is not even a proper options setting to turn it off, then I'm sad to say this is the end of the line for FF for me. I avoided Chrome for as long as possible, but it's improved a lot. On the other hand, having to mess with multiple settings and install add-ons to make FF display normally is not a real solution. Now I'm actually thankful that Thunderbird is in maintenance mode. At least it should keep working as always.

I do not think for these purposes a 15"1080px monitor is considered Hi Dpi

Note if you change the pref as mentioned in the earlier post from -1 to 1.0 (NO MINUS SIGN) Firefox 22 display behaviour should be the same as in Firefox 21.

No the problem is you need to clear cache.

refer to

helped one user out with the "zoom" issue

No the problem is you need to clear cache. refer to

helped one user out with the "zoom" issue 

That my have been a different problem with part of a web page missing. Compare

Web deverlopers (and everyone with 3 minutes to spare), please use the COMPLAINT FORM at

 to explain in "detail" how FX22 is not working for your clients' websites.  This is the only way to get a solution or at least a temporary rollback. Complaining  is not what the forums are for and won't get any action.

Old versions of Fx:

 Note the "Firefox 21 (US English)"  IS clickable even it looks like normal text.

Added correct links ~J99

John99 மூலமாக திருத்தப்பட்டது

I have corrected the links in the last comment https://support.mozilla.org/en-US/que.../959621?page=2#answer-455686

Firefox 22 may be made to behave like Firefox 21 as explained in workarounds in this thread.

It is wise to avoid Firefox 21 use as it is unsupported and insecure.

Corporate / Enterprise / Educational establishments that have an IT Department and support users and deploy Firefox may consider using Firefox ESR that does not have this problems and is secure and supported. ESR however will next update to Firefox 24, and unless things change ESR will then inherit the same problem.

Tried setting to 1.0 from -1.0 and it still does not look like ver 21.0.

FunkyB is right on. For my system FF 21.0 was much better than FF 22.0. Too many things to change and it still does not give the desired results. Make the content smaller and the headers get too small to see.

Why did they ruin firefox, I've been a long time user, the new dpi mode it's terrible, I set the dpi to 1.0 like ppl suggest and yet it's horrible

  1. 1
  2. 2