Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Banish drop-downs -- How?

  • 72 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 47 views
  • Last reply by cor-el

When I type into the URL bar or the search bar, a drop-down list appears. How do I banish that behavior? Thank you -- Mark.

When I type into the URL bar or the search bar, a drop-down list appears. How do I banish that behavior? Thank you -- Mark.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Recap for those finding this topic while searching:

In 'prefs.js' user_pref("browser.urlbar.maxRichResults", 0);

In 'userChrome.css' .search-panel-tree,.search-panel-tree+.searchbar-separator{display:none !important}

Read this answer in context 👍 0

All Replies (20)

Helpful?

Eric said

Is this of any help: https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox

Unfortunately not. I've turned every search control OFF. I've changed the state of every setting in about:config that says anything about search. I don't want to change what's in the drop-down search list. I want to banish the drop-down itself. I have never found a way to do that.

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

Go to about:config and change browser.urlbar.maxRichResults to 0. Then go to Search settings and untick all the search engines (don't remove them, just hide by unticking).

Helpful?

zeroknight said

Go to about:config and change browser.urlbar.maxRichResults to 0. Then go to Search settings and untick all the search engines (don't remove them, just hide by unticking).

Done.

No effect other than to remove the search engines from the 'Search' Bar.

The 'Address' (URL) Bar still drops down -- no list but it still drops down.

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

It works for me. Can you share a screenshot of the dropdown?

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Helpful?

As you can see, the 'Address' drop-down is still there. As you can see, the 'Search' drop-down is very intrusive. It covers up what I try to copy on the page.

Developer's Edition? You mean the devs have their own edition?

Helpful?

Your profile modifications are likely interfering for the address bar.

The search bar dropdown height can be reduced by disabling "Remember search and form history" and clearing existing "Form & search history" with Ctrl+Shift+Delete. Alternatively, you can resort to userChrome.css and attempt to hide it completely:

#PopupSearchAutoComplete {
  display: none !important;
}

Helpful?

Thanks, zeroknight.

zeroknight said

Your profile modifications are likely interfering for the address bar.

How? I don't have any profile modifications that I know of. I don't know what a profile modification looks like or how to make one. ...What a train wreck.

The search bar dropdown height can be reduced by disabling "Remember search and form history" ...

Not found. Where is it?

... and clearing existing "Form & search history" with Ctrl+Shift+Delete. Alternatively, you can resort to userChrome.css and attempt to hide it completely: #PopupSearchAutoComplete { display: none !important; }

Done. Now I can't search dictionary.com, imdb.com, etc. at all. That's not good.

Helpful?

zeroknight said

Go to about:config and change browser.urlbar.maxRichResults to 0. Then go to Search settings and untick all the search engines (don't remove them, just hide by unticking).

I have info: I change 'browser.urlbar.maxRichResults' from '10' to '0', close FFox, launch FFox, and 'browser.urlbar.maxRichResults' equals '10' once again.

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

Remember search and form history can be found in the History section of settings.

If you have a user.js file in your profile folder, it will override your about:config changes on startup.

Helpful?

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.


You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

zeroknight said

Remember search and form history can be found in the History section of settings.

Forms is not my problem. My problem, I've only recently discovered in the course of this thread, is that none of the settings and changes I make survive restarting FFox.

If you have a user.js file in your profile folder, it will override your about:config changes on startup.

Here is '/media/mark/FFox profile/ckls0yge.default-release/chrome/userChrome.css' a:link{cursor:pointer !important;outline:green solid 0.1em !important;font-weight:bold !important;text-decoration:underline !important} a:visited{cursor:pointer !important;outline:red solid 0.1em !important;font-weight:bold !important;text-decoration:underline !important} /*#PopupSearchAutoComplete {display: none !important;}*/

Here is '/media/mark/FFox profile/ckls0yge.default-release/chrome/userContent.css' a:link{cursor:pointer !important;outline:green solid 0.1em !important;font-weight:bold !important;text-decoration:underline !important} a:visited{cursor:pointer !important;outline:red solid 0.1em !important;font-weight:bold !important;text-decoration:underline !important} /* a:link{cursor:pointer !important;font-weight:bold !important;text-decoration:underline !important} a:visited{cursor:pointer !important;font-weight:bold !important;text-decoration:underline !important}

  • /

Here is '/usr/share/webapp-manager/firefox/profile/user.js' user_pref("browser.cache.disk.enable", false); user_pref("browser.cache.disk.capacity", 0); user_pref("browser.cache.disk.filesystem_reported", 1); user_pref("browser.cache.disk.smart_size.enabled", false); user_pref("browser.cache.disk.smart_size.first_run", false); user_pref("browser.cache.disk.smart_size.use_old_max", false); user_pref("browser.ctrlTab.previews", true); user_pref("browser.tabs.warnOnClose", false); user_pref("plugin.state.flash", 2); user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); user_pref("browser.tabs.drawInTitlebar", false); user_pref("browser.tabs.inTitlebar", 0); user_pref("browser.contentblocking.category", "strict"); user_pref("privacy.clearOnShutdown.offlineApps", false); user_pref("privacy.sanitize.sanitizeOnShutdown", false); user_pref("privacy.sanitize.timeSpan", 1);

I searched 'about:config' with 'Show only modified preferences' and found no suspects. What a train wreck.

Helpful?

cor-el said

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.
What? Hahaha... Is that the Mozilla equivalent of "look at the source code"? I have no idea what you're 'talking' about and I don't care to know.
You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

I have no idea what you're 'talking' about. Can you be more specific with actual file paths and names?

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

My profile is here: /media/mark/FFox profile/ckls0yge.default-release It is a virtual disk attached to the Linux VM running in Win7 SP1. The only thing that has changed is the update to FFox 119.0 (64-bit).

Helpful?

Thanks folks. I'm not angry. I'm frustrated beyond words.

Helpful?

Mark Filipak said

zeroknight said

Remember search and form history can be found in the History section of settings.

Forms is not my problem.

"Form and search history" is the source of the suggestions in the search bar drop-down that have a little clock icon.

Helpful?

jscher2000 - Support Volunteer said

Mark Filipak said

zeroknight said

Remember search and form history can be found in the History section of settings.

Forms is not my problem.

"Form and search history" is the source of the suggestions in the search bar drop-down that have a little clock icon.

I never noticed that before. How would that prevent new settings being accepted and surviving an FFox restart -- You see, the symptoms have changed. The symptoms are much more serious than simply banishing the drop-downs.

edit: last lines were "I don't recall ever seeing that."

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

There is an old article on prefs.js -- the file in your profile folder that stores the changes you make through about:config -- not updating:

How to fix preferences that won't save

But updated packaging designs could add new/different wrinkles.

Helpful?

jscher2000 - Support Volunteer said

There is an old article on prefs.js -- the file in your profile folder that stores the changes you make through about:config -- not updating: How to fix preferences that won't save But updated packaging designs could add new/different wrinkles.

'about:config', now 'prefs.js', this is rather ridiculous, don't you think? Ah, well, in my 'prefs.js', below, what do you suggest I change?

Change of Course: I've deleted the 'prefs.js' listing -- it was only partial, anyways.

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

You said "My problem, I've only recently discovered in the course of this thread, is that none of the settings and changes I make survive restarting FFox."

Changes you make in about:config, and most settings changes you make on the Settings/Preferences page, should be written to the prefs.js file relatively promptly, within 30 seconds. You see the pattern in the file:

user_pref(preference.name, value);

So you should be able to tell whether changes you make in about:config are getting saved in the file (in alphabetical order by preference name).

Helpful?

jscher2000 - Support Volunteer said

You said "My problem, I've only recently discovered in the course of this thread, is that none of the settings and changes I make survive restarting FFox."

I have big news. And I'm glad you're a pro. :-) prefs.js was corrupt. I archived it. 1 - I quit the Linux VM. 2 - I mounted 'FFox profile.vhd' (the FFox profile virtual disk) in Windows Drive Management. 3 - I ran the 'chkdsk' command on it and found errors. 4 - I archived the bad file (=prefs.js) to my main Windows drive. 5 - I copied the original 'prefs.js' in place. 6 - I unmounted 'FFox profile.vhd'. 7 - I launched the Linux VM. 8 - I launched FFox. FFox opened like it was just created. I recovered my bookmarks but I'm having difficulties with the rest. Will you help me? I have two older backup copies of 'FFox profile.vhd' - from 25 days ago, - from 7 months ago. I favor just copying the 'prefs.js' from 25 days ago, but you may have a thought.

Thanks for helping. If I can help explain what happened to the corrupt version of 'prefs.js' that I have archived, I will do that of course. I'm a retired scientist-engineer and am well qualified to help troubleshoot. Due to the nature of the corruption, I suspect the most recent update of Linux Mint.

PS: My saved logins are there.

Mark Filipak மூலமாக திருத்தப்பட்டது

Helpful?

  1. 1
  2. 2
  3. 3
  4. 4
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.