Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

usps tracking and informed delivery does not work on firefox, but works on edge!

  • 24 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 44 views
  • Last reply by 09grizzly550

how is it that the usps website works on edge, but not on firefox? usps stopped working about a month ago on firefox. i already tried clearing the cashe and cookies from usps and that did not work, and neither did turning off ad block plus. im at a loss here.

how is it that the usps website works on edge, but not on firefox? usps stopped working about a month ago on firefox. i already tried clearing the cashe and cookies from usps and that did not work, and neither did turning off ad block plus. im at a loss here.

All Replies (20)

Show the issue, it works for me. see screenshot

jonzn4SUSE மூலமாக திருத்தப்பட்டது

the issue, is the page either does not load, or i get a "this service is currently unavailable" on the usps site when i try to log into informed delivery. once i got a 504 error, but only once. i tried safemode, same thing. same with disabling my firefox ad ons.

What security software are you running?

none. all of my security issues were caused by viruses in ads. with ad block, i dont get that anymore, so i dont use any.

09grizzly550 said

none. all of my security issues were caused by viruses in ads. with ad block, i dont get that anymore, so i dont use any.

This is confusing???

what is confusing? i dont get viruses since using ad block. the only thing confusing here is why usps doesnt work on my firefox, yet works on chrome and edge and on other's firefox. that is what i get when i try to log into informed delivery. made sure to include the address bar in it as well.

09grizzly550 மூலமாக திருத்தப்பட்டது

Thanks for the screenshot. https://informeddelivery.usps.com I was able to sign up for the service and I'm in my account. see screenshot

Try this option and make sure you know the login information. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions

Also, can you try under a different windows account. If you don't have one, just make another account for testing.

if you look at the snip i posted, you can see my name at the top right. im signed in correctly. i can go to the usps site and then click on informed delivery and that still does not work. right now it wont even load up the page for informed delivery, either from a direct link from my home page, or from the usps site.

how would it be my windows account if i can use chrome and edge to use informed delivery?

Who are you using for DNS?

what does my dns have to do with usps not working on firefox?

09grizzly550 மூலமாக திருத்தப்பட்டது

just did that, usps shows a loading circle and wont load informed delivery still.

I just signed out, cleared cache and history and now getting the same error. see screenshot After going to the home page, logging back in, it works again for me. Someone closer to Dev will have to chime in.

jonzn4SUSE மூலமாக திருத்தப்பட்டது

this is what i get when i try and log in sometimes.

A full browser screenshot would be more helpful that just showing what's in the browser window. Break out the Snip tool and get more useful screenshots.

Also, I'm curious to know your dns settings? Testing something different wouldn't hurt.

  1. 1
  2. 2