Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox creashes after closing conferences

  • 9 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 52 views
  • Last reply by cor-el

i am currently working in Kubuntu 20.04 with Firefox 95.0 (64-bit). I'm not sure how it started but slowly whenever i close a conference (closing a conference includes exiting audio or closing the tab entirely. and this has happened since about a weeks or so), such as google meet and all, Firefox crashes and opens the crash reporter or something. i have reported this several times but I'm not really seeing any fix or causes. if it helps, here is the link for the crash report - One of the crashes i have reported i have two add-on installed- Tab Auto Refresh and Ghostery – Privacy Ad Blocker Do let me know if you require any other information regarding this.

i am currently working in Kubuntu 20.04 with Firefox 95.0 (64-bit). I'm not sure how it started but slowly whenever i close a conference (closing a conference includes exiting audio or closing the tab entirely. and this has happened since about a weeks or so), such as google meet and all, Firefox crashes and opens the crash reporter or something. i have reported this several times but I'm not really seeing any fix or causes. if it helps, here is the link for the crash report - [https://crash-stats.mozilla.org/report/index/8b9b33db-46e6-456b-bd69-680000211216#tab-extensions One of the crashes i have reported] i have two add-on installed- ''Tab Auto Refresh'' and ''Ghostery – Privacy Ad Blocker'' Do let me know if you require any other information regarding this.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try "visibility: hidden;" or opacity: 0;" to see if that makes a difference.

Read this answer in context 👍 1

All Replies (10)

Have you tried Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Helpful?

I have tried trouble-shooting mode and re-installed firefox and both of them shows that it doesn't crash when i close a meeting. but i have tried all steps for trouble-shooting as shown in the article, such as disabling extentions and such. the issue still persists. is there any other underlying causes?

Helpful?

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Helpful?

Are you in Wayland or X11? If you are familiar with strace, it will show you what is going on at the time of the crash.

Operating System: openSUSE Tumbleweed 20211220 KDE Plasma Version: 5.23.4 KDE Frameworks Version: 5.89.0 Qt Version: 5.15.2 Kernel Version: 5.15.8-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Helpful?

cor-el said

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

this worked and there is no crashes when i close the tab. but i would like to know how this is happening in the linux distribution, because i updated it to the latest and this only started about a week ago, after a long time of use.

jonzn4SUSE said

Are you in Wayland or X11? If you are familiar with strace, it will show you what is going on at the time of the crash.

i am in X11. and, i'm not familiar but i tried strace firefox and received a huge text which i cant understand and a new firefox window. is there any particular line or something that i should look out for?

Helpful?

If you can confirm that this is an issue with the Firefox version from your distro then you need to take this to your distro's support, so they can look into this.

Helpful?

When you got to your distro support I'm positive they're going to ask for a dump from strace so they can see what's going boom when you close the browser. By using the time stamp option in strace you can narrow down the data to a little before and the exact time the browser goes boom to see what's going on. see screenshots

Helpful?

Thanks for all the help and support, but I think I found the culprit.

long ago, I made a userChrome.css file to get rid of the pop-up that occurs whenever mic is being shared, since its annoying and stays on top of all tabs and windows on my desktop. the code I copy-pasted from a help forum is given in the picture i attached. it worked and there was no problem, because I have been using this since last year, before I even updated my OS or Firefox. and I think that makes sense that this could the underlying cause, since I would be sharing my mic in a conference. I tried joining only by audio and not with mic and this time it didn't crash.

I recently also made a change to disable showing the mute and unmute pin on top of tabs, but I hadn't put this code into the installed Firefox and removed it from the Kubuntu's distro, but it didn't stop the crashing.

this came to my notice when i tried to add the code to disable the pop-up of mic to the installed version of Firefox and it crashed again. Is there a error in the code or something?

Vulpa மூலமாக திருத்தப்பட்டது

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try "visibility: hidden;" or opacity: 0;" to see if that makes a difference.

Helpful?

Thanks! this really sorted out my problem and firefox no longer crashes! although "visibility: hidden;" just made the block to the color of my default title bar, no matter the window. and "opacity: 0;" had the same results, just that when clicked on does exactly what the original pop-up does, take us to the tab in firefox. i think this problem is probably a code or bug, but I'm going to stick to "visibility: hidden" for now.

Edit: I dug around the internet and found a solution. I found it in- How to remove Firefox orange microphone/webcam indicator from the top of the screen? (the second solution solved it) instead of making a userChrome.css, there was some other changes made in the configuration of Firefox. this solved the problem, and i hope this wont crash again after a long time.

Anyways, Thanks for helping me out and support!

Vulpa மூலமாக திருத்தப்பட்டது

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.