Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't activate two-step-authentication

  • 15 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 43 views
  • Last reply by BRAC

I try to add the two-step-authentication to my account, but when I scan the QR-code and enter the generated security code I get the error message "two-step-authentication required"; so it tells me I have to enable two-step-authentication before I can enable two-step-authentication?

All Replies (15)

Please ignore emmahelp506's post and don't call that number   -   it's a scam !

Helpful?

I thought so and already reported it :)

Helpful?

Anthesnatidis said

I thought so and already reported it :)

Good for you - well done  !

Helpful?

Hello Anthesnatidis,

This Article will Surely help you.

Secure your Firefox Account with two-step authentication

Thank You.

Helpful?

No, sadly that does not help me. Step 6 is the problem: When I scan the QR code and enter it, I get an error message saying I have to enable two-step-authentication first.

Helpful?

Helpful?

Do you possibly already have enabled 2FA ?

Can you login via this website?

Helpful?

I can login, but I have not enabled 2FA before

Helpful?

When you enable 2FA then you get a QR code that you need to scan with an Authenticator app that generates a 6-digit code that you need to enter to confirm that 2FA is working.

How far do you get ?

Helpful?

Two-step authentication adds extra security by making it harder for someone else to log in to your account, especially if they steal your password.

When you enable two-step authentication, when someone attempts to log in to your account with your password, Firefox will also ask for a verification code from an authentication application for proof that it’s really you.

Helpful?

cor-el said

When you enable 2FA then you get a QR code that you need to scan with an Authenticator app that generates a 6-digit code that you need to enter to confirm that 2FA is working. How far do you get ?

Step 6 is the problem: When I scan the QR code and enter it, I get an error message saying I have to enable two-step-authentication first.

Helpful?

Hello,

I have a similar issue to the OP. Didn't want to start a new topic. So, I'll ask here.

I've been trying to activate the Two Factor Authentication on my FF account without success for over a week now. I've tried using the two Authenticator apps (Winauth & Authy) as suggested on your site and a third party one. But, It says invalid two-step authentication code every time across all three apps. The only one occasion it worked with Winauth, it reset itself upon a reload of the page saying Authentication disabled and repeats the failure message, thereafter.

OS: Windows 10 1909

FF: 77.0.1 (64-bit)

Any workaround is appreciated.

BRAC மூலமாக திருத்தப்பட்டது

Helpful?

Are you sure you have the correct time in the authenticator apps ?
Can you try another internet time service?

Does this TOTP feature work with other websites ?

Helpful?

cor-el said

Are you sure you have the correct time in the authenticator apps ?
Can you try another internet time service? Does this TOTP feature work with other websites ?

I don't see an option to manually tinker with time settings in any of the apps. So, not sure how it's done.

Tried a different time service but still no luck, although I did notice the Windows time service isn't running and the tweak fields are all grayed out. A manual update fails with an error. I did try a fix (reset of the Time service) suggested on the web via CMD but it says access denied at which point I gave up. The system Time and Date itself is accurate and haven't noticed any issue.

Haven't tried any other sites yet because I'm fairly new to TFA. The only other site where I have TFA enabled is my Microsoft account which works albeit with a different App.

BRAC மூலமாக திருத்தப்பட்டது

Helpful?

Just a heads up on the issue.

It turns out the problem was down to wrong system time (as you said). Mine was off by 2 minutes and I never realized that. The authenticator apps now work without a hitch until maybe it happens again because the underlying issue with win32 time service itself is unaddressed. The system time hasn't synced in well over a year...That's for another forum I guess.

Anyway thanks for your help @cor-el

BRAC மூலமாக திருத்தப்பட்டது

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.