X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

since the latest update firefox opens new windows with a blank page instead of my home page.

  • 19 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by McCoy
பதிவிடப்பட்டது

In options I have homepage and new windows set to custom urls. The new tab option doesn't have an option for custom url but I'm opening a new window so it shouldn't follow the new tab setting. I never open tabs, just windows.

Why does every update have to cause a problem with my settings? I leave updates as long as I possibly can as they always cause a problem.

In options I have homepage and new windows set to custom urls. The new tab option doesn't have an option for custom url but I'm opening a new window so it shouldn't follow the new tab setting. I never open tabs, just windows. Why does every update have to cause a problem with my settings? I leave updates as long as I possibly can as they always cause a problem.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello cathc,

Apologies if this is a rethorical question, but have you checked "Restore previous session" in Options => General => under "Startup"  ?

Read this answer in context 1
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71076 பதில்கள்
பதிவிடப்பட்டது

Hi cathc, it's not you, it's Firefox. There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67.

Here is the problem combination:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Options > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Options > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If you set either of those red-boxed preference back to its default value (unchecked), the problem should not occur. If you do not want to change settings, you'll have to click the Home button at startup.

Hi cathc, it's not you, it's Firefox. There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67. Here is the problem combination: (1) "Delete cookies and site data when Firefox is closed" * set in Options > Privacy & Security > Cookies section<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-50-21661b.png" width="400"> * '''about:config''' => network.cookie.lifetimePolicy => 2 (modified) (2) "Clear history when Firefox closes" * set in Options > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-56-8b9d89.png" width="400"> * '''about config''' => privacy.sanitize.sanitizeOnShutdown => true (modified) If you set ''either'' of those red-boxed preference back to its default value (unchecked), the problem should not occur. If you do not want to change settings, you'll have to click the Home button at startup.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks, I do appreciate you getting back to me.

However I don't have " delete cookies and site data when Firefox is closed" checked and my History is set to "remember history"

Thanks, I do appreciate you getting back to me. However I don't have " delete cookies and site data when Firefox is closed" checked and my History is set to "remember history"
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17479 தீர்வுகள் 157964 பதில்கள்
பதிவிடப்பட்டது

Is this about opening a new window via the New Window menu item (Ctrl+N)?

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)?

Is this about opening a new window via the New Window menu item (Ctrl+N)? Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for your help. Sorry to take so long to respond - the site's been down most of the day.

i open a window from a desktop shortcut, but yes, I get the same problem if I use Ctrl+N.

I don't know what Private Browsing mode is, or how to set it. As above my History is set to "remember history"

Thanks for your help. Sorry to take so long to respond - the site's been down most of the day. i open a window from a desktop shortcut, but yes, I get the same problem if I use Ctrl+N. I don't know what Private Browsing mode is, or how to set it. As above my History is set to "remember history"
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59413 பதில்கள்
பதிவிடப்பட்டது

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks FredMcD. It does now open to the home page but without remembering my bookmarks sidebar! So I've still lost out to the latest update.

Is there a way for it to remember my settings?

Do I always have to open Firefox in safe mode now?

Thanks FredMcD. It does now open to the home page but without remembering my bookmarks sidebar! So I've still lost out to the latest update. Is there a way for it to remember my settings? Do I always have to open Firefox in safe mode now?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17479 தீர்வுகள் 157964 பதில்கள்
பதிவிடப்பட்டது

Does this still happen in Firefox 67.0.2?

Does this still happen in Firefox 67.0.2? *https://support.mozilla.org/en-US/kb/update-firefox-latest-version
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71076 பதில்கள்
பதிவிடப்பட்டது

cathc said

It does now open to the home page but without remembering my bookmarks sidebar!

Does the Bookmarks Sidebar still open using Ctrl+b or the Sidebars button? But Firefox doesn't automatically re-open it at the start of the next session?

''cathc [[#answer-1229573|said]]'' <blockquote> It does now open to the home page but without remembering my bookmarks sidebar! </blockquote> Does the Bookmarks Sidebar still open using Ctrl+b or the Sidebars button? But Firefox doesn't automatically re-open it at the start of the next session?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

jscher2000 said

Does the Bookmarks Sidebar still open using Ctrl+b or the Sidebars button? But Firefox doesn't automatically re-open it at the start of the next session?

That's exactly right. It opens with the button but doesn't automatically re-open at the start of the next session.

''jscher2000 [[#answer-1229587|said]]'' <blockquote> Does the Bookmarks Sidebar still open using Ctrl+b or the Sidebars button? But Firefox doesn't automatically re-open it at the start of the next session? </blockquote> That's exactly right. It opens with the button but doesn't automatically re-open at the start of the next session.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

Does this still happen in Firefox 67.0.2?

Yes. I've updated and it still opens without the sidebar.

''cor-el [[#answer-1229584|said]]'' <blockquote> Does this still happen in Firefox 67.0.2? *https://support.mozilla.org/en-US/kb/update-firefox-latest-version </blockquote> Yes. I've updated and it still opens without the sidebar.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17479 தீர்வுகள் 157964 பதில்கள்
பதிவிடப்பட்டது

Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Sorry. I really don't know what any of this means.

''cor-el [[#answer-1229625|said]]'' <blockquote> Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Sorry. I really don't know what any of this means.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

i think I may be best going back to the earlier version of Firefox. I try to leave updating as long as possible as it never seems to result in improvements.

Why can't they just leave it alone?

i think I may be best going back to the earlier version of Firefox. I try to leave updating as long as possible as it never seems to result in improvements. Why can't they just leave it alone?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello cathc,

Apologies if this is a rethorical question, but have you checked "Restore previous session" in Options => General => under "Startup"  ?

Hello cathc, Apologies if this is a rethorical question, but have you checked "Restore previous session" in Options => General => under "Startup" ?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

McCoy said

Hello cathc, Apologies if this is a rethorical question, but have you checked "Restore previous session" in Options => General => under "Startup"  ?

Thanks, I have done that now! Isuppose I need to re-update and see if that works now :-(

''McCoy [[#answer-1229634|said]]'' <blockquote> Hello cathc, Apologies if this is a rethorical question, but have you checked "Restore previous session" in Options => General => under "Startup" ? </blockquote> Thanks, I have done that now! Isuppose I need to re-update and see if that works now :-(
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71076 பதில்கள்
பதிவிடப்பட்டது

cathc said

cor-el said
Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Sorry. I really don't know what any of this means.

The xulstore.json file stores the status of which bars are displayed, which sidebar is open (if any), and what size windows are. If Firefox stops showing the expected items at the expected sizes, it could be due to that file becoming corrupted with nonsensical values. However, since Ctrl+b is only one extra keypress, it might not be worth removing the file. You certainly can decide later.

''cathc [[#answer-1229631|said]]'' <blockquote> ''cor-el [[#answer-1229625|said]]'' <blockquote> Try to rename/remove xulstore.json and when present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Sorry. I really don't know what any of this means. </blockquote> The xulstore.json file stores the status of which bars are displayed, which sidebar is open (if any), and what size windows are. If Firefox stops showing the expected items at the expected sizes, it could be due to that file becoming corrupted with nonsensical values. However, since Ctrl+b is only one extra keypress, it might not be worth removing the file. You certainly can decide later.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks McCoy! It's working with the latest version now, opening to the home page and with the sidebar.

Thanks to everyone for your input.

Thanks McCoy! It's working with the latest version now, opening to the home page and with the sidebar. Thanks to everyone for your input.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

said </blockquote>

The xulstore.json file stores the status of which bars are displayed, which sidebar is open (if any), and what size windows are. If Firefox stops showing the expected items at the expected sizes, it could be due to that file becoming corrupted with nonsensical values. However, since Ctrl+b is only one extra keypress, it might not be worth removing the file. You certainly can decide later. </blockquote>


Thanks jscher2000 for persisting. I think i'm there!jscher2000

[[#answer-1229650|said]]'' </blockquote> The xulstore.json file stores the status of which bars are displayed, which sidebar is open (if any), and what size windows are. If Firefox stops showing the expected items at the expected sizes, it could be due to that file becoming corrupted with nonsensical values. However, since Ctrl+b is only one extra keypress, it might not be worth removing the file. You certainly can decide later. </blockquote> Thanks jscher2000 for persisting. I think i'm there!''jscher2000
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

cathc said

Thanks McCoy! It's working with the latest version now, opening to the home page and with the sidebar.

My pleasure, cathc - I'm glad everything's back to normal.

''cathc [[#answer-1229651|said]]'' <blockquote> Thanks McCoy! It's working with the latest version now, opening to the home page and with the sidebar. </blockquote> My pleasure, cathc - I'm glad everything's back to normal.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.