X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Disable search bar(blue) when typing in address bar

  • 23 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jonpal
பதிவிடப்பட்டது

I have been through numerous support pages and nothing helps, did a few about config changes as listed but still it appears. One post said it has always been there, I can assure you I never had this before and do not want it now. Is there any way to stop it please as I hate it even though just clicking removes it, I would prefer not to have it in the first place

I have been through numerous support pages and nothing helps, did a few about config changes as listed but still it appears. One post said it has always been there, I can assure you I never had this before and do not want it now. Is there any way to stop it please as I hate it even though just clicking removes it, I would prefer not to have it in the first place

தீர்வு தேர்ந்தெடுக்கப்பட்டது

neilbowls said

I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0

The preference "browser.urlbar.maxRichResults" has nothing to do with getting rid of the blue bar you started this thread about; hence I didn't look for a way for you to get rid of the search
results ......

A little miscommunication ......

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:65.0) Gecko/20100101 Firefox/65.0

கூடுதல் தகவல்

McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

Hello neilbowls,

You have probably read the posts in these threads :

https://support.mozilla.org/en-US/questions/1249258

https://support.mozilla.org/en-US/questions/1249309

Assuming that it is the blue 'Visit' bar you are referring to : After entering a URL, I click the 'Visit' bar instead of pressing Enter. (in Edge this bar is grey …. )

I understand that having to see that blue bar, even if only for a spilt second, can be very annoying to you - maybe you'd like to try what's suggested by 'cor-el' in the above mentioned threads  ?

Hello neilbowls, You have probably read the posts in these threads : https://support.mozilla.org/en-US/questions/1249258 https://support.mozilla.org/en-US/questions/1249309 Assuming that it is the blue 'Visit' bar you are referring to : After entering a URL, I click the 'Visit' bar instead of pressing Enter. (in Edge this bar is grey …. ) I understand that having to see that blue bar, even if only for a spilt second, can be very annoying to you - maybe you'd like to try what's suggested by 'cor-el' in the above mentioned threads ?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

these are the things I have already tried, and didnt work so i started a new thread in the hope others may have a new idea, when you start typing in the address bar it says search by google and stays until you click enter, What i am wanting to do is to stop seeing it altogether.

these are the things I have already tried, and didnt work so i started a new thread in the hope others may have a new idea, when you start typing in the address bar it says search by google and stays until you click enter, What i am wanting to do is to stop seeing it altogether.
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

The header of your original post is :

"Disable search bar(blue) when typing in address bar"

You should not see the 'Search with Google' if you have tried everything that was mentioned in those threads - I am really puzzled and I hope that somebody else will come up with the perfect sulution for you .....

(the blue 'Visit' bar is a different issue, but you don't mention that)

The header of your original post is : "''Disable search bar(blue) when typing in address bar''" You should not see the 'Search with Google' if you have tried everything that was mentioned in those threads - I am really puzzled and I hope that somebody else will come up with the perfect sulution for you ..... (the blue 'Visit' bar is a different issue, but you don't mention that)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi McCoy Thanks for the reply. not sure what you mean by different issue please see attached picture. This is what I am trying to disable and it never used to be there hope this clarifies the issue better, Will be offline till next week so I will not be able to see and comment on any replies straight away

Hi McCoy Thanks for the reply. not sure what you mean by different issue please see attached picture. This is what I am trying to disable and it never used to be there hope this clarifies the issue better, Will be offline till next week so I will not be able to see and comment on any replies straight away
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

neilbowls said

not sure what you mean by different issue

I mean that the 'Visit' bar is not the same thing as the 'Search with Google' bar.

I disabled the latter by doing what is mentioned in the threads I gave you links to : I changed the value of browser.urlbar.OneOffSearches on the 'about:config' page to false (and then closed and restarted Firefox)

As you say that you have already tried everything that is mentioned in those threads to no avail, I can only hope that somebody else will come to your rescue ......

''neilbowls [[#answer-1195045|said]]'' <blockquote> not sure what you mean by different issue </blockquote> I mean that the 'Visit' bar is not the same thing as the 'Search with Google' bar. I disabled the latter by doing what is mentioned in the threads I gave you links to : I changed the value of '''browser.urlbar.OneOffSearches''' on the 'about:config' page to '''false''' (and then closed and restarted Firefox) As you say that you have already tried everything that is mentioned in those threads to no avail, I can only hope that somebody else will come to your rescue ......
பதிவிடப்பட்டது

உதவிகரமான பதில்

thanks again for trying to help, i do hope someone can resolve this as it is really annoying and is starting to make me feel like stop using firefox. This is a shame as it has always been so good in the past

thanks again for trying to help, i do hope someone can resolve this as it is really annoying and is starting to make me feel like stop using firefox. This is a shame as it has always been so good in the past
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

neilbowls said

i do hope someone can resolve this as it is really annoying and is starting to make me feel like stop using firefox. This is a shame as it has always been so good in the past

Again : if you have done everything that's suggested in the threads I gave you links to, the problem should be solved.

Just curious : are you serious about switching to another browser because of a blue bar that you see for a split second  ? You might see the same bars in other browsers, in gloomy dark grey ......

But seriously : would you please go over the suggestions again that are mentioned in those other threads  ? Maybe you missed something .....

The blue 'Search with Google' bar should be gone when you do what I (also) suggested here.

''neilbowls [[#answer-1196267|said]]'' <blockquote> i do hope someone can resolve this as it is really annoying and is starting to make me feel like stop using firefox. This is a shame as it has always been so good in the past </blockquote> Again : if you have done everything that's suggested in the threads I gave you links to, the problem should be solved. Just curious : are you serious about switching to another browser because of a blue bar that you see for a split second ? You might see the same bars in other browsers, in gloomy dark grey ...... But seriously : would you please go over the suggestions again that are mentioned in those other threads ? Maybe you missed something ..... The blue 'Search with Google' bar should be gone when you do what I (also) suggested here.
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hi I did look some more since my last post and found reference to this from about a year ago. This worked

browser.urlab.maxRichResults turn value from 10 to 0

If you suggested this before I missed it and am sorry for continuing the discussion.

I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load.

i understand it may be because of my laptop limitations but IE does not freeze but because I cannot update it some sites do not load

Hi I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 If you suggested this before I missed it and am sorry for continuing the discussion. I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load. i understand it may be because of my laptop limitations but IE does not freeze but because I cannot update it some sites do not load
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

neilbowls said

Hi I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 If you suggested this before I missed it and am sorry for continuing the discussion.

No, you definately did not miss it - it surprises me that this is what did the trick for you, but : well done  !

Would you please mark your own last post as Chosen Solution  ?

I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load.

Before reading this, I just posted something in that thread .....

https://support.mozilla.org/en-US/questions/1244200

''neilbowls [[#answer-1196271|said]]'' <blockquote> Hi I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 If you suggested this before I missed it and am sorry for continuing the discussion. </blockquote> No, you definately did ''not'' miss it - it surprises me that this is what did the trick for you, but : well done ! Would you please mark your own last post as Chosen Solution ? <blockquote> I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load. </blockquote> Before reading this, I just posted something in that thread ..... https://support.mozilla.org/en-US/questions/1244200
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

neilbowls said

I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0

The preference "browser.urlbar.maxRichResults" has nothing to do with getting rid of the blue bar you started this thread about; hence I didn't look for a way for you to get rid of the search
results ......

A little miscommunication ......

''neilbowls [[#answer-1196271|said]]'' <blockquote> I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 </blockquote> The preference "browser.urlbar.maxRichResults" has nothing to do with getting rid of the blue bar you started this thread about; hence I didn't look for a way for you to get rid of the search <BR>results ...... A little miscommunication ......
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi McCoy Thanks for all your help and support A bit of miscommunication is to be expected especially with all the variables these days and peoples differing ideas of what they are looking at.

Hi McCoy Thanks for all your help and support A bit of miscommunication is to be expected especially with all the variables these days and peoples differing ideas of what they are looking at.
McCoy
  • Top 10 Contributor
520 தீர்வுகள் 4894 பதில்கள்
பதிவிடப்பட்டது

neilbowls said

Thanks for all your help and support

My pleasure  ! Now I'm going to ask you to do one more thing for me : Remove the Chosen Solution mark from my post (after all : I didn't solve your problem .... ) You can do so by clicking on the 'Undo' button and then mark your own post (the one that mentions what solved the problem) as Chosen Solution.

(fair is fair .... )

''neilbowls [[#answer-1196280|said]]'' <blockquote> Thanks for all your help and support </blockquote> My pleasure ! Now I'm going to ask you to do one more thing for me : Remove the Chosen Solution mark from my post (after all : I didn't solve your problem .... ) You can do so by clicking on the 'Undo' button and then mark your own post (the one that mentions what solved the problem) as Chosen Solution. (fair is fair .... )
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hope I got it right and thanks again

Hope I got it right and thanks again
vmedlock 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

neilbowls said

Hi I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 If you suggested this before I missed it and am sorry for continuing the discussion. I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load. i understand it may be because of my laptop limitations but IE does not freeze but because I cannot update it some sites do not load

Thanks for posting this information. I've been going crazy trying to disable the d*mn blue annoyance as well. And to answer McCoy, yes, I have already switched to Waterfox on my personal computers. It's a better browser in every way, and the developer doesn't try to force users to adopt new "features" every few weeks.

It's sad, really. I used Firefox for many years and was generally quite happy with it until the "Quantum" interface was forced down everyone's throats. This latest ball-drop was the last straw.

''neilbowls [[#answer-1196271|said]]'' <blockquote> Hi I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0 If you suggested this before I missed it and am sorry for continuing the discussion. I am serious about considering another browser but mainly because of a separate thread concerning Firefox constantly freezing and slow to load. i understand it may be because of my laptop limitations but IE does not freeze but because I cannot update it some sites do not load </blockquote> Thanks for posting this information. I've been going crazy trying to disable the d*mn blue annoyance as well. And to answer McCoy, yes, I have already switched to Waterfox on my personal computers. It's a better browser in every way, and the developer doesn't try to force users to adopt new "features" every few weeks. It's sad, really. I used Firefox for many years and was generally quite happy with it until the "Quantum" interface was forced down everyone's throats. This latest ball-drop was the last straw.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi sorry I didnt find it earlier and maybe you would have stayed with Firefox. As my IE is at its limit and many sites are no longer working with it, I did try the Brave browser but found that dreadful with even more annoyances and lack of user options. hope this information helps others

Hi sorry I didnt find it earlier and maybe you would have stayed with Firefox. As my IE is at its limit and many sites are no longer working with it, I did try the Brave browser but found that dreadful with even more annoyances and lack of user options. hope this information helps others
vmedlock 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

Thanks, but there's no need to be sorry. Honestly, I'm much happier with Waterfox. I'm just sorry that Firefox has lost its way.

And thanks again for posting this info. It's very helpful on my work machine where Firefox is the least bad choice.

Thanks, but there's no need to be sorry. Honestly, I'm much happier with Waterfox. I'm just sorry that Firefox has lost its way. And thanks again for posting this info. It's very helpful on my work machine where Firefox is the least bad choice.
jonpal 0 தீர்வுகள் 17 பதில்கள்
பதிவிடப்பட்டது

So, is there an answer to how to disable the blue bar?

So, is there an answer to how to disable the blue bar?
jscher2000
  • Top 10 Contributor
8638 தீர்வுகள் 70669 பதில்கள்
பதிவிடப்பட்டது

Hi jonpal, each person seems to be looking for something a bit different. Could you describe more exactly how you want the drop-down to work?

The blue bar informs you of what Firefox would do if you submit the contents of the address bar right now (either by pressing Enter or clicking the Go button). The bar can be hidden using a custom style rule, but when the bar is hidden the highlight won't move to the next matching item automatically.

With that in mind, would you want to:

  • Hide just the blue bar, keep the rest of the drop-down
  • Hide the entire drop-down, blue bar and all
Hi jonpal, each person seems to be looking for something a bit different. Could you describe more exactly how you want the drop-down to work? The blue bar informs you of what Firefox would do if you submit the contents of the address bar right now (either by pressing Enter or clicking the Go button). The bar can be hidden using a custom style rule, but when the bar is hidden the highlight won't move to the next matching item automatically. With that in mind, would you want to: * Hide just the blue bar, keep the rest of the drop-down * Hide the entire drop-down, blue bar and all
cor-el
  • Top 10 Contributor
  • Moderator
17419 தீர்வுகள் 157388 பதில்கள்
பதிவிடப்பட்டது

You can disable the search by setting this pref to false on the about:config page.

  • keyword.enabled = false

You will get other suggestions instead though.

You can hide the drop-down list with code in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-results { display:none!important; }

You can disable the search by setting this pref to false on the <b>about:config</b> page. *keyword.enabled = false You will get other suggestions instead though. You can hide the drop-down list with code in userChrome.css. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #urlbar-results { display:none!important; } </nowiki></pre> ---- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html

cor-el மூலமாக திருத்தப்பட்டது

jonpal 0 தீர்வுகள் 17 பதில்கள்
பதிவிடப்பட்டது

This appears to work: https://support.mozilla.org/en-US/questions/1251014 On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox). In case you don't want anything to appear under the address bar : Type in the search bar browser.urlbar. Look for the preference : browser.urlbar.maxRichResults And set its value to 0 (= zero) (then close and restart Firefox)

But the larger question, why did firefox alter my preferences when I upgraded to 68.0.1? The pop up blue bar is very distracting.

This appears to work: https://support.mozilla.org/en-US/questions/1251014 On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox). In case you don't want anything to appear under the address bar : Type in the search bar browser.urlbar. Look for the preference : browser.urlbar.maxRichResults And set its value to 0 (= zero) (then close and restart Firefox) But the larger question, why did firefox alter my preferences when I upgraded to 68.0.1? The pop up blue bar is very distracting.