Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google sign in pop-up.

  • 7 majibu
  • 6 wana tatizo hili
  • 172 views
  • Last reply by njbetavirp1

more options

Does anyone know how to configure Firefox to stop the annoying google log-in pop-up? I've seen others ask the same question, but I have not seen any functional answers. I've never had a google account, for anything. I don't get the pop-up with other browsers, like Falcon or Brave. It's just a problem on Firefox. I appreciate you help!

Does anyone know how to configure Firefox to stop the annoying google log-in pop-up? I've seen others ask the same question, but I have not seen any functional answers. I've never had a google account, for anything. I don't get the pop-up with other browsers, like Falcon or Brave. It's just a problem on Firefox. I appreciate you help!

Chosen solution

I found a fix by following a link prvided by jscher2000. The uBlock Origin add-on needs to be installed to Firefox. I made 2 changes in uBlock Origin Preferences. I don't know which change stopped the google sign in pop-ups, So I'll show them both:

Click Firefox's hamburger icon (3 lines) on the right side of the Menu bar. Click Add-ons and Themes. Click the 3 dots on the right side of the UBlock Origin listing, then click Preferences. Click to highlight My filters on uBlock's Menu bar. Click on line 1, in the big open space, and paste: ||accounts.google.com/gsi/*$xhr,script,3p Click the Apply Changes button. I think this is the specific fix, but I also made the following change. Click on the Filter list tab in uBlock's Menu. Scroll down to the line -Annoyances. I put a check in all the boxes in front of anything that had the word Annoyances in the filter name. Click the Apply changes button. Close the uBlock Preferences Firefox tab.

The link that I used: https://www.reddit.com/r/uBlockOrigin/wiki/solutions/#wiki_how_to_apply_filters

My understanding is that a web site that subsribes to the google sign-on service runs a script on Firefox to trigger the pop-up. This fix blocks the script. I'm running Firefox v109.

Read this answer in context 👍 4

All Replies (7)

more options

That isn't coming from either Firefox or Google. What is the site that your using that is causing this? Did you verify this problem in Firefox Private Mode browsing as well?

Modified by Dropa

Helpful?

more options

It is possible that this is a consequence of Total Cookie Protection. Total Cookie Protection isolates (partitions) cross-site cookies and makes Firefox use a separate cookie jar for each website you visit. This will make the Google widget that injects this form on a webpage unaware of interaction on other websites with this form.

More info about Total Cookie Protection.

Helpful?

more options

"Sign in with Google" pops up on most of the websites that offer accounts. My guess is that the web sites subscribe to the Google log in service. Again, it only happens when I'm using Firefox. It dosen't happen with the LibreWolf, Falcon, Brave, or Opera web browsers. I selected Firefox's Private Browsing mode hoping it would help. It didn't. Thanks for the input cor-el. Firefox is not running 'Total Cookie Protection.' I added 'AdBlocker Ultimate' and 'uBlock Origin.' It didn't make any difference. (By the way, cor-el, I use to work for Corel in Utah.) I'm hoping that someone can share an about:config setting to take care of the issue. Thanks for your help.

Helpful?

more options

Total Cookie Protection is one of the levels of cross-site cookie blocking in Firefox's Enhanced Tracking Protection feature. If you want to experiment with adjusting it, you would switch to "Custom" so you can manually select the lower cookie blocking level (the first one on the list):

Many users are using an add-on to hide the login suggestions. For example, see:

Modified by jscher2000 - Support Volunteer

Helpful?

more options

Thanks jscher2000, I wish a cookie setting would stop the annoying Google sign-in pop-ups in Firefox. I have the different cookie settings available in Firefox Settings locked down. I haven't notice that changing any of the cookie settings makes a difference. Except, that after closing the google pop-up, it doesn't reappear again on the same web site until after I delete all cookies and reload the same web site. Apparently closing the google pop-up loads a cookie indicating that it has already been closed once on the site. I hope someone will share an about:config Firefox configuration to disable the google log-in popups.

Helpful?

more options

I found a fix by following a link provided by jscher2000. The uBlock Origin add-on needs to be installed to Firefox. I made 2 changes in uBlock Origin Preferences. I don't know which change stopped the google sign in pop-ups, So I'll show them both:

Click Firefox's hamburger icon (3 lines) on the right side of the Menu bar. Click Add-ons and Themes. https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-02-15-08-28-24-d0df89.png Click the 3 dots on the right side of the UBlock Origin listing, then click Preferences.

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-02-15-08-33-03-8ad5cb.png Click to highlight My filters on uBlock's Menu bar. Click on line 1, in the big open space, and paste: ||accounts.google.com/gsi/*$xhr,script,3p Click the Apply Changes button. I think this is the specific fix, but I also made the following change.

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-02-15-08-33-57-809d09.png Click on the Filter list tab in uBlock's Menu. Scroll down to the line -Annoyances. I put a check in all the boxes in front of anything that had the word Annoyances in the filter name. Click the Apply changes button. Close the uBlock Preferences Firefox tab.

The link that I used: https://www.reddit.com/r/uBlockOrigin/wiki/solutions/#wiki_how_to_apply_filters

My understanding is that a web site that subsribes to the google sign-on service runs a script on Firefox to trigger the pop-up. This fix blocks the script. I'm running Firefox v109. Sorry that I don't know how to make my screeshots show up in the configuration steps, but if you click on the links the screenshots are displayed.

Modified by njbetavirp1

Helpful?

more options

Suluhisho teule

I found a fix by following a link prvided by jscher2000. The uBlock Origin add-on needs to be installed to Firefox. I made 2 changes in uBlock Origin Preferences. I don't know which change stopped the google sign in pop-ups, So I'll show them both:

Click Firefox's hamburger icon (3 lines) on the right side of the Menu bar. Click Add-ons and Themes. Click the 3 dots on the right side of the UBlock Origin listing, then click Preferences. Click to highlight My filters on uBlock's Menu bar. Click on line 1, in the big open space, and paste: ||accounts.google.com/gsi/*$xhr,script,3p Click the Apply Changes button. I think this is the specific fix, but I also made the following change. Click on the Filter list tab in uBlock's Menu. Scroll down to the line -Annoyances. I put a check in all the boxes in front of anything that had the word Annoyances in the filter name. Click the Apply changes button. Close the uBlock Preferences Firefox tab.

The link that I used: https://www.reddit.com/r/uBlockOrigin/wiki/solutions/#wiki_how_to_apply_filters

My understanding is that a web site that subsribes to the google sign-on service runs a script on Firefox to trigger the pop-up. This fix blocks the script. I'm running Firefox v109.

Helpful?

Uliza swali

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.