Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Can't pin extensions to the toolbar using the extension button

  • 1 svar
  • 1 har detta problem
  • 59 visningar
  • Senaste svar av maria lopez

more options

Hello folks

According to Firefox help pages, pinning an extension to the toolbar should work as follows:

"Click the extensions button (jigsaw puzzle Fx109ExtensionsButton icon) in the toolbar to open the extensions panel. Each extension in the panel has a menu button with a gear Fx91GearIcon icon. You can use this menu button to manage those extensions."

The extensions button doesn't seem to work like that for me. When I click the Extensions button I get several buttons (Recommendations, Extensions etc) on the left side of the page as in the first image attached (Firefox1).

If I then click the Extensions button I get to the Manage Extensions page, and if I then click the 3 dots (...) button on (say) Proton Pass I don't get a Pin to Toolbar option and clicking the Manage option opens the Proton Pass Details page (see image Firefox2) - none of the buttons on the any of the pages offers a Pin to Toolbar option.

Those extensions that are pinned to the toolbar, such as Adblock Plus ( see Firefox2 image), got pinned during installation and not by using the extensions button. Currently I seem to have no way of interacting with any extension via the extensions button.

Could be I'm doing something silly but any suggestions would be appreciated.

Regards Ken

Hello folks According to Firefox help pages, pinning an extension to the toolbar should work as follows: "Click the extensions button (jigsaw puzzle Fx109ExtensionsButton icon) in the toolbar to open the extensions panel. Each extension in the panel has a menu button with a gear Fx91GearIcon icon. You can use this menu button to manage those extensions." The extensions button doesn't seem to work like that for me. When I click the Extensions button I get several buttons (Recommendations, Extensions etc) on the left side of the page as in the first image attached (Firefox1). If I then click the Extensions button I get to the Manage Extensions page, and if I then click the 3 dots (...) button on (say) Proton Pass I don't get a Pin to Toolbar option and clicking the Manage option opens the Proton Pass Details page (see image Firefox2) - none of the buttons on the any of the pages offers a Pin to Toolbar option. Those extensions that are pinned to the toolbar, such as Adblock Plus ( see Firefox2 image), got pinned during installation and not by using the extensions button. Currently I seem to have no way of interacting with any extension via the extensions button. Could be I'm doing something silly but any suggestions would be appreciated. Regards Ken
Bifogade skärmdumpar

Vald lösning

Hi Ken, the button will load the Add-ons page if there is nothing on the drop-down list.

it looks like your first three extensions are already pinned to the toolbar. When you do that, they no longer appear on the drop-down.

So the question is why the fourth extension doesn't appear on the drop-down. I'm going to speculate here...

The only thing I notice is that it doesn't have the mask icon indicating that it is allowed to run in private windows. More info on that issue: Extensions in Private Browsing. Maybe you are browsing Firefox in a private window ("Never Remember History" mode)?

Läs svaret i sitt sammanhang 👍 2

Alla svar (1)

more options

Vald lösning

Hi Ken, the button will load the Add-ons page if there is nothing on the drop-down list.

it looks like your first three extensions are already pinned to the toolbar. When you do that, they no longer appear on the drop-down.

So the question is why the fourth extension doesn't appear on the drop-down. I'm going to speculate here...

The only thing I notice is that it doesn't have the mask icon indicating that it is allowed to run in private windows. More info on that issue: Extensions in Private Browsing. Maybe you are browsing Firefox in a private window ("Never Remember History" mode)?

Hjälpsam?

Ställ en fråga

Du måste logga in på ditt konto för att svara på inlägg. Vänligen starta en ny fråga om du inte har ett konto ännu.