Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Firefox extremely slow on some sites

  • 15 odpovedí
  • 0 má tento problém
  • 913 zobrazení
  • Posledná odpoveď od jonzn4SUSE

more options

Hi, I just replaced my SSD (Samsung 960EVO m.2 250Gb) for a larger/faster SSD (Samsung 980 m.2 1Tb) . I'm on Windows 10 and have 32Mb Ram. Firefox is now very slow on some websites (not all).

This example is typical and has occured on multiple sites. To test and compare, I copied the URL, created a new tab in Firefox, then Paste and Go. I timed this 3 times and each time was 30 seconds. I Pasted the same into Chrome and Edge and each time it was instant. https://savingschampion.co.uk/best-buys/personal/easy-access-accounts

On my previous SSD, there was never an issue of any lag on any site.

BBC.co.uk/news is fine, as are several other sites. Does anyone have any idea what's happening? This is making Firefox unworkable for me, so unless I can fix the issue, I will have to move permanently to Chrome or Edge. That would be a shame after many years with Firefox.

Thank you in advance.

Hi, I just replaced my SSD (Samsung 960EVO m.2 250Gb) for a larger/faster SSD (Samsung 980 m.2 1Tb) . I'm on Windows 10 and have 32Mb Ram. Firefox is now very slow on some websites (not all). This example is typical and has occured on multiple sites. To test and compare, I copied the URL, created a new tab in Firefox, then Paste and Go. I timed this 3 times and each time was 30 seconds. I Pasted the same into Chrome and Edge and each time it was instant. https://savingschampion.co.uk/best-buys/personal/easy-access-accounts On my previous SSD, there was never an issue of any lag on any site. BBC.co.uk/news is fine, as are several other sites. Does anyone have any idea what's happening? This is making Firefox unworkable for me, so unless I can fix the issue, I will have to move permanently to Chrome or Edge. That would be a shame after many years with Firefox. Thank you in advance.

Vybrané riešenie

Thanks, mark it as resolved and have a good day.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (15)

more options

That should be 32Gb Ram

more options

Do you have the same issue with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Can you post a screenshot and also try this add-on to show the load times. see screenshot https://addons.mozilla.org/en-US/firefox/addon/load-time/?utm_source=addons.mozilla.org&utm_medium=referral&utm_content=search

What security software are you running?

Upravil(a) jonzn4SUSE dňa

more options

Hi, thank you for your response and your help. Firefox in safe mode (troubleshooting mode) made no difference. I've installed the add-on you suggested and attached a screenshot of loading times for https://savingschampion.co.uk/best-buys/personal/easy-access-accounts. Again the same, almost exactly 30 seconds. Every time. I'm using Avira Security Free and Malwarebytes 4.5.19. Windows 10 is up to date. I was using exactly the same programs on my previous SSD, without any delays. The same sites that Firefox has a delay with, Chrome and Edge are still opening withou delay. Thank you.

more options

Here's another screenshot of the load times for https://www.bbc.co.uk/news While the page loads without detlay, the busy icon is visible in the tab for 30 seconds (consistently, I've timed it) and the load times data is not available for 30 seconds.

more options

Thanks for the update. Can you disable those security apps, reboot, and try again? Also, just curious to know who you are using for DNS?

more options

Thank you again for your help.

I rebooted, then stopped Avira and quit Malwarebytes. It was the same as before. 30 second delay. It's odd that it's 30 seconds for some sites consistently. But when I clicked on the bookmark to bring me to this page, it was instant.

I don't understand about DNS. I have no knowledge of that.

more options

Have a look at this site and go down to the section that says "How Do I Check My DNS Settings in Windows?". https://www.lifewire.com/check-dns-settings-5215603

more options

Go to this page and click the button to clear DNS. see screenshot You can also Refresh Firefox to see if it helps, but read the warning on the page. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Upravil(a) jonzn4SUSE dňa

more options

Did you transfer Firefox files like the profile folder to the new drive or did you start with a fresh profile and only transfer some data files?


You can copy certain files with Firefox closed to the current profile folder to transfer or recover personal data. Note that best is to avoid copying a full profile folder.


  • bookmarks and history: places.sqlite
  • favicons: favicons.sqlite
  • bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder
  • cookies.sqlite for the Cookies
  • formhistory.sqlite for saved autocomplete Form Data
  • logins.json (encrypted logins;32+) and key4.db (decryption key;58+) for Passwords saved in the Password Manager
    key3.db support ended in 73+; to use key3.db in 58-72, make sure to remove key4.db
  • cert9.db (58+) for (intermediate) certificates stored in the Certificate Manager
  • persdict.dat for words added to the spell checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences)
  • sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)
more options

Hi Johzn, thanks again. I've attached a screenshot of the DNS settings, as directed in your first link. It means nothing to me. I visited the 2nd link and reset Firefox (which I presume resets DNS, as I saw no button for it). It has made no difference. I also checked DNS settings in the Command Prompt after resetting Firefox, but they are the same.

Hi Cor-el, thank you also. I did a clean install of Windows 10 onto the new SSD. Then did all the updates. Then a clean install of Firefox by downloading the latest version from their site. I imported Bookmarks from a .json file that I created from within Firefox before replacing the old SSD. I restored passwords from a .csv file that I also created from within Firefox before replacing SSD.

After the Firefox reset I have no extensions installed, but I never had many anyway. The only 2 plugins are the Open H264 that Mozilla automatically installs, and Widevine Content Encryption Module by Google.

I've just checked again and some sites respond instantly, but other sites, like https://savingschampion.co.uk/news/savings-news/what-can-savers-expect-in-2023 take almost exactly 30 seconds.

I'm guessing that one possible cause could be the bookmarks and logins, but all I know is that I created the .json and .csv from within Firefox. I know nothing about key3.db, key4.db etc. I kept Firefox up to date so it would have been the latest version on 3/1/23, when I did the SSD swap. So I would imagine they would be compatible.

Many thanks again. I've now set Chrome as my default browser, but would love to return to Firefox if this gets resolved.

more options

As a test, change the DNS to 1.1.1.1 / 1.0.0.1 and see if it makes a difference. Also need to make this change on our modem and or router.

How to Change DNS Servers in Windows https://www.lifewire.com/how-to-change-dns-servers-in-windows-2626242

Change the DNS servers on your router https://www.lifewire.com/how-to-change-dns-server-settings-2617979

Upravil(a) jonzn4SUSE dňa

more options

Hi Jonzn, Thank you for all your help and suggestions.

I'm with Virgin Media and on the Virgin Community I've read conflicting reports that you can't change the DNS on the hub 3.0, that I have. In any case, it looks quite involved and not something I'm comfortable with. I don't want to cause other problems (by my own errors).

Apart from Firefox and the random, but consistent, 30 second delays, the whole system, including Chrome and Edge are working perfectly. I don't want to take up any more of your time trying to solve an issue that I don't have to solve.

So thank you again, most sincerely, for your help and expertise and I'm sorry we didn't get to solve the problem.

Many thanks.

more options

You can check the Timings in the Network Monitor.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Hi Jonzn and Cor-el, I've not used Firefox since my last post, 12 days ago, but tried it again today and it's working fine again. The same links that I've referenced above, that took a consistent 30 seconds to load, now open instantly. Nothing has changed in the last 12 days. I'm using exactly the same programs (as I was before the new SSD and reinstall of Windows). So still a mystery, but thanks again for your help and suggestions. I thought I'd let you know.

more options

Vybrané riešenie

Thanks, mark it as resolved and have a good day.