Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

UI scale changing after Youtube fullscreen

  • 2 replies
  • 0 have this problem
  • 10 views
  • Last reply by axel123

more options

(sorry for my english)

I recently uprgraded Firefox from 102.0.1 to 109.0.1. UI went bigger, but I already searched that I had to create ui.textScaleFactor and set to 100 in about:config and to change browser.display.os-zoom-behavior to 0.

After these changes UI went normal again. Except one case: when I go to youtube and go fullscreen, then when I go back from fullscreen, my UI is going to bigger again - despite ui.textScaleFactor is 100 and browser.display.os-zoom-behavior is 0.

I need to restart Firefox and after restarting everyhing is normal (UI is not big).

The problem is: UI is going to bigger after youtube fullscreen and I need to restart the browser to go back to normal.

(sorry for my english) I recently uprgraded Firefox from 102.0.1 to 109.0.1. UI went bigger, but I already searched that I had to create ui.textScaleFactor and set to 100 in about:config and to change browser.display.os-zoom-behavior to 0. After these changes UI went normal again. Except one case: when I go to youtube and go fullscreen, then when I go back from fullscreen, my UI is going to bigger again - despite ui.textScaleFactor is 100 and browser.display.os-zoom-behavior is 0. I need to restart Firefox and after restarting everyhing is normal (UI is not big). The problem is: UI is going to bigger after youtube fullscreen and I need to restart the browser to go back to normal.

All Replies (2)

more options

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting.

more options

willjoe24421 said

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting.

I changed this now, but no results. Still UI too big after coming back from YT fullscreen. But thanks for reply.