Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Эта тема была закрыта и архивирована. Если вам нужна помощь, задайте новый вопрос.

How do I install version 28 over 29?

  • 55 ответов
  • 42 имеют эту проблему
  • 1740 просмотров
  • Последний ответ от John99

more options

I want to return to version 28. Version 29's interface is hideous. I installed the add-on which supposedly makes it look like version 28, but it doesn't.

I have downloaded version 28. All I need to know is: Do I uninstall version 29 before installing version 28, or can I install version 28 over version 29 without uninstalling it first? I want to keep all my bookmarks.

I have already turned off automatic updates.

Выбранное решение

Oh, you know something, I'm embarrassed to say this, but fooling around with the options for that add-on has allowed me to get FF looking ALMOST like it did before. Not quite as good, but almost as good. Maybe I should keep 29. (It still looks clunkier.)

The problem, however, is that too many add-ons can make the program unstable, and now I have one more add-on in the mix.

 Modified May 10, 2014 5:18:08 AM BST by Purebeads

And a closing comment from a Moderator including a resources link see /questions/999759?page=3#answer-582363

Прочитайте этот ответ в контексте 👍 0

Все ответы (20)

more options

The CTR can make it look much the same with some added extras even. Have you gone into the CTR options?

Notes that Firefox 28.0.1 is behind on security fixes. http://www.mozilla.org/security/known-vulnerabilities/firefox.html

more options

It is highly NOT suggested to return back to version 28 due to security issues and bugs that are present. Support for 28 will not be provided, if you find a way to install 28 back on, that is all up to you.

However, we are open to listen to suggestions to make Firefox 29 better.

Изменено Andrew

more options

I am not the SLIGHTEST BIT INTERESTED in being warned not to go back to version 28. Firefox provides old versions to the public, and I have already downloaded version 28. NOW PLEASE ANSWER MY QUESTIONS. Do I have to uninstall version 29 before installing version 28, or can I install version 28 over 29. Will I lose my bookmarks?

Mozilla is causing me a huge amount of trouble at a time that I am very busy. Now just ANSWER MY QUESTIONS.

more options

You can directly install 28 over, however this goes not guarantee that things will be the same. Your bookmarks should remain okay as long no profile or data deletion is made.

Thank you for your time.

more options

Why SHOULDN'T things be the same???

more options

Things roll along smoothly when an upgrade is done but when you want to go back, there are bits and pieces that may get lost and/ or may stop working and functioning. Not to worry, you can still install 28 over 29.

more options

Bits and pieces may get lost? What does that mean?

more options

I have a suggestion. Please allow an option within Firefox to select the interface you want.

I have spent years adjusting my toolbars, settings and plugins under the old interface. Strange as it may sound, the look of the interface is a deeply personal thing that is important to me. I put a lot of work into it, and really enjoyed the way I had it set up.

But this new update forced me to lose everything! It didn't ask first. It didn't say "Would you like to try a new interface?" I was given no option, no choice. Firefox just automatically downloaded an update and completely destroyed everything I had set up.

As I said, my setup was very personal and important to me, and this update sends a message that Mozilla don't care about that.

PS: I've tried all the plugins like Classic Theme Restorer and worked my way through the guides online, and I can promise you that it is NOT possible to get the theme looking just the way it did before. And certainly not the way it did for me.

more options

I definitely feel and understand your frustration. I cannot speak on behalf of the developers or engineers that created this new version. However, the classic theme restorer will restore some items but obviously not all.

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.

more options

Andrew, I want to know what "bits and pieces" may be lost if I reinstall version 28. Give me an answer please.

more options

With an upgrade, new things are installed, the new items installed and created on 29 should be not be automatically deleted when you revert to 28 and therefore those bit and pieces may cause Firefox to not perform properly.

more options

Purebeads,

I have reinstalled version 28 myself, and all seems to be running OK. All my bookmarks are there, my bookmarks toolbar (and its contents) are all there. All settings seem to be set back to how they were before the v29 update. My history is there, and my plugins seem OK. In other words, downgrading to version 28 went without any obvious hitches, and I'm happy.

Изменено sunkencathedral

more options

Sunkencathedral, thank you for that feedback. I guess I'll take my chances. On Mozzillazine, they say to uninstall first.

One of the changes I made was I removed the icons from my bookmarks so I could have more horizontal room, and I would hate to have to go through all those customizations again.

Изменено Purebeads

more options

Simmply reinstalled FF 28. Worked great. For around 4 years now I have had to train and show many hundreds of people how to make forefox work properly with addon features like Tab mix plus and how to put there tabs below so they could improve there work productivity becouse they just didnt know any better way existed. With over a million people now having downloaded the new classic restore addon in order to get just ONE FEATURE "TABS BELOW" It defies logic that the Firefox Developers either dont know how to use a browser properly or dont care. They are sheep following Internet explorer and google down a black hole of stupidity. I use Firefox becouse its different and its able to work the way I like with TABS BELOW. Firefox 29 lasted aproximately 5 minutes before I went back to FF 28. I would happily use FF 29 but ONLY if tabs are below. This should not require an addon. Tabs below should be the standard and it would be the defining feature that makes firefox stand out. The inability to have tabs below is the very reason I Dont use other browsers. If a petition to get tabs below is made just how many signatures do we need to get the developers to listen. What does it take for the developers to listen to its users. I just dont get why this has gone down the path of becomming more and more like crome and internet explorer both of which I utterley hate becouse I cant put tabs below and organise things in the same way I have always been able to do in Firefox. Where has the difference gone. May as well rebadge as "crome clone" or "baby IE". Please listen to your users and fix this issue as some of us do know a better way and its TABS BELOW

more options

I did not uninstall v29 before installing v28, and things seem fine. I can't say for certain whether everything is perfect 'under the hood', but things definitely look and seem fine. All my customizations seem to be there, and performance seems the same as usual.

more options

Steve1084, when you say "tabs below", you mean the tabs right above the windows? That's the way I want it too. This business of putting tabs above the address bar and bookmarks is ridiculous. I installed that add-on, and the tabs look clunky and stupid -- much larger than they looked before. Ever since Windows XP, interfaces have looked like they were designed for children. And now Firefox is doing it too.

By the way, the most stable version of FF that I ever used was version 2. It has been downhill since then.

Thanks again, Cathedral.

Изменено Purebeads

more options

By the way, what would happen if I installed version 28 in an entirely new directory, leaving 29 in place but not using it? What would happen then?

Изменено Purebeads

more options

Выбранное решение

Oh, you know something, I'm embarrassed to say this, but fooling around with the options for that add-on has allowed me to get FF looking ALMOST like it did before. Not quite as good, but almost as good. Maybe I should keep 29. (It still looks clunkier.)

The problem, however, is that too many add-ons can make the program unstable, and now I have one more add-on in the mix.

 Modified May 10, 2014 5:18:08 AM BST by Purebeads

And a closing comment from a Moderator including a resources link see /questions/999759?page=3#answer-582363

Изменено John99

more options

I have also abandoned 29 for the moment, although the user interface changes are annoying I have given up because of the removal of security with a master password.

With 29, anyone who can open my browser can see all my usernames and passwords in plain text if I want to keep syncing passwords!

Instead of going back to 28, you might want to look at 'Pale Moon', a fork of FF26.

more options

You truly want to make it better? Fix the bugs and security issues that you know about in 28 or make 29 look like 28. Your Chrome Clone sucks to say the least.

I reloaded 28 earlier today, turned off auto update and still had 29 over rule and download again! Is this a "new" bug or are we being force fed???

Redid my lap top this morning to 28, turned of auto update, and guess what? Just turned it back on and there was 29!!!!!

Изменено rsc0155

  1. 1
  2. 2
  3. 3