Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

"Firefox will" setting reverts to "Never remember history" on Firefox restart

  • 3 ответа
  • 8 имеют эту проблему
  • 3 просмотра
  • Последний ответ от cor-el

more options

I am using Firefox 26 on Windows XP. The Privacy -> History -> "Firefox will" setting refuses to be anything but "Never remember history". When I try to change the drop down's value to "Remember history" I get a pop up saying "Firefox must restart to disable this feature". On clicking "Ok" Firefox restarts but the expected behavior of the setting changing to "Remember history" never happens. The value of "Firefox will" is still "Never remember history". I tried "Use custom settings for history" and unchecking "Always use private browsing mode" but the exact same thing happens. It says to restart Firefox but even after restart "Always use private browsing mode" is still checked. So the end result is that I am forever stuck with none of my history being remembered. I tried using safe mode and resetting Firefox still no effect.

Все ответы (3)

more options

Your System Details List shows browser.privatebrowsing.autostart: True
This indicates that Private Browsing mode is active.

"Always use private browsing mode" will have a tick in this case.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Always use private browsing mode"

Note that Firefox will show "Use custom settings for history" when at least one of the history and cookie settings do not have the default value.
You only see remember history or never remember history when all settings are the default.

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

more options

I tried the following and none of them works: 1. Renamed pref.js 2. Deleted pref.js 3. Modified the value of browser.privatebrowsing.autostart to false from about:config 4. Modified the value of browser.privatebrowsing.autostart to false from pref.js file On successive restarts something is automatically changing he value of browser.privatebrowsing.autostart to true, don't know who and why.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.