Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

non-xpi addons only install in the first profile - e.g. Flashplayer

  • 4 ответа
  • 2 имеют эту проблему
  • 6 просмотров
  • Последний ответ от Sundari-Experts01

more options

I've noticed that several question are being asked about Flashplayer not popping up in the Plugin screen, even after reinstalling.

IMO it has to do with non-xpi installers for users who have multiple profiles.

I have two profiles : Default (created at installation) & Me When installing/removing Flashplayer the Plugin appears/disappears only in the "Default" profile, eventhough the installation was started from the "Me" profile. Selecting a specific profile and indicating in Profilemanager not to ask the profile selecting does not change the behaviour.

Does anyone have an idea of how I can force non xpi addons to install its libraries in a particular profile? Or is it possible to "copy/paste" a plugin from one profile to another.

I've noticed that several question are being asked about Flashplayer not popping up in the Plugin screen, even after reinstalling. IMO it has to do with non-xpi installers for users who have multiple profiles. I have two profiles : Default (created at installation) & Me When installing/removing Flashplayer the Plugin appears/disappears only in the "Default" profile, eventhough the installation was started from the "Me" profile. Selecting a specific profile and indicating in Profilemanager not to ask the profile selecting does not change the behaviour. Does anyone have an idea of how I can force non xpi addons to install its libraries in a particular profile? Or is it possible to "copy/paste" a plugin from one profile to another.

Выбранное решение

There is a preference you can toggle in about:config to prevent Firefox from checking the Windows registry for plugins. By default, this is true but setting it to false will cause Firefox not to pick up Flash and other plugins that advertise their availability in the registry: plugin.scan.plid.all Could you check for that?

Прочитайте этот ответ в контексте 👍 2

Все ответы (4)

more options

On Windows, the Flash player plugin DLL is under C:\Windows. When everything is working correctly, Firefox finds the Flash player by checking entries under a registry key. I don't know whether this check takes place every time Firefox restarts, or at other intervals.

Other plugins may install differently, e.g., copying a DLL into a folder under c:\Program Files (x86). It's rare for a plugin to be profile-specific.

If your plugin list is not updating, the pluginreg.dat file that stores plugin information might be corrupted. This article has a section on how to delete that file so Firefox will regenerate it: https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix.... Does that help?

more options

I agree that it is rare for a plugin to be profile specific. What I see however is that one profile does have Flash and several other plugins whereas the other profile does not.

Removing the plugin DB for regeneration is described in many articles but was no help. Uninstalling Flash was the easiest to test. I uninstalls correctly from profile 1 (not present in profile 2). When reinstalling it, it again appears only in profile 1 and not in profile 2.

Creating a new profile 3, imports all Plugins like in Profile 1.

I can create additional profiles but I want to understand what is happening to Profile 2.

Изменено Sundari-Experts01

more options

Выбранное решение

There is a preference you can toggle in about:config to prevent Firefox from checking the Windows registry for plugins. By default, this is true but setting it to false will cause Firefox not to pick up Flash and other plugins that advertise their availability in the registry: plugin.scan.plid.all Could you check for that?

more options

The plugin.scan.plid.all was set to false -- changing it back to true solved the issue.


TNX !