Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox 12 keeps starting in full-screen mode.

  • 3 ответа
  • 14 имеют эту проблему
  • 14 просмотров
  • Последний ответ от David Shochat

more options

Ever since upgrading to Firefox 12, it wants to start up in full screen mode. I dopn't mean the extreme full screen mode where even the menu bar is hidden. I mean the more "typical" full screen mode where it just gets as large as possible but has the same content. I tried forcing a new profile (by renaming. ~/.mozilla/firefox) and that fixed it. But then as soon as I brought back the bookmarks toolbar and exited, it was back to starting in full screen mode again. I wish there was something in preferences for this. I NEVER want it to start in full screen mode. This is Ubuntu 11.10.

Ever since upgrading to Firefox 12, it wants to start up in full screen mode. I dopn't mean the extreme full screen mode where even the menu bar is hidden. I mean the more "typical" full screen mode where it just gets as large as possible but has the same content. I tried forcing a new profile (by renaming. ~/.mozilla/firefox) and that fixed it. But then as soon as I brought back the bookmarks toolbar and exited, it was back to starting in full screen mode again. I wish there was something in preferences for this. I NEVER want it to start in full screen mode. This is Ubuntu 11.10.

Выбранное решение

Last night I upgraded to Ubuntu 12.04 (aka Precise Pangolin), and the problem has disappeared. No more auto maximize on startup.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See also:

more options

Thanks for your reply. It does not maximize (I think that's the term I should have used) when starting in safe mode. But I think the reason is that it has a smaller window when it starts in safe mode. If I increase the size of the window beyond a certain point, then when I exit and restart FF, it auto-maximizes. If I delete localstore.rdf, again it comes up not auto-maximized. But again, if I make the window a little bigger, exit and restart, then it does come up auto-maximized. And if I make it smaller before exiting, it will come up properly. I really believe this is a Ubuntu/Unity problem. Unity has a very irritating tendency to maximize windows all on its own. When I upgrade to Ubuntu 12.04, I'm hoping there will be an easy way to tell it not to do this.

more options

Выбранное решение

Last night I upgraded to Ubuntu 12.04 (aka Precise Pangolin), and the problem has disappeared. No more auto maximize on startup.