Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

why do added buttons jump to the right in full screen

  • 7 ответов
  • 1 имеет эту проблему
  • 16 просмотров
  • Последний ответ от E_Pericoloso_Sporgersi

more options

I've added 3 add-on buttons and 1 command-button to the navigation toolbar:

  1. Web of Trust
  2. Adblock Plus
  3. NoScript
  4. Full Screen toggle

When I toggle Firefox 6 to full screen these 4 buttons jump to the extreme right.

Why does Firefox 6 do that? It is somewhat annoying. This did not happen in Firefox 4.1 and earlier. Please compare the two screenshots on screenshot 1 screenshot 2

Изменено E_Pericoloso_Sporgersi

Выбранное решение

Looks that you have added those buttons to the right of the fullscreenflex hbox that normally causes only the Windows control buttons to be shifted to the right corner.

You can try to remove all those toolbar buttons and re-add them one at a time to see if they still appear at the far right.

See also:

Прочитайте этот ответ в контексте 👍 0

Все ответы (7)

more options

Maybe Full Screen toggle add-on is doing that.

Troubleshooting extensions and themes

Check and tell if its working.

more options

No joy there.

BTW Full screen toggle is NOT an add-on. It's a standard Firefox feature.

more options

you mentioned in your Question Message that I've added 3 add-on buttons and 1 command-button to the navigation toolbar:

  • Web of Trust -> Adblock Plus -> NoScript -> Full Screen toggle

Okay i misunderstood. i thought that you are using some add-on called Full Screen toggle. Sry about that..

Изменено Hasan

more options
more options

I already visited all trouble-shooting pages you suggested. None resolved my complaint.

Oh well, I can live with it and I'm already getting used to it. Besides this negligible little quirk, Firefox 6 works very well indeed.

In any case, thank you kindly for your support.

Изменено E_Pericoloso_Sporgersi

more options

Выбранное решение

Looks that you have added those buttons to the right of the fullscreenflex hbox that normally causes only the Windows control buttons to be shifted to the right corner.

You can try to remove all those toolbar buttons and re-add them one at a time to see if they still appear at the far right.

See also:

Изменено cor-el

more options

Thanks, cor-el.

Your note "Looks that you have added those buttons to the right of the fullscreenflex hbox that normally causes only the Windows control buttons to be shifted to the right corner." pointed me to a solution.

I simply put my additional buttons to the left of the navigation bar. See screenshot 3 and screenshot 4

Problem solved. Thanks again.