Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How can I make my Composition window look like my Reader one, without forcing that onto recipients?

  • 16 ответов
  • 1 имеет эту проблему
  • 31 просмотр
  • Последний ответ от Gordon Lack

more options

I like to have a dark theme (I do not wish to be dazzled by lots of bright white backgrounds).

But if I do that then the reader window is white on black, which I do no like. I prefer almost-black on light-grey. I can set this up. However, what I cannot do is set this in my Composition window without forcing those same colours onto all recipients, as the <body> tag ends up with my text="" and bgcolor="" tags on it.

If I set "Use reader's default colours" then I end up with the default colours from the reader (white on black) not what I have set (although this does remove the text and bgcolor tags).

So the problem I have is can either set the default colours in my Composition windows to what I am comfortable with or I can set them such that recipients can view them as they wish. But I cannot do both.

Is it possible to set the text and background colours form with a Theme? (Indeed, where is the documentation which describes what is settable within a Theme?).

I like to have a dark theme (I do not wish to be dazzled by lots of bright white backgrounds). But if I do that then the reader window is white on black, which I do no like. I prefer almost-black on light-grey. I can set this up. However, what I ''cannot'' do is set this in my Composition window without '''forcing''' those same colours onto all recipients, as the <body> tag ends up with my text="" and bgcolor="" tags on it. If I set "Use reader's default colours" then I end up with the default colours from the reader (white on black) not what I have set (although this does remove the text and bgcolor tags). So the problem I have is can ''either'' set the default colours in my Composition windows to what I am comfortable with ''or'' I can set them such that recipients can view them as '''they''' wish. But I '''cannot do both'''. Is it possible to set the text and background colours form with a Theme? (Indeed, where is the documentation which describes what is settable within a Theme?).

Выбранное решение

I've found a workaround (for me - not generally useful).

I have an Extension, BorderColors D (https://addons.thunderbird.net/en-GB/thunderbird/addon/bordercolors-d/), installed which decorates the Compose editor window with a colour based on the sending account. One of its colouring options is to set the background colour.

So I've modified this to add in the css code for the compose colours I want to all of its other options. Things now look as I want them to.

Прочитайте этот ответ в контексте 👍 0

Все ответы (16)

more options

There may be other options, but I have found that using the dark theme and the 'dark reader' addon works perfectly (for me, at least).

more options

Doesn't seem to solve my problem as it has no effect on the Composition window, which is where I have the issue.

more options

Puzzling. I have all colors set to default (black text, white background) and did only two things: - changed to dark theme and added the 'dark reader' addon. There are options in Dark Reader and may need to be reviewed.

more options

Odd. As soon as I select a Dark Theme (any dark theme, as far as I can see) the default text becomes white on black in both the reader and composition windows.

more options

I've tracked down the Composition window message area in the Developer tools inspector.

It's picking up its colours from editorContent.css line 100. @media: (prefers-color-scheme: dark}, which sets color: #f9f9fa and background-color: #2a2a2e.

If I switch to the system Light theme (or Auto) then this item goes away.

more options

If you have the skills to track it down, use those to create a userchrome.css file to set it to what you want it to be. http://kb.mozillazine.org/UserChrome.css

Make sure to toggle the preference toolkit.legacyUserProfileCustomizations.stylesheets in the config editor

more options

Matt said

If you have the skills to track it down, use those to create a userchrome.css file to set it to what you want it to be.

That might be a problem as I do not want it to set this at all, and I can't think of a way to override a CSS setting with something that results in it not being set.

more options

Actually, if I could set the colours in css while leaving the config to believe it is using the default it might work.

But I can't get TB to use the values (I can see that it is reading the file).

Even a catch-all:

   body: {
       color: #2a2a2e !important;
       background-color: #f9f9fa !important;
   }

is ignored.

more options

Ignore the extraneous ":" after "body" above.

I can edit those values in using the Dev Tools Inspector and it changes to what I'd expect. But putting that into a userChrome.css file does nothing.

more options

HOWEVER.

Adding this to userContent.css does have an effect! (Although putting it inside a @media () {..} selection doesn't work).

But the result is of no use, as this affect ALL body elements, so it messes up things like the Settings/Preferences pages - making the left-hand section choice panel unreadable.

So unless there is a way to specify the one body I want, this isn't going to work.

more options

The bottom line is this - if you set html css in email then it is in email. So if you are creating and sending in HTML format then the recipient will get email with the html you inserted.

However, it does not matter if you create email using html formatting to control what you see, it's all about how the email is sent. If you send email only using plain text then all the formatting should get stripped. So set up the colours you want to use, then alter the 'Sending Format' options. Choose 'Only Plain Text'

If you choose to send using Sending Format option 'Both HTML and Plain Text' Then the recipient can choose to view either in HTML and see your choice of colours Or view it as Plain Text which strips all formatting OR maybe they are techno savvy enough to have configured to overirde whatever you have inserted in html.

more options

Toad-Hall said

The bottom line is this - if you set html css in email then it is in email.

But I'm not setting it. All I'm setting is what I want to see whilst composing! If I set it to use the default reader colours it doesn't set anything in the <body> tag. The problem is that it doesn't use my reader colours when I set this.

If you send email only using plain text then all the formatting should get stripped.

Which doesn't help at all when I wish to send html messages (with link, formatting and images...)

more options

re :The problem is that it doesn't use my reader colours when I set this.

OK I've tested this in current release version 112.12.0 and also in current beta 115.0b5 and I completely agree. 'Use Readers colours' is not being used. It seems to be using 'system colours'.

But I also see an additional bug with the Formatting bar foreground and background colour icons. I've created a bug report which you can follow or add any relevant information. https://bugzilla.mozilla.org/show_bug.cgi?id=1841302

more options

Regarding the bug - We shall have to wait and see what transpires.

Currently I suggest you choose the colours you want to use in the Composition HTML Style area and then make sure the Sending Format is using 'Both HTML and Plain Text.'

After all your choice of colours is reasonable for most people who want to always see html and if they do not then they have other options available - use the Plain Text option you provided OR set up their own override options.

more options

Toad-Hall said

I've created a bug report which you can follow or add any relevant information. https://bugzilla.mozilla.org/show_bug.cgi?id=1841302
I'd already created:

https://bugzilla.mozilla.org/show_bug.cgi?id=1841263 so I'll link them up.

btw: I don't set up my reader colours to "override always". I set it to "never". I'll use something if a user sends it, but all I'm trying to set is what my default looks like - in both reading and composing.

Odd that I can't get Descendant Selectors to work (in userContext.css). I reckon that:

#messageEditor body {
   color: #2a2a2e !important;
   background-color: #f9f9fa !important;
}

should do what I want, but only a Sibling Selector ( html > body) works, and that finds far too many matches.

Изменено Gordon Lack

more options

Выбранное решение

I've found a workaround (for me - not generally useful).

I have an Extension, BorderColors D (https://addons.thunderbird.net/en-GB/thunderbird/addon/bordercolors-d/), installed which decorates the Compose editor window with a colour based on the sending account. One of its colouring options is to set the background colour.

So I've modified this to add in the css code for the compose colours I want to all of its other options. Things now look as I want them to.

Изменено Gordon Lack