Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Thunderbird email signature not showing images

  • 25 ответов
  • 2 имеют эту проблему
  • 781 просмотр
  • Последний ответ от rsl29

more options

I hope someone can help me. Up until the last week or so, I have had no problem with my signature file in outgoing email. I've been using the same signature file for at least 5 years. Suddenly, Thunderbird is blocking my logo image in my signature file in all outgoing mail. Instead, it is showing my alternate text. I am using version 102.6.1 on Windows 10

I hope someone can help me. Up until the last week or so, I have had no problem with my signature file in outgoing email. I've been using the same signature file for at least 5 years. Suddenly, Thunderbird is blocking my logo image in my signature file in all outgoing mail. Instead, it is showing my alternate text. I am using version 102.6.1 on Windows 10

Выбранное решение

re :I clicked on 'Write' then opened image properties and re-selected the relevant images and saved the changes as advised but, when I opened a new Write window the images did not appear!

Close original Write window after saving as html file Then access Account Settings, click on the 'Choose' button and reselect the newly updated DA Signature html file because you need to use the updated version. I'm presuming info stored in any cache is not the updated file. Then open a new Write message.

Прочитайте этот ответ в контексте 👍 0

Все ответы (20)

more options

Just possibly, if you post the actual source HTML code, someone here may have suggestions.

more options

Pardon my ignorance but, what is the source HTML code, please?

more options

The signature file that shows an image is constructed of HTML code. To suggest changes to allow the image to appear requires seeing the code itself.

more options

Okay, where do I find it, please?

more options

The signature is often stored at the account pane, the same one that shows name and email address.

more options

Is this it, it looks too simple? C:\Users\david01\Desktop\Signatures\DA Signature.html

more options

Your signature content is supplied by that HTML file and it is the source of that which is what David was hoping to see.

But before going that far, what version of Thunderbird are you using right now? (more troubleshooting information on the help menu will show the version as the first entry after the application name). There are bugs affecting signatures in the 102.x series, so knowing where you are is important.

more options

The sig is probably in the file named DA signature.html and it should appear in the account settings pane. Sharing the contents of that may help. You state you are using 102.6.1. Please post the content. I defer to @matt on possible complications created by ver 102.

more options

Hi Matt and David, I am on version 102.7.1 964 bit) which apparently was addressing the issue that I am having but it hasn't solved the problem. Curiously, a second PC in our office is on 102.7.1 (32 bit) and is not having the problem!

more options

RE: Suddenly, Thunderbird is blocking my logo image in my signature file in all outgoing mail.

Can you just clarify a few points: which of the following describes your problem

  1. When you click on 'Write' the signature appears but the image is not displaying - just the alternate text.
  2. When you click on 'Write', you see the correct signature and image - it's all displaying as you would expect it.
  3. After Sending - the saved email in 'Sent' folder does not display the signature image - just alternate text.
  4. The signature appearing ok when composing in Write window, but is not displaying when the recipient receives the email?

If signature appears perfectly ok when you are composing the email, but it is not displaying in the Sent folder copy and recipients cannot see it. Check your sending options. It is possible you are composing in HTML but not sending as HTML.

  • Menu icon > Settings > Composition
  • Under 'Sending Format' sub section
  • Select: 'Both HTmL and Plain Text'

Also check the settings you are using to 'View' emails. If you are using Plain Text or perhaps recipient is using Plain Text, then change it it to HTML. View > Message Body as > Original HTML


re :DA Signature.html Click on Write Did you create that 'DA Signature.html' file using the Thunderbird Write window and save as html file? Double click on image in signature to open the 'Image Properties' window. Is 'Attach this image to the message' checkbox selected?

I did two tests - I checked visibility in the webmail account as this would give a good idea what a recipient would see. Test 1: 'Attach this image to the message' checkbox NOT selected. Sent to gmail email address - image not shown in webmail account. I can only see image in my imap gmail account probably because the file link is to a folder on my computer. But if this was sent to a different person they would not see image, just a box with some alternative text.

Test 2: 'Attach this image to the message' checkbox selected. Sent to gmail email address - image shown in webmail account.

Изменено Toad-Hall

more options

This might sound silly, but can you copy the file from the machine that has no issue. Please rename the existing file before you replace it cause if this works. I really want to know why.

more options

In response to Toad-Hall, No.1 When you click on 'Write' the signature appears but the image is not displaying - just the alternate text, is what I am experiencing. I created the signature in both Libre Office - Write and Thunderbird Write but this made no difference. I even copied the signature from the second machine and saved as a html file and that didn't solve the problem. This is the file on the second machine: C:\Users\David\OneDrive\Desktop\KA Signature.html

more options

I will extend my usual offer. Send the HTML file to me and I will have a look. matt_au at gmx dot com

No promises, but I will try.

more options

In an interesting twist, if I open a template that I have previously created, the images are displayed!!

Изменено david514

more options

re : No.1 When you click on 'Write' the signature appears but the image is not displaying - just the alternate text, is what I am experiencing.

Q: Do you have this setting?

  • View > Message Body as > Original HTML

click on 'Write' Q: Do you see alternate text in an outlined box? If yes, double in the outlined box, it will open Image Properties Is this checkbox selected: "Attach this image to the message' ?

Save as draft. Go to Drafts folder and select the saved draft email so you can read in Message Pane. click on 'More' and select 'View Source' Q: Which of the following do you see in the source code?

img moz-do-not-send="false"
img moz-do-not-send="true"

Изменено Toad-Hall

more options

Answer to Q2: "Attach this image to the message" checkbox ticked.

Answer to Q3: img moz-do-not-send="false" ] Nether of these items appear in the source code

                        img moz-do-not-send="true"   ]
more options

I am still trying to get to the bottom of this problem and today I was looking in the signature selection pane. When I clicked on the signature to select, the following message was displayed.

"Some pictures were blocked to help prevent the sender from identifying your computer. Open this item to view the pictures"

It makes no sense at all! Any thoughts, please?

more options

re :"Some pictures were blocked to help prevent the sender from identifying your computer. Open this item to view the pictures"

Sounds like remote content was in the image. Thunderbird automatically blocks remote content for very obvious reasons. If you use images in your signature then ideally you need to make sure they do not contain remote content othewise any person receiving the email may not see the signature making your email look unprofessional and may even be viewed as suspicious.

Regarding the image: was the image saved in a folder on your computer? Where did you get that image ? Was it an image you copied off a webpage? If copied off webpage then it may contain remote content.

re :Answer to Q3: img moz-do-not-send="false" - Nether of these items appear in the source code img moz-do-not-send="true"

That does not sound like the html file was created using Thunderbird Write.

Have you have sent an email that contains the image to Matt ? Send one to me using the following email address - note I've written it phonetically to prevent spam bots from detecting it on this public forum, but where I've typed 'at' you replace it with the @ . Email : mail at anje dot co dot uk For Subject type : check signature

It means I can watch out for the email and see what is going on in the code.

All correspondence will be maintained in this forum for continuity.

more options

I can confirm email received. I can see that the html file you are using was created in LibreOffice. It mentions the images as a source file, but the code does not actually add those images as part of the html which explains why we cannot see them. The source view does not have the images included - eg: Content-Disposition: inline; as part of the code.

I used the image files you provided to create an example of html file.

I saved the images to a folder on computer created specifically for your case, which I will delete as soon as this problem is resolved.

Using Thunderbird 'Write' - I completely removed my signature so it was a blank fresh Write.

Rather than use a paragraph for each line I simply put it all in a Table.

  • First I created a table to hold the data. 1 columns and seven rows.
  • Entered text one section per row

I copied the text from your email to me, so it contained all the same settings eg: colour. Please note: you used font 'dubai' which is not a font on my Windows OS. Generally I would advise you should fonts that are likely to be on the majority of operating systems. eg: Arial

  • Left one row blank
  • Put cursor in last row first column
  • Then clicked on 'Insert' > 'Image'
  • Select the stored image by using 'Choose file'
  • select: 'Attach this image to the message'
  • Entered Alternate text : eg: 'Logo'
  • clicked on 'Link' tab and then entered the link to website.
  • click on OK

Selected last row and repeated the above process to enter the second image. On this image I also selected 'Appearance' tab and set spacing Left and Right to 100 pixels. As this moves the image as if central to the one above.

File > 'Save as' > 'File' Chose the special folder I created for your stuff. set filename eg: 'MySignature' Chose File Type as html clicked on Save.

For the purpose of this test, I set the account to use that saved html file. Hopefully you should see the signature below in this email.

I will attach a copy of that 'Signature.html'. If you save the file into wherever you store your signatures on computer and then set the account in Thunderbird to use it, you can then do the following.

  • click on 'Write'
  • If you see the -- delimiter sign then remove it.
  • Now double click on the first image to open the 'Image properties' window.
  • click on 'Choose file' and reselect the relevant image stored on your computer and click on open.
  • Check all the settings are the same as I've mentioned above. This should reset the file data to add the image as stored on your computer and not mine.
  • Repeat for second image.
  • Then use File > Save as > File and save.
  • Close that Write window.
  • check the Account is using correct file - the one you have just saved.
  • click on Write to open a new Write window.

Please report back on results.

more options

Thanks Toad-Hall that worked perfectly but, with a twist. I clicked on 'Write' then opened image properties and re-selected the relevant images and saved the changes as advised but, when I opened a new Write window the images did not appear! I wonder if there is something wrong with the images saved on my computer? Also baffling is why it just randomly occurred.

  1. 1
  2. 2