Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox Mac New Window Animation

  • 4 ответа
  • 1 имеет эту проблему
  • 25 просмотров
  • Последний ответ от cor-el

more options

Is there a way for the new window animation in Firefox for Mac to be disabled?

Safari does not do this, but firefox has a... ~100ms animation for new windows that's extremely frustrating for those of us who do not use tabs (Apple's Exposé/Mission Control obsoletes them).

I haven't found a configuration in about:config, although I've been able to disable a few others.

Is there a way for the new window animation in Firefox for Mac to be disabled? Safari does not do this, but firefox has a... ~100ms animation for new windows that's extremely frustrating for those of us who do not use tabs (Apple's Exposé/Mission Control obsoletes them). I haven't found a configuration in about:config, although I've been able to disable a few others.

Все ответы (4)

more options

fchickencs said

Is there a way for the new window animation in Firefox for Mac to be disabled? Safari does not do this, but firefox has a... ~100ms animation for new windows that's extremely frustrating for those of us who do not use tabs (Apple's Exposé/Mission Control obsoletes them). I haven't found a configuration in about:config, although I've been able to disable a few others.

This seems to be more of a thing on macOS and not by Firefox.

ex: https://apple.stackexchange.com/questions/14001/how-to-turn-off-all-animations-on-os-x

more options

Dropa said

I am on Windows O/S and never saw the window animation your talking about?

Because you are using Windows and not macOS.

more options

I found a way to reduce a lot of delays to zero, editing some about:config files. There was a large list, but I can't remember what exactly I followed, and I don't remember which of the many things I changed made a different and didn't.

more options

I do not know whether the ui.prefersReducedMotion pref includes this animation. You can give it a try and create a new Number pref named ui.prefersReducedMotion on the about:config page and set its value to '1'.

  • set its value to 0 if you want to see animations
  • set its value to 1 if you want to block animations

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.