Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Changing SMTP authentication to OAuth2

  • 3 ответа
  • 4 имеют эту проблему
  • 18 просмотров
  • Последний ответ от Jason

more options

I am on Thunderbird 102.5.0 (32-bit) The authentication of my University of Glasgow e-mail account has to be change to OAuth2. I have tried to do so but there is a problem. When I try to change the Outgoing Server (SMPT) from Normal Password to OAuth2, the drop menu does NOT contain the option 'OAuth2'. The 'OAuth2' option is available in the Security Settings Authentication method drop menu.

I have made the recommended checks on cookies and java script etc. They are set as instructed.

I am on Thunderbird 102.5.0 (32-bit) The authentication of my University of Glasgow e-mail account has to be change to OAuth2. I have tried to do so but there is a problem. When I try to change the Outgoing Server (SMPT) from Normal Password to OAuth2, the drop menu does NOT contain the option 'OAuth2'. The 'OAuth2' option is available in the Security Settings Authentication method drop menu. I have made the recommended checks on cookies and java script etc. They are set as instructed.

Изменено Wayne Mery

Все ответы (3)

more options

p.h.law said

a) When I try to change the Outgoing Server (SMPT) from Normal Password to OAuth2, the drop menu does NOT contain the option 'OAuth2'. b) The 'OAuth2' option is available in the Security Settings Authentication method drop menu.

Can you post a screen shot of "a" and "b"?

How old is the account definition in Thunderbird?

Полезно?

more options

FWIW, the history of oauth and smtp

Полезно?

more options

I have a similar problem with a school e-mail (outlook server) on Thunderbird 102.6.1 (64-bit), and macOS if it makes a difference. Two months ago I reconfigured my settings when the school finally implemented OAuth2, and I could send and receive e-mails once it was set up. Since then I have not reconfigured anything, but now I can only receive e-mails, not send. When I checked the SMTP Server settings, OAuth2 does not appear in the dropdown for Authentication method. When I checked the account-level Server Settings, OAuth2 is selected for the Authentication method. See the first two attached screenshots.

When sending messages, a dialog box pops up, saying:

Password Required for Outgoing (SMTP) Server smtp-mail.outlook.com Enter your password for <e-mail address> on smtp-mail.outlook.com: <text field> [] Use Password Manager to remember this password.

Neither the school password nor the OAuth2-generated saved password work (even after clearing the saved password and restarting Thunderbird to redo the OAuth2 process). Another dialog box pops up when I hit Cancel. See third screenshot.

Current workaround is to send messages through Outlook via Office 365, but I like Thunderbird and would prefer to avoid visiting Office 365 if I can.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.