Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Can't find a way to close profiler

  • 8 ответов
  • 0 имеют эту проблему
  • 23 просмотра
  • Последний ответ от cor-el

more options

While exploring about pages in Firefox, I came across about:profiling. I'm not sure what exactly it does, but since I've been to it, a profiler icon has been added to the toolbar and I can't find any way to get rid of it completely (only ways are to hide it). If it could be added, there must also be a way to remove it? How can I close it?

While exploring ''about'' pages in Firefox, I came across about:profiling. I'm not sure what exactly it does, but since I've been to it, a profiler icon has been added to the toolbar and I can't find any way to get rid of it completely (only ways are to hide it). If it could be added, there must also be a way to remove it? How can I close it?

Выбранное решение

AliceWyman said

I did some testing and the Profiler icon is added when you enable the Firefox Profiler Menu Button on the https://profiler.firefox.com page. See https://profiler.firefox.com/docs/#/./guide-getting-started If you don't get a better answer you could do one of the following to remove the Profiler icon from the Firefox Customization palette:
  • Reset Firefox preferences by deleting or renaming the prefs.js file in your Firefox profile. See Reset Firefox preferences to troubleshoot and fix problems Solution 2. This the least destructive option.
  • Refresh Firefox. See Refresh Firefox - reset add-ons and settings. This is very easy. It creates a new profile, and keeps certain basic data like bookmarks and passwords. However, a Refresh removes add-ons, preference changes and many other customizations that you may want to keep. It saves your old profile to the desktop in an "Old Firefox Data" folder, in case you want to recover some of that data .
  • Create a new Firefox profile. See Profile Manager - Create, remove or switch Firefox profiles. This is pretty easy and it keeps your original profile accessible in the Profile Manager. However, you will have to transfer any of your old data and settings you want to keep to the new profile, as explained here. Just don't transfer the prefs.js file!

Thanks for the info. It's just sad to see that there's no 'authentic' way to disable something that enables so easily.

When you mentioned the prefs.js file and that resetting it solves the problem, I immediately thought that there must surely be some specific config(s) which cause this. And sure enough, after fiddling around and disabling some configs containing the word "performance" and restarting Firefox, the profiler icon disappeared! All thanks to your answer!

Прочитайте этот ответ в контексте 👍 0

Все ответы (8)

more options

You can drag it to the Customize page. Right-click the 3 bar menu or a toolbar and select Customize Toolbar.

https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars

Изменено Terry

Полезно?

more options

Can you attach a screenshot?

Полезно?

more options

Terry said

You can drag it to the Customize page. Right-click the 3 bar menu or a toolbar and select Customize Toolbar. https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars

Yeah, I'm aware about that. That's why I said "only ways are to hide it".

Полезно?

more options

cor-el said

Can you attach a screenshot?

Полезно?

more options

I did some testing and the Profiler icon is added when you enable the Firefox Profiler Menu Button on the https://profiler.firefox.com page. See https://profiler.firefox.com/docs/#/./guide-getting-started

If you don't get a better answer you could do one of the following to remove the Profiler icon from the Firefox Customization palette:

  • Reset Firefox preferences by deleting or renaming the prefs.js file in your Firefox profile. See Reset Firefox preferences to troubleshoot and fix problems Solution 2. This the least destructive option.
  • Refresh Firefox. See Refresh Firefox - reset add-ons and settings. This is very easy. It creates a new profile, and keeps certain basic data like bookmarks and passwords. However, a Refresh removes add-ons, preference changes and many other customizations that you may want to keep. It saves your old profile to the desktop in an "Old Firefox Data" folder, in case you want to recover some of that data .
  • Create a new Firefox profile. See Profile Manager - Create, remove or switch Firefox profiles. This is pretty easy and it keeps your original profile accessible in the Profile Manager. However, you will have to transfer any of your old data and settings you want to keep to the new profile, as explained here. Just don't transfer the prefs.js file!

Изменено AliceWyman

Полезно?

more options

Выбранное решение

AliceWyman said

I did some testing and the Profiler icon is added when you enable the Firefox Profiler Menu Button on the https://profiler.firefox.com page. See https://profiler.firefox.com/docs/#/./guide-getting-started If you don't get a better answer you could do one of the following to remove the Profiler icon from the Firefox Customization palette:
  • Reset Firefox preferences by deleting or renaming the prefs.js file in your Firefox profile. See Reset Firefox preferences to troubleshoot and fix problems Solution 2. This the least destructive option.
  • Refresh Firefox. See Refresh Firefox - reset add-ons and settings. This is very easy. It creates a new profile, and keeps certain basic data like bookmarks and passwords. However, a Refresh removes add-ons, preference changes and many other customizations that you may want to keep. It saves your old profile to the desktop in an "Old Firefox Data" folder, in case you want to recover some of that data .
  • Create a new Firefox profile. See Profile Manager - Create, remove or switch Firefox profiles. This is pretty easy and it keeps your original profile accessible in the Profile Manager. However, you will have to transfer any of your old data and settings you want to keep to the new profile, as explained here. Just don't transfer the prefs.js file!

Thanks for the info. It's just sad to see that there's no 'authentic' way to disable something that enables so easily.

When you mentioned the prefs.js file and that resetting it solves the problem, I immediately thought that there must surely be some specific config(s) which cause this. And sure enough, after fiddling around and disabling some configs containing the word "performance" and restarting Firefox, the profiler icon disappeared! All thanks to your answer!

Полезно?

more options

Hey, That's great! Thanks for posting back with the solution.

Полезно?

more options

Note that the toolbar customization is stored in browser.uiCustomization.state that you can inspect on the about:config page. The value of this pref is in JSON format and you can possibly save this data to a file with the .json file extension and open this file in a Firefox tab for easier inspection and verify that the data is valid JSON in case you edit the JSON data.

{"placements":{"widget-overflow-fixed-list":[],"nav-bar":["back-button","forward-button","stop-reload-button","customizableui-special-spring1","urlbar-container","customizableui-special-spring2","save-to-pocket-button","downloads-button","fxa-toolbar-menu-button","profiler-button"],"toolbar-menubar":["menubar-items"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button"],"PersonalToolbar":["import-button","personal-bookmarks"]},"seen":["save-to-pocket-button","developer-button","profiler-button"],"dirtyAreaCache":["nav-bar","PersonalToolbar","toolbar-menubar","TabsToolbar"],"currentVersion":17,"newElementCount":2}


Изменено cor-el

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.