Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I stop Firefox from adding “HTTP” or “HTTPS” to a URL address?

  • 1 ответ
  • 0 имеют эту проблему
  • 3 просмотра
  • Последний ответ от cor-el

more options

I need to access an essential security device that has an address similar to my modem, with numbers and periods only. But Firefox consistently adds either "HTTP" or "HTTPS" to the address, so Firefox says, “Unable to connect.” I am able to access my modem page without Firefox adding anything to the address. The instructions I found (at Support.mozilla.org/en-US/kb/https-only-prefs) say to disable or insert exceptions in the “HTTPS only" option on the “Privacy and Security” section of Firefox Preferences. However, there is NO "HTTPS only" selection in my Preferences (Version 78.150esr). The other suggestion, to “Click the Lock icon in the address bar,” will not work because there is no Lock icon in the address bar with this address. I have "Use the address bar for search. . ." unchecked in the "Search" section of Firefox Preferences. I also tried unchecking “Provide search suggestions,” disabling all of my Firefox extensions, and using “non-private browsing” mode. Safari browser will not connect to this URL either. Help!

I need to access an essential security device that has an address similar to my modem, with numbers and periods only. But Firefox consistently adds either "HTTP" or "HTTPS" to the address, so Firefox says, “Unable to connect.” I am able to access my modem page without Firefox adding anything to the address. The instructions I found (at Support.mozilla.org/en-US/kb/https-only-prefs) say to disable or insert exceptions in the “HTTPS only" option on the “Privacy and Security” section of Firefox Preferences. However, there is NO "HTTPS only" selection in my Preferences (Version 78.150esr). The other suggestion, to “Click the Lock icon in the address bar,” will not work because there is no Lock icon in the address bar with this address. I have "Use the address bar for search. . ." unchecked in the "Search" section of Firefox Preferences. I also tried unchecking “Provide search suggestions,” disabling all of my Firefox extensions, and using “non-private browsing” mode. Safari browser will not connect to this URL either. Help!

Все ответы (1)

more options

Firefox always needs a protocol like http:// or https:// to access webpages. Firefox may hide the protocol in the location bar and only show the URL without the protocol (about:config => browser.urlbar.trimURLs). Older router firmware may only support the HTTP protocol and it should work if you explicitly add the http:// protocol.

Some routers support a secure connection but do not support modern TLS versions, i.e. they only support the deprecated TLS 1.0 and 1.1 protocol that are by default disabled in Firefox 78.

TLS 1.0 and TLS 1.1 are deprecated and have been disabled by default in Firefox 78+ releases. You can still enable TLS 1.0/1.1 via about:config although this is not recommended and you should only flip the pref to true when you need to access this device/website and reset the pref to false once you are done with accessing this device/website.

  • about:config => security.tls.version.enable-deprecated = true

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.