Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Secure connection failed and Firefox did not connect

  • 17 ответов
  • 1 имеет эту проблему
  • 31 просмотр
  • Последний ответ от maisie27

more options

Can anyone from firefox send me the instructions to get rid of this message. Secure connection failed and Firefox did not connect

Please avoid sending links with tons of info to read because I don't have time to follow.

Many thanks Jorge

Все ответы (17)

more options

Полезно?

more options

Thanks but it didn't help.

Полезно?

more options

Hi Jorge, we need to figure out the root of the problem.

Does the error page list a code? They often start with SEC_ERROR but whatever they say, they usually are in CAPITAL_LETTERS separated by _ characters.

Are there particular sites where you see this issue or does this problem affect all sites?

Полезно?

more options

Hello - below is copy of the error message.

Secure Connection Failed

An error occurred during a connection to emea01.safelinks.protection.outlook.com. PR_CONNECT_RESET_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Полезно?

more options

Just one more point.

Error message usually happens when I try to follow a link received by email.

Полезно?

more options

Полезно?

more options

I use bitdefender. Encrypted web scan option has been switch off with no luck.

Полезно?

more options

Hi Jorge, are you receiving the links in an external mail program like Outlook or Thunderbird, clicking the link, and loading it in Firefox -- an external link? Or is the message open in Firefox so it's considered an internal link?

A number of users have reported problems with Outlook safelinks over the years but I can't tell whether the issues are linked to settings, add-ons, service providers, or something else. For example:

Unfortunately I think you probably need to try various things to see whether they make any difference. You could take a look at your proxy setting. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy".

Any difference?

Полезно?

more options

Do you use a bookmark or are you starting with the main (home) page of this website?

If you use a bookmark to access a specific page then instead navigate to this page starting with the main page or with the sign in page in case there is a problem with this bookmark.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Полезно?

more options

I'm getting lost with all messages and links..

I tried already cleaning the history, cache, cookies, etc with no luck.

Links going on error are received by email. I use both versions of outlook app and web with the same result.

Полезно?

more options

BTW, I'm using W10 computer and see no option to say "no proxy" as suggested by jscher. You can only switch on/off the automatic detection of proxy settings. That's it. I understand you are trying to help but I'm getting confused/lost with these kind of suggestions.

Полезно?

more options

jagliano said

BTW, I'm using W10 computer and see no option to say "no proxy" as suggested by jscher. You can only switch on/off the automatic detection of proxy settings.

Actually, it's a Firefox setting. The box should look like this:

jscher2000 said

You could take a look at your proxy setting. You can check that here:
  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy". Any difference?

Полезно?

more options

Thanks jscher! - 'No Proxy' has been setup but see no differences..

Полезно?

more options

Hi Jorge, thank you for trying No Proxy. If I could summarize:

  • Links to addresses on the server emea01.safelinks.protection.outlook.com return PR_CONNECT_RESET_ERROR (server or a router/program between Firefox and the server told Firefox to stop trying to connect)
  • Both external links launched from Outlook app and internal links from Outlook on the web return the same code
  • Clearing cache and cookies did not help
  • Setting "No proxy" did not help
  • Disabling Encrypted web scan in Bitdefender did not help

If you copy/paste the link into the address bar of the Microsoft Edge browser and submit it there, can you access the link? I don't know whether you will need to log in to your Outlook account to do that.

If it works in Edge, the difference might be:

(A) Firefox and the server do not agree on connection settings (protocols, ciphers, etc.) (B) An add-on running in Firefox is interfering (C) Could a VPN be a factor? (D) Something else...

When I try a link starting with https://nam02.safelinks.protection.outlook.com/?url=[omitted] the server sends Firefox a redirect to the actual link destination. The details of that connection are:

  • Protocol version: "TLSv1.2"
  • Cipher suite: "TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384"

Both of these are very standard and don't require special settings. Unfortunately, I don't know of a way to figure out what your Firefox is offering to the server along these lines. Hopefully someone with more advanced troubleshooting skills can jump in.

Полезно?

more options

Hi jscher, Links don't work in Edge either but in Chrome. Of course, I have to do manual copy/paste of the link. Note, sth weird happened when the first link was pasted in Chrome. Initially the page was not loaded (don't remember what the message was..) but after a few minutes that page was loaded successfully. I didn't change any settings it was automatically fixed by Chrome.. (don't ask me how :D)

Полезно?

more options

I've had this message for weeks when clicking on links in Outlook (app) on my W10 laptop and the same effect but with the message 'The connection was reset' on my phone. Just tried disabling (and reenabling) extensions on the laptop and after doing this for AdBlock and then Facebook Container links were working again. Don't ask me how.

No change yet on the phone, on which I don't have any add-ons listed.

Полезно?

more options

No, it appeared to be fixed, but only temporarily. Back to square one

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.