Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox Nightly Video Playback on Fedora 33

  • 15 ответов
  • 1 имеет эту проблему
  • 49 просмотров
  • Последний ответ от Bryan Moore

more options

I've installed Nightly the same way I have for years on my latest Fedora 33 install—i.e., download tarball, extract into /opt, set appropriate chmod and chown, make .desktop file, etc.—but certain videos certain videos on certain sites refuse to play. A Fedora discussion discussion led me to think it's how Fedora 33 may sandbox apps; I haven't yet had any hits on solutions in the Fedora groups, so I thought I'd ask here, since I can't be the only one with this issue.

Any help would be greatly appreciated!

I've installed Nightly the same way I have for years on my latest Fedora 33 install—i.e., download tarball, extract into /opt, set appropriate chmod and chown, make .desktop file, etc.—but [https://www.ted.com/talks/prince_william_this_decade_calls_for_earthshots_to_repair_our_planet certain videos] certain videos on certain sites refuse to play. A Fedora [https://ask.fedoraproject.org/t/possible-firefox-nightly-sandboxing-issue/11371/4 discussion] discussion led me to think it's how Fedora 33 may sandbox apps; I haven't yet had any hits on solutions in the Fedora groups, so I thought I'd ask here, since I can't be the only one with this issue. Any help would be greatly appreciated!

Выбранное решение

Make sure you have the latest FFmpeg and libavcodec packages installed.

You can also check the Web Console for possible messages.

Прочитайте этот ответ в контексте 👍 0

Все ответы (15)

more options

It works for me. Have you tried it in safe mode. I just downloaded Nightly, extracted it, made a shortcut on my desktop. Do you have any issues with YouTube? KDE or Gnome?

Operating System: openSUSE Tumbleweed 20210101 KDE Plasma Version: 5.20.4 KDE Frameworks Version: 5.77.0 Qt Version: 5.15.2 Kernel Version: 5.10.3-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Изменено jonzn4SUSE

more options

Thanks for checking in, @jonzn4SUSE...

I have tried it in safe mode, without success; YouTube plays just fine, as do several other sites. No love for TED and a few others.

I really wonder if this is due to some of Fedora's sandboxing features; e.g., openH264 is installed as a flatpak, although that shouldn't matter as Nightly seems to ship with it's own openH264.

Изменено Bryan Moore

more options

KDE or Gnome. Does it work in the distro current version of Firefox?

Изменено jonzn4SUSE

more options

Sorry, I meant to include it was GNOME.

The distro version (84.0.1-2.fc33) works fine.

more options

Interesting... Maybe try downloading it again and just extract and run it. Can you also post a screenshot of the issue?

more options

Did that a couple of times...

more options

What if you download it and try to play it?

more options

Plays fine in Videos when downloaded.

Изменено Bryan Moore

more options

.....

Изменено jonzn4SUSE

more options

Yeah, looking like more of a Gnome / Ubuntu issue. Just for kicks, if you feel like testing... switch to KDE and see what happens.

more options

It can't be an Ubuntu issue, since I'm on Fedora, and I'm not sure being on GNOME would make any difference; however, I'm becoming more and more convinced it's a quirk of Fedora's new sandboxing.

Thanks, anyway, @jonzn4SUSE...

Изменено Bryan Moore

more options

LMAO.... Ubuntu on the brainu.  ;-))

more options

No worries... It's extra-comical to me because I started my Linux journey with Ubuntu (back in the good ol' Warty days) and used it up until about two or three years ago. :-)

more options

Выбранное решение

Make sure you have the latest FFmpeg and libavcodec packages installed.

You can also check the Web Console for possible messages.

more options

Didn't even think to check libavcodec, @cor-el, and that was it; installing "GStreamer Multimedia Codecs - libav" fixed things.

Thanks a ton!