Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Image upload issue: blank image

  • 9 ответов
  • 1 имеет эту проблему
  • 117 просмотров
  • Последний ответ от cor-el

more options

When uploading images in some web sites (such as web.whatsapp.com and others) the image is uploaded but it is blank/white, even if I visit the site with another browser I see only a blank image. When uploading to the same web site using other browser, for example Chrome, the image uploading has no issues and it is displayed correctly. I've already tried to disable the AdBlocker but nothing changes.

When uploading images in some web sites (such as web.whatsapp.com and others) the image is uploaded but it is blank/white, even if I visit the site with another browser I see only a blank image. When uploading to the same web site using other browser, for example Chrome, the image uploading has no issues and it is displayed correctly. I've already tried to disable the AdBlocker but nothing changes.

Выбранное решение

Hello Masss,

Would you try this please :

Type or paste in the address bar   about:config  and press Enter
(ignore the warning)

Type or paste in the search bar :

privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts

and set its value to   false


If you get a permissions prompt asking to allow HTML5 canvas image data :

Click   "Allow"


Any luck ?

Прочитайте этот ответ в контексте 👍 1

Все ответы (9)

more options

I've forgot: I use Firefox 77.0.1 but the proble arose with previous versions too.

more options

Did you check with the website's support?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link}
by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh).
Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks FredMcD. I tried all your suggestions but the problem still persists.

more options
more options

It is possible that (anti-virus) security software is causing the problem.
Try to disable security software temporarily to see if that makes a difference.

more options

I tried, no change...

more options

Выбранное решение

Hello Masss,

Would you try this please :

Type or paste in the address bar   about:config  and press Enter
(ignore the warning)

Type or paste in the search bar :

privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts

and set its value to   false


If you get a permissions prompt asking to allow HTML5 canvas image data :

Click   "Allow"


Any luck ?

more options

Probably a redundant remark, but if allowing HTML5 canvas image data does the trick, then the preference on the   "about:config"   page can keep its default value of   "true".

more options

Do you see the canvas notification icon () on the location bar when this happens ?

  • chrome://browser/skin/notification-icons/canvas.svg