Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox opening .aspx with "in-browser" pdf reader instead of installed reader

  • 2 ответа
  • 1 имеет эту проблему
  • 41 просмотр
  • Последний ответ от NickLandis

more options

My work just updated my computers. On the old computers, if I download a .aspx file from a website (something I do frequently for my job) the file would open in my installed pdf reader (Foxit PhantomPDF - Version: 9.2.0.9297). On the new computers, the .aspx file opens in the Firefox "in-browser" pdf reader. The filetype .pdf is set to automatically open in Foxit, but there is no .aspx filetype available in the applications list of Firefox preferences. Does anyone know a away to force firefox to open a certain filetype (like .aspx) with a certain program?

For reference, my old computers were Lenovos. I had a tower running windows 7 and a laptop running windows 10. Both behaved correctly where the .aspx file would open automatically (or at least ask) in Foxit. The new computers are Dells. Again a tower and a laptop. Both are running windows 10 and both are behaving the same way where .aspx files open in the firefox "in-browser" pdf reader.

Выбранное решение

evhenry said

You want aspx files to open in foxit and not firefox pdf viewer, right? Right click the file you want to open in foxit and click "Open with..." then "Choose another app" and navigate to your foxit.exe and check the box "always open with this file type" Unless I'm misunderstanding your problem. Let me know.

Thank you for your reply. I think there may have been some miscommunication, but I believe the problem may be resolved anyway.

I think what resolved it was I opened an actual .pdf file (not .aspx) which automatically prompted me with the dialog box asking if I wanted to open it in Foxit, or if I just wanted to save it. I selected open in foxit, and "always do this from now on" and that seemed to make firefox open .aspx files that way too.

Not really sure why it wasn't doing that in the first place, but for now it seems it may be resolved

Прочитайте этот ответ в контексте 👍 0

Все ответы (2)

more options

You want aspx files to open in foxit and not firefox pdf viewer, right?

Right click the file you want to open in foxit and click "Open with..." then "Choose another app" and navigate to your foxit.exe and check the box "always open with this file type"

Unless I'm misunderstanding your problem. Let me know.

more options

Выбранное решение

evhenry said

You want aspx files to open in foxit and not firefox pdf viewer, right? Right click the file you want to open in foxit and click "Open with..." then "Choose another app" and navigate to your foxit.exe and check the box "always open with this file type" Unless I'm misunderstanding your problem. Let me know.

Thank you for your reply. I think there may have been some miscommunication, but I believe the problem may be resolved anyway.

I think what resolved it was I opened an actual .pdf file (not .aspx) which automatically prompted me with the dialog box asking if I wanted to open it in Foxit, or if I just wanted to save it. I selected open in foxit, and "always do this from now on" and that seemed to make firefox open .aspx files that way too.

Not really sure why it wasn't doing that in the first place, but for now it seems it may be resolved