Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

language selector from the right-click menu doesn't print out correctly the language name

  • 4 ответа
  • 2 имеют эту проблему
  • 12 просмотров
  • Последний ответ от mauro.trevisan

more options

The language selector menu from the right-click menu doesn't print out correctly the language name of the spellchecker dictionary.

I have installed the venetan dictionary (language code ISO639-3 vec) I've created (https://addons.mozilla.org/en-US/firefox/addon/dithionario-de-lengua-v%C3%A8neta/?src=ss) but in the right-click menu appears the language "vec" alongside my default "English (United States)". Why doesn't it spell out "Venetan"? Is there something I did wrong?

Приложенные скриншоты

Выбранное решение

I filed a bug to Bugzilla@Mozilla for that.

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

No, I think that that is OK and expected behavior The names of the dictionary files are vec.dic and vec.aff as you can see and that is what you see in the Language sub menu.

more options

I don't think that your response is the right one. I, for example, installed the Catalan dictionary (https://addons.mozilla.org/en-US/firefox/addon/general-catalan-dictionary/) and it displays Catalan even if its files are ca.aff and ca.dic. However, surprisingly, your answer worked: I renamed my files into Venetan.aff and Venetan.dic and it displays "venetan". Anyway I would like it to be internationalized. However, I wonder why the Catalan works and why, renaming my files with a capital V, I then see the language with a small v...

Изменено mauro.trevisan

more options

From https://developer.mozilla.org/en-US/docs/Mozilla/Creating_a_spell_check_dictionary_add-on : "The .dic and .aff files must be placed in a subfolder named dictionaries within the ZIP file. Both files must have the locale code as their file name." May be because Firefox lacks my language?

Изменено mauro.trevisan

more options

Выбранное решение

I filed a bug to Bugzilla@Mozilla for that.