Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

1 or 2 weeks ago the behaviour of opening PDF changed (settings: open with adobe acrobat in firefox), now some PDF will only download without any other option.

  • 4 ответа
  • 3 имеют эту проблему
  • 28 просмотров
  • Последний ответ от charles2014

more options

Plugins: Adobe Acrobat Reader is set to "Always active" Options/Applications: PDF are set to open with Adobe Acrobat Reader (in Firefox)

Before (1 or 2 weeks ago): some PDF opened directly in the browser. For others a dialog box appeared, giving me the choice to either save or open the file. If I chose to open, it opened in the normal Adobe Reader (that's still OK, but why do they not all open in the browser?)

Now: what I described above still works with the integrated viewer (i.e. when I change settings to "Preview in Firefox"). With the Adobe plugin, PDF that opened automatically in the browser still do, for the others I don't even get the dialog box. They are just being saved and that's it. How can this be changed?

Все ответы (4)

more options

Sometimes when data about a file is sent, it does not give the correct label. And sometimes, there are is then one label for the same file type. The next time you get the what to do question, look for a Always Do This option and turn it on.

On a personal note; Unless the file changes over time, it would be better to save the file, and open it later. This way you don't have to download it again.

more options

I don't get the "what to do" question at all in the case I described. The problem seems not to be the file itself. It looks like it depends on where (from which site) I'm trying to open the file from. For example, when I want to open a PDF attachment in Yahoo-mail (or any other mail server) or other sites it doesn't open. But if I open the downloaded file In Firefox from my computer it works.

more options

Ahh, an attachment. Open the settings on your e-mail provider. This may be the cause. If not;


Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

more options

I already tried that. And the e-mail providers don't have anything to be set about it. Anyway I didn't change any of my settings. The issue just occured one day. And only with PDF (application set to open with adobe acrobat in firefox). So maybe the problem lies in the Adobe plugin? (which I re-installed without changing anything by doing it). Everything works as it should and always did with other files (.docx etc.)

Изменено charles2014