Решение проблем с такими плагинами как Flash или Java для решения типичных проблем Firefox

Если у вас возникли проблемы со страницами, использующими плагины (такие как Flash, Java и другие) для отображения содержимого, вам может понадобиться проверить, не лежит ли причина возникшей проблемы в плагине.

Типичными проблемами, вызываемые плагинами, являются:

Эта статья рассказывает, как решить проблемы с плагинами. Если у вас возникли проблемы с расширениями или темами, прочтите статью Устранение проблем с расширениями, темами и аппаратным ускорением для решения типичных проблем в Firefox. Для получения общей информации о плагинах прочтите статью Использование плагинов для проигрывания аудио, видео, игр и многого другого.

Определение, лежит ли проблема в плагине

Вы можете выборочно отключать плагины при запущенном Firefox. Если вы подозреваете определённый плагин, сначала отключите его, а затем проверьте наличие вашей проблемы. Если вы не знаете, какой плагин нужно отключить:

  1. В верхней части окна Firefox щёлкните по кнопке FirefoxВ панели меню щёлкните по меню ИнструментыВ верхней части окна Firefox щёлкните по меню Инструменты, и затем щёлкните по Дополнения. Будет открыта вкладка Управление дополнениями. Щёлкните по кнопке меню New Fx Menu и выберите Дополнения для открытия вкладки Управление дополнениями.

  2. Выберите плагин из списка и нажмите кнопку Отключить. Повторите этот шаг для каждого плагина в списке, пока все они не будут отключены. Вам не нужно перезапускать Firefox, чтобы изменения вступили в силу.
  3. Проверьте наличие вашей проблемы. Если она не проявляется, вернитесь в менеджер дополнений и включайте плагины по одному кнопкой Включить, каждый раз проверяя наличие проблемы, до тех пор, пока не найдёте, какой из них её вызывает.
  1. В верхней части окна Firefox щёлкните по кнопке FirefoxВ панели меню щёлкните по меню ИнструментыВ верхней части окна Firefox щёлкните по меню Инструменты, и затем щёлкните по Дополнения. Будет открыта вкладка Управление дополнениями. Щёлкните по кнопке меню New Fx Menu и выберите Дополнения для открытия вкладки Управление дополнениями.

  2. Выберите плагин в списке и выберите в выпадающем меню Никогда не включать. Повторите этот шаг для каждого плагина в списке, пока все они не будут отключены. Вам не нужно перезапускать Firefox, чтобы изменения вступили в силу.
  3. Проверьте наличие вашей проблемы. Если она не проявляется, вернитесь в менеджер дополнений и включайте плагины по одному, выбирая в выпадающем меню Всегда включать, каждый раз проверяя наличие проблемы, до тех пор, пока не найдёте, какой из них её вызывает.

Если вы обнаружили, что отключение плагина решило вашу проблему, следуйте дальнейшим инструкциям в статье.

Обновление или переустановка ваших плагинов

Многие проблемы с плагинами могут быть решены обновлением плагина до последней версии.Чтобы проверить, актуальны ли версии установленных у вас плагинов, посетите страницу проверки и обновлений плагинов от Mozilla.

Если обновление до новой версии плагина или его переустановка не устранила проблему, вы можете снова отключить плагин.

Удаление плагина вручную

Если вы не можете использовать программу деинсталляции для удаления плагина, вы можете удалить его вручную:

  1. В панели адреса, наберите about:config и нажмите EnterReturn.

    • Может появится страница предупреждения about:config "Будьте осторожны, а то лишитесь гарантии!". Щелкните по Я обещаю, что буду осторожен!, чтобы перейти на страницу about:config.
  2. Найдите параметр plugin.expose_full_path.
  3. Дважды щёлкните по параметру plugin.expose_full_path в списке, чтобы изменить его значение на true.
  4. Наберите about:plugins в панели адреса и нажмите EnterReturn для отображения страницы Включённые плагины.
  5. У каждого плагина на странице Включённые плагины есть строка "Файл:" с путём к файлу. Используйте Проводник Windows, чтобы перейти вПерейдите в папку, отображаемую в пути плагина, который вы хотите удалить.
  6. Переименуйте указанный файл, добавив Х впереди имени файла (например npswf32 в Xnpswf32).
  7. Дважды щёлкните по параметру plugin.expose_full_path в списке на странице about:config, чтобы изменить его значение назад на false и избежать раскрытия пути к плагину веб-сайтам.

Плагин будет удалён.

Если вы не можете использовать программу деинсталляции для удаления плагина, вы можете удалить его вручную:

  1. Наберите about:plugins в панели адреса и нажмите EnterReturn для отображения страницы О плагинах.
  2. У каждого плагина на странице О плагинах есть строка "Файл:" после которой указано имя плагина. Вы можете проверить содержимое файла "pluginreg.dat" (в текстовом редакторе), расположенного в вашей папке профиля Firefox, чтобы найти расположение каждого плагина. Используйте проводник Windows, чтобы перейти вПерейдите в папку, указанную для плагина, который вы хотите удалить.
  3. Переименуйте указанный файл, добавив Х впереди имени файла (например npswf32 в Xnpswf32).

Плагин будет удалён.

Если вы не можете использовать программу деинсталляции для удаления плагина, вы можете удалить его вручную:

  1. Наберите about:plugins в панели адреса и нажмите EnterReturn для отображения страницы О плагинах.
  2. У каждого плагина на странице О плагинах есть строки "Файл:" и "Путь:", указывающие имя и расположение файла плагина. Используйте проводник Windows, чтобы перейти вПерейдите в папку, указанную для плагина, который вы хотите удалить.
  3. Переименуйте указанный файл, добавив Х впереди имени файла (например npswf32 в Xnpswf32).

Плагин будет удалён.

Переинициализация базы плагинов

В некоторых случаях вам не удастся установить или переустановить плагин. Переинициализация базы плагинов может решить эту проблему:

  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Удалите файл pluginreg.dat.
  6. Откройте Firefox
  7. Наберите в панели адреса about:plugins и нажмите EnterReturn для отображения списка плагинов Firefox.



Поделиться этой статьей: http://mzl.la/NYtGci

Помогла ли эта статья? Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, na_PaLm, harrierr. Вы тоже можете помочь - узнайте как.