Работа с закладками и журналом невозможна

Эта статья относится к Firefox 3.5 или более поздней версии. Если у вас возникли проблемы с вашими закладками в Firefox 3.0.x, прочтите статью Bookmarks and toolbar buttons not working after upgrading.

Вы видите это сообщение об ошибке при запуске Firefox?

Работа с закладками и журналом невозможна, так как один из файлов Firefox используется другим приложением. Данную проблему могут вызывать некоторые из защитных программ

Это происходит, когда Firefox не может получить доступ к файлу places.sqlite, содержащему ваши закладки и историю. В этой статье описаны два возможных решения.

Если вы не видите описанную выше ошибку, попробуйте прочесть одну из этих статей:

Решение 1: Перезапустите ваш компьютер

Наиболее распространенной причиной этой ошибки является использование этого файла другой программой или проблема с файлом, который был вызвана внезапным отключением компьютера (например при пропадании питания). Хорошей новостью является то, что в большинстве случаев простая перезагрузка компьютера и перезапуск Firefox приведет к решению обоих проблем.

Решение 2: Создание новой базы данных библиотеки

Если перезагрузка компьютера не решила проблему, вы можете исправить её, заставив Firefox создать для вас новую базу данных библиотеки. Не волнуйтесь, это не так сложно, как кажется.

Часть 1 - Открытие вашей папки профиля

В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  • В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  • Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.
    Оставьте папку профиля открытой - перейдите к части 2.

    Часть 2 - Создание базы данных

    1. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

      Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

      Подождите полного закрытия Firefox.
    2. В папке профиля Firefox, найдите и переименуйте файл places.sqlite и, если он существует, файл places.sqlite-journal.
      • Чтобы переименовать файл, щёлкните по нему правой кнопкой мыши и выберите из меню Переименоватьщёлкните по нему один раз, чтобы его выбрать, а затем щёлкните второй раз по имени файла, чтобы сделать его редактируемым. Затем добавьте в конец его имени .old.
      • Когда вы снова откроете Firefox, он создаст новую базу данных библиотеки. Ваш журнал посещений исчезнет, но Firefox автоматически импортирует ваши закладки из самой последней резервной копии.
      • Если ваши закладки не были восстановлены после создания новой базы данных библиотеки, попробуйте выполнить действия, описанные в статье Восстановление пропавших или отсутствующих закладок.

    Помогите! Это не решило проблему.

    Эта проблема имеет симптомы, схожие с рядом других проблем. Может быть одна из этих статей лучше опишет вашу проблему.



    Поделиться этой статьей: http://mzl.la/LLcerE

    Помогла ли эта статья? Пожалуйста, подождите...

    Следующие хорошие люди помогли написать эту статью: Unghost. Вы тоже можете помочь - узнайте как.