Не могу добавлять, изменять или сохранять закладки - Как исправить

Эта статья покажет, что делать, если вы не можете добавлять новые закладки или вносить другие изменения в свои закладки.

Примечание: Если вы смогли сохранить закладки, но они в настоящее время отсутствуют, прочтите статью Восстановление пропавших или отсутствующих закладок.

Я не могу добавлять или изменять закладки

Если вы не можете добавлять новые закладки, или если изменения, внесенные в панель инструментов, не сохраняются после перезапуска Firefox, прочтите статью Не сохраняются изменения в панели инструментов и размеров окна.

Если вы не можете добавлять новые закладки или вносить другие изменения в свои закладки, и у вас установлено расширение Firefox связанное с закладками (например расширение, синхронизирующее закладки), следуйте инструкциям в статье Устранение проблем с расширениями, темами и аппаратным ускорением для решения типичных проблем в Firefox, чтобы определить, является ли расширение причиной проблемы.

Я могу добавлять или изменять закладки, но они теряются после перезапуска мною Firefox

Если вы можете добавлять, удалять, пересортировывать и вносить другие изменения в закладки, но ваши изменения теряются после перезапуска вами Firefox, попробуйте выполнить следующие действия.

Примечание: Мы рекомендуем вам отключить все расширения, связанные с закладками, как объяснено здесь, прежде чем использовать решения предлагаемые ниже.

Почините файл Закладок

Если ваши изменения в закладках не отображаются после перезапуска вами Firefox, проблема может быть в том, что ваш файл закладок защищен от записи. Защищенный от записи файл не может быть изменен, что не позволяет Firefox сохранить любые сделанные вами изменения.

Разрешите Firefox сохранять изменения в закладках:

  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Щёлкните правой кнопкой мыши по файлу places.sqlite и выберите Свойства, чтобы открыть окно Свойства.
  6. В окне Свойства выберите вкладку Общие. В нижней части окна, убедитесь, что флажок Только чтение НЕ установлен.

    bookmarksnotsaved-readonly.png

Чтобы разрешить запись в ваш файл закладок:

  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Выберите файл places.sqlite.
  6. В строке меню выберите меню Файл и выберите Свойства. Откроется окно информации о файле places.sqlite.
  7. В окне информации о файле places.sqlite снимите флажок с поля Защита.

Создайте новый файл Закладок

Закладки и история посещенных страниц хранятся в папке профиля Firefox в файле places.sqlite. Если с этим файлом возникла проблема, то изменения в ваших закладках могут быть утеряны после перезапуска вами Firefox. Вы можете заставить Firefox создать ещё один файл places.sqlite, удалив существующий.

Возможно, вы захотите распечатать эти инструкции или скопировать их, чтобы им следовать, так как вам нужно будет закрыть Firefox для удаления этих файлов.

Внимание: После удаления файла places.sqlite вы потеряете всю историю посещённых вами страниц.
  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. В вашей папке профиля удалите файл places.sqlite и, если он существует, файл places.sqlite-journal.
  6. (Необязательно) Также удалите файл localstore.rdf. Это приведет к сбросу всех сделанных вами настроек панели инструментов.

Firefox создаст новый файл places.sqlite и автоматически импортирует самый последний резервный файл закладок. Ваши закладки будут сохранены, но вы потеряете историю посещённых вами страниц.




Основано на информации с Bookmarks not saved (mozillaZine KB)



Поделиться этой статьей: http://mzl.la/ON1mdk

Помогла ли эта статья? Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, harrierr. Вы тоже можете помочь - узнайте как.