X
Apasă aici pentru a merge la versiunea mobilă a site-ului.

Forum de asistență

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

Font rendering issue in Windows 7 with Aero

Postat

I'm running Windows 7 Home Premium 64-bit, and using Firefox 19.0.2. Aero is enabled, but the ClearType font smoothing is turned off.

At completely random intervals, text is rendered like this in Firefox: http://i49.tinypic.com/vgshv4.png

Sometimes it can be fixed as simply as hovering the mouse pointer over the affected parts. Sometimes I have to mark the text to get it rendered correctly, and sometimes it can be fixed by scrolling the page.

It can happen on any sites with any encoding, regardless of the font size and color, but I noticed it's extremely rarely happens with Japanese text. It never affects the whole page, only random parts of the on-screen text, and sometimes the interface text as well. Also worth mentioning that it never happens when Aero is turned off.

Is this a Firefox bug, or is something wrong with my system? Thanks in advance.

I'm running Windows 7 Home Premium 64-bit, and using Firefox 19.0.2. Aero is enabled, but the ClearType font smoothing is turned off. At completely random intervals, text is rendered like this in Firefox: http://i49.tinypic.com/vgshv4.png Sometimes it can be fixed as simply as hovering the mouse pointer over the affected parts. Sometimes I have to mark the text to get it rendered correctly, and sometimes it can be fixed by scrolling the page. It can happen on any sites with any encoding, regardless of the font size and color, but I noticed it's extremely rarely happens with Japanese text. It never affects the whole page, only random parts of the on-screen text, and sometimes the interface text as well. Also worth mentioning that it never happens when Aero is turned off. Is this a Firefox bug, or is something wrong with my system? Thanks in advance.

Alte detalii despre sistem

Pluginuri instalate

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02

Aplicație

  • Agent utilizator: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

Mai multe informații:

iamjayakumars 489 soluții 5951 răspunsuri

Try to disable hardware acceleration in Firefox.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/
cor-el
  • Top 10 Contributor
  • Moderator
17333 soluții 156710 răspunsuri

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled. *http://kb.mozillazine.org/about:config

Deținătorul întrebării

Thank you all, but unfortunately, none of these have solved the issue.

When hardware acceleration is disabled, all the web page text looks terrible, and the interface text is barely readable.

Setting gfx.content.azure.enabled to false fixes the text problem, but introduces various other graphical glitches.

Setting gfx.direct2d.disabled to true has the same effect as disabling hardware accceleration.

My graphics drivers are up to date, and I use the default theme. The only extension I have is AdBlock Plus, and nothing changes if I remove or disable it.

Thank you all, but unfortunately, none of these have solved the issue. When hardware acceleration is disabled, all the web page text looks terrible, and the interface text is barely readable. Setting gfx.content.azure.enabled to false fixes the text problem, but introduces various other graphical glitches. Setting gfx.direct2d.disabled to true has the same effect as disabling hardware accceleration. My graphics drivers are up to date, and I use the default theme. The only extension I have is AdBlock Plus, and nothing changes if I remove or disable it.
iamjayakumars 489 soluții 5951 răspunsuri

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.''
johndoe678 0 soluții 2 răspunsuri

Răspuns util

I had the same issue, uninstalling windows update kb2670838 fixed it for me. See also: http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/text-rendering-issues-in-firefox-after-installing/1aaefaec-ba47-4577-82c3-44b72a50049b

Răspuns util

Thanks very much, johndoe678! It solved the problem.

And of course, thank you all for your replies!

Thanks very much, johndoe678! It solved the problem. And of course, thank you all for your replies!